Hi, everybody, I try to support this discussion telling you about my experience.
I tried to install the last Novell Client from Novell site. I dowloaded novell-client-2.0-sp2-patch2-sle11-x86_64.iso, mounted and installed using YAST.
I created a symbolic link libbfd-2.19.so, required by novell-xtier-base rpm, from /usr/lib64/libbfd-2.21.1.so.
After installation, I tried to restart novfsd service but it exited with code status=1. Here's the /var/log/messages highlight:
Code:
Mar  2 10:56:29 novfsd[4978]: Starting Novell novfs daemon...
Mar  2 10:56:29 novfsd[4978]: FATAL: Module novfs not found.
Mar  2 10:56:30 novfsd[4978]: FATAL: Module novfs not found.
Mar  2 10:56:30 novfsd[4978]: mount: unknown filesystem type 'novfs'
Mar  2 10:56:30 novfsd[4978]: /etc/init.d/novfsd: line 108: /dev/stderr: No such device or address
Mar  2 10:56:30 novfsd[4978]: ..failed
I think the trouble is that novfs.ko is missing. In fact there isn't any novfs.ko file in /lib/modules subdirs.

I have a similar problem in a another pc with OpenSuse 11.4 installed.
Before I updated from kernel version 2.6 to 3.2, Novell client works perfectly. I copied novfs.ko from /lib/modules/2.6.37.6-0.11-xen/kernel/fs/novfs/novfs.ko to /lib/modules/3.2.8-1-desktop/kernel/fs/novfs/novfs.ko.
Code:
modprobe -l |grep -i nov
kernel/drivers/media/dvb/dvb-usb/dvb-usb-nova-t-usb2.ko
kernel/fs/novfs/novfs.ko
If I try:
Code:
modprobe -v novfs
insmod /lib/modules/3.2.8-1-desktop/kernel/fs/novfs/novfs.ko 
FATAL: Error inserting novfs (/lib/modules/3.2.8-1-desktop/kernel/fs/novfs/novfs.ko): Invalid module format
Launching dmesg and seeing system log:
Code:
[10270.817407] novfs: disagrees about version of symbol module_layout
It's seems that the kernel objetc wasn't compiled for 3.2 kernel. If I search for additional info:
Code:
modinfo novfs
filename:       /lib/modules/3.2.8-1-desktop/kernel/fs/novfs/novfs.ko
version:        2.0.0-440
description:    Novell NetWare Client for Linux
author:         Novell Inc.
license:        GPL
srcversion:     B24DD0F7AEF683E6FC86AB3
depends:        
vermagic:       2.6.37.6-0.11-xen SMP mod_unload modversions Xen 686
Any ideas? Thank you in advance!