Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: IR-LV2 concolution

  1. #1
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    584

    Default IR-LV2 concolution

    I am trying to install LV2 convolution on opensuse 11.4 x86_64
    IR: LV2 Convolution Reverb | Factorial Enterprises

    But I keep getting this error.
    Can somebody help me out with this.

    anton@linux:~/Downloads/ir.lv2-1.3.1> make
    g++ ir.cc -Wall -I. -I/usr/include `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gthread-2.0` -D__STDC_FORMAT_MACROS -O2 -ffast-math -D_HAVE_GTK_ATLEAST_2_20 -c -fPIC -o ir.o
    ir.cc: In function ‘void free_conv_safely(Convproc*)’:
    ir.cc:168:9: error: ‘class Convproc’ has no member named ‘check’
    ir.cc: In function ‘void init_conv(IR*)’:
    ir.cc:561:23: error: no matching function for call to ‘Convproc::start_process(int)’
    /usr/local/include/zita-convolver.h:414:9: note: candidate is: int Convproc::start_process(int, int)
    make: *** [ir.o] Fout 1
    anton@linux:~/Downloads/ir.lv2-1.3.1>

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: IR-LV2 concolution

    Please use CODE tags around yourcomputer text: http://forums.opensuse.org/english/i...ags-guide.html

    When I read this, you are trying to build it, not to install it.
    Henk van Velden

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: IR-LV2 concolution

    On 2012-02-25 15:06, anton wrote:

    > But I keep getting this error.
    > Can somebody help me out with this.


    You may ask in the programming forum, but to me it looks a problem specific
    to that package.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  4. #4
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    584

    Default Re: IR-LV2 concolution

    Sorry I could not edit the post anymore for using code tags.
    saw it too late

    Readme shows this:

    Compiling and installing
    ------------------------

    If you have the above dependencies installed, a 'make' and (as root)
    'make install' is all you need to use the plugin. The LV2 plugin
    bundle is installed under /usr/lib/lv2/ by default (please edit the
    Makefile to suit your needs if this is not what you want).

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: IR-LV2 concolution

    Yes, the README is an important item here as there is no "standard" way people are making these sorts of things.

    Then there does not seem to be a make config as first action.

    I am afraid that only somebody who did this earlier can comment on this. Best would be to go to the developers of the product. They know what their expectations where when they composed the whole thing.

    BTW your title may not help you to attrackt people who did this build earlier. because of the typo you made there
    Henk van Velden

  6. #6
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    584

    Default Re: IR-LV2 concolution

    Got the answer form IR
    I Need zita-convolver 2.0 installed, that's the version that
    IR needs to work.
    There is a newer version of zita-convolver (3.x) that is not backwards
    compatible with IR.LV2 1.2 or 1.3

    Problem is I cannot find zita-convolver 2.0 for 64 bits ?

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: IR-LV2 concolution

    No idea where to find it. Maybe a new thread with title "Need zita-convolver 2.0" in e.g. the Looking for something other then support subforum may help.
    Henk van Velden

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: IR-LV2 concolution

    Am 25.02.2012 17:36, schrieb anton:
    >
    > Got the answer form IR
    > I Need zita-convolver 2.0 installed, that's the version that
    > IR needs to work.
    > There is a newer version of zita-convolver (3.x) that is not backwards
    > compatible with IR.LV2 1.2 or 1.3
    >
    > Problem is I cannot find zita-convolver 2.0 for 64 bits ?
    >
    >

    Download the source for the version 3
    http://kokkinizita.linuxaudio.org/li...-3.1.0.tar.bz2
    its only 21 kB and open the AUTHORS file it contains the email address
    of the author (I am reluctant to post a mail address to a public list),
    contact him and ask where to find the code for the old version.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
    nVidia ION | 3GB Ram

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: IR-LV2 concolution

    On 2012-02-25 17:56, hcvv wrote:
    >
    > No idea where to find it. Maybe a new thread with title "Need
    > zita-convolver 2.0" in e.g. the Looking for something other then support
    > subforum may help.


    Google does find it in several distros.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  10. #10
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    584

    Default Re: IR-LV2 concolution

    I know but not for openSuse 11.3 or 11.4 x86_64.
    Actually I am looking for a ir-lv2 package.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •