Results 1 to 6 of 6

Thread: YAST error "Error while creating client module sw_single"

  1. #1

    Default YAST error "Error while creating client module sw_single"

    Hi,

    Last night my system was running fine and I got a pop-up from the update manager to update something(do not remember what). Once the update completed it sseems to have broken Yast nd Zypper.

    Now whenever I open Yast and select any module I am getting an error message. Following is the one if I select "Software Management" : Error while creating client module sw_single.

    In terminal I typed "zypper" and I am getting the following error: "zypper: error while loading shared libraries: /usr/lib64/libzypp.so.1003: file too short".

    Can anyone please help me fix this as I am not able to use Yast to install any further packages.

    Regards,
    Prad

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: YAST error "Error while creating client module sw_single"

    Tried a reboot yet?

    Create a folder in your homedir "rpmzypp"
    Download libzyp, zypper from Index of /update/12.1 to that folder (highest version numbers, you need the .rpm files)
    Open a terminal window and do:
    Code:
    cd ~/rpmzypp
    su -c 'rpm -iUvh *rpm'
    (enter rootpassword)
    That reinstalls zypper and libzypp. Next run
    Code:
    su -c 'zypper ref'
    (enter rootpassword)
    and report here what's happening.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YAST error "Error while creating client module sw_single"

    On 02/23/2012 04:36 PM, Prad viking wrote:

    > broken Yast nd Zypper.


    if you can, please show us the terminal input/output from:

    Code:
    zypper lr -d
    cat /etc/SuSE-release
    rpm -qa | tail --lines=20

    --
    DD
    What does DistroWatch write about YOU?: http://tinyurl.com/SUSEonDW

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YAST error "Error while creating client module sw_single"

    On 02/23/2012 05:17 PM, DenverD wrote:
    >
    Code:
    > zypper lr -d
    > cat /etc/SuSE-release
    > rpm -qa | tail --lines=20
    >


    i could not see Knurpht's post when i posted....so, ignore mine...

    --
    DD
    What does DistroWatch write about YOU?: http://tinyurl.com/SUSEonDW

  5. #5

    Default Re: YAST error "Error while creating client module sw_single"

    Worked like a charm.

    Zypper & Yast both fixed and working now.

    Thanks a ton.

    PS: could you also let me know what the problem was and what this fix exactly did?

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: YAST error "Error while creating client module sw_single"

    On 2012-02-23 18:06, Prad viking wrote:
    > PS: could you also let me know what the problem was and what this fix
    > exactly did?


    The reboot? Known feature of unix like filesystems, a file is not actually
    deleted if it is in use by something. That something was using versions of
    libraries from before the update, and had some kind of conflict with some
    other updated library. Or file, or whatever.

    Try running "zypper ps" after any update.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •