Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: kde crash prevents shutdown

  1. #1

    Default kde crash prevents shutdown

    Hello

    Very frequently, I get a kde crash when I decide to shutdown my laptop running OS12.1.
    The crashed instances are various kde tools, but mostly it is kdeinit4.
    It opens a window to report a bug. This window must be waiting for input and prevents the laptop from shutting down.
    Most of the time I am already gone and the machine keeps running till the next morning. This is especially annoying when it runs on battery.

    Does anybody know how to prevent these crash popups?

    thanks

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: kde crash prevents shutdown

    Quote Originally Posted by serengeti View Post
    Hello

    Very frequently, I get a kde crash when I decide to shutdown my laptop running OS12.1.
    The crashed instances are various kde tools, but mostly it is kdeinit4.
    It opens a window to report a bug. This window must be waiting for input and prevents the laptop from shutting down.
    Most of the time I am already gone and the machine keeps running till the next morning. This is especially annoying when it runs on battery.

    Does anybody know how to prevent these crash popups?

    thanks
    I found the following link with an explanation and abash script file to run. It might be worth a try to see if it helps.

    Automating knotify4 notifications (stopping popup alerts) • KDE Community Forums

    Of course its not normal to see such problems, but we would need to know more about what the popups say is wrong.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: kde crash prevents shutdown

    I have this exact same problem 90% of the time that I shutdown. My 12.1 install is a fresh installation and I had this problem also on 11.4 which was also a fresh installation. Other folks are experiencing this too. See:

    http://forums.opensuse.org/english/g...gging-out.html

    I think its a bug of some sort.

    Gordon

  4. #4
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: kde crash prevents shutdown

    I have submitted an OpenSUSE bug report here:

    https://bugzilla.novell.com/show_bug.cgi?id=749017

    Also, there are several KDE bug reports already submitted regarding this issue including the following two bug reports:

    https://bugs.kde.org/attachment.cgi
    https://bugs.kde.org/show_bug.cgi?id=282081

    So, those of you that are also experiencing this problem may want to add a comment to these bug reports.

    FYI,

    Gordon

  5. #5

    Default Re: kde crash prevents shutdown

    Thanks for the help.

    It seems I am facing that same kde bug.

    I found a workaround. I added:
    Code:
    export KDE_DEBUG=1
    to
    ~/.bashrc

    If I understand correctly, this will disable Dr.Konqi

    Development/FAQs/Debugging FAQ - KDE TechBase

    So far it worked...

  6. #6
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: kde crash prevents shutdown

    Hi serengeti,

    export KDE_DEBUG=1
    That appears to be working for me too.....

    Thanks!

    Gordon

  7. #7

    Default Re: kde crash prevents shutdown

    I suffered from this bug too. I upgraded KDE to 4.7.4 and it fixed the problem.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  8. #8

    Default Re: kde crash prevents shutdown

    Yes I know, KDE4.7.4 solved this problem, but how did you do this?

  9. #9

    Default Re: kde crash prevents shutdown

    Quote Originally Posted by amadrits View Post
    Yes I know, KDE4.7.4 solved this problem, but how did you do this?
    I'm not 100% sure what you're asking. I assume you mean how did I upgrade to KDE4.7.4?

    If so, then you need to add the following repository to YAST: Index of /repositories/KDE:/Release:/47/openSUSE_12.1

    Then select that repository and choose "switch system packages to the version in this repository". It'll perform the upgrade. You may need to go back to the packman repos and switch some of the multimedia files back to packman.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  10. #10

    Default Re: kde crash prevents shutdown

    I added the repository Index of /repositories/KDE:/Release:/47/openSUSE_12.1 to YAST, but I did not find where to choose "switch system packages to the version in this repository" in openSUSE 12.1.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •