Results 1 to 10 of 10

Thread: Truecrypt - Error: mount: you must specify the filesystem type

  1. #1

    Default Truecrypt - Error: mount: you must specify the filesystem type

    Hi there,

    here you are my last instance - I have been trying to solve it in truecrypt forum, also in google but I havent found any solution and tc forum is mostly sleeping.

    So my problem:

    I have file which encrypted by truecrypt. It has two volumes - visible, hidden. To mount visible volume, there is no problem. When I try to mount hidden volume, I get "Error: mount: you must specify the filesystem type".

    I was trying to mount with option --filesystem=none, it seems it is mounted but I cant find it anywhere although I specify mount point. The volumes are in vfat.

    Please, any idea how to correct and get data?

    Thank you,

    Martin

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,057

    Default Re: Truecrypt - Error: mount: you must specify the filesystem type

    On Tue, 03 Jan 2012 19:26:02 +0000, atilius wrote:

    > Hi there,
    >
    > here you are my last instance - I have been trying to solve it in
    > truecrypt forum, also in google but I havent found any solution and tc
    > forum is mostly sleeping.
    >
    > So my problem:
    >
    > I have file which encrypted by truecrypt. It has two volumes - visible,
    > hidden. To mount visible volume, there is no problem. When I try to
    > mount hidden volume, I get "Error: mount: you must specify the
    > filesystem type".
    >
    > I was trying to mount with option --filesystem=none, it seems it is
    > mounted but I cant find it anywhere although I specify mount point. The
    > volumes are in vfat.


    If it's vfat, you can't use --filesystem=none, because then you're
    telling it it doesn't have a filesystem.

    What happens if you mount it using the GUI application (or is it a
    headless server?)

    Jim




    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3

    Default Re: Truecrypt - Error: mount: you must specify the filesystem type

    Hello Jim,

    if I use GUI I just get the message "Error: mount: you must specify the filesystem type " so I have been trying to search for another way - for hidden volume. For visible it works correctly.
    And on one Gentoo´s website was the way how to mount it manually with this option. And if I do it so I can list all mounted devices and it shows me that my hidden disc is mounted in slot 1 but I cant find mount point, nor with mount point specified in options of truecrypt command.

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,057

    Default Re: Truecrypt - Error: mount: you must specify the filesystem type

    On Wed, 04 Jan 2012 05:16:02 +0000, atilius wrote:

    > Hello Jim,
    >
    > if I use GUI I just get the message "Error: mount: you must specify the
    > filesystem type " so I have been trying to search for another way - for
    > hidden volume. For visible it works correctly.
    > And on one Gentoo´s website was the way how to mount it manually with
    > this option. And if I do it so I can list all mounted devices and it
    > shows me that my hidden disc is mounted in slot 1 but I cant find mount
    > point, nor with mount point specified in options of truecrypt command.


    So let me see if I understand correctly - you have a setup that has a
    hidden volume and a standard (outer) volume. The outer volume mounts
    fine, but the hidden volume doesn't.

    Have you mounted the outer volume and written data to it without
    protecting the hidden volume from damage? If you did this (and didn't
    protect the hidden volume from damage), then it's possible you overwrote
    some critical data in the hidden volume that's preventing the hidden
    volume from mounting.

    I've used truecrypt a little bit myself, and what you describe sounds to
    me like damage to the hidden volume.

    Jim


    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5

    Default Re: Truecrypt - Error: mount: you must specify the filesystem type

    You understand well....I copied some files to standard volume - I hadnt idea I should protect hidden volume....

    Any chance to correct hidden volume and get at least some data?

  6. #6
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,164

    Default Re: Truecrypt - Error: mount: you must specify the filesystem type

    I have Truecrypt & I can tell you from personal experience it's gone!
    I'm just a curious cat
    My 64 bit: RADEON RX 570 |CPU AMD - Ryzen 5 1600
    MOTHERBOARD B450M D53H GGABYTE
    Opensuse Tumbleweed Plasma 5

  7. #7
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,057

    Default Re: Truecrypt - Error: mount: you must specify the filesystem type

    On Thu, 05 Jan 2012 06:56:03 +0000, atilius wrote:

    > You understand well....I copied some files to standard volume - I hadnt
    > idea I should protect hidden volume....


    Yeah, that's the only way to ensure the hidden volume isn't overwritten
    when the outer volume is modified.

    > Any chance to correct hidden volume and get at least some data?


    If you backed up the hidden volume header then there's a chance you might
    be able to recover some data - otherwise, the chances are so low as to be
    nonexistent. The beauty of encrypted filesystems is that there isn't a
    backdoor. The problem with encrypted filesystems is that if the
    information used to encrypt the filesystem is corrupted, there's no
    backdoor to be able to recover any of your data.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  8. #8

    Default Re: Truecrypt - Error: mount: you must specify the filesystem type

    I have in my mind only not publicable words.... and for this no backup .... in any case, thanks for your help.

  9. #9
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,057

    Default Re: Truecrypt - Error: mount: you must specify the filesystem type

    On Thu, 05 Jan 2012 18:46:02 +0000, atilius wrote:

    > I have in my mind only not publicable words.... and for this no backup


    Understood completely - this is one reason I haven't used truecrypt for
    partitions in general at this stage, just for USB flash drives and the
    occasional file "container".

    > ... in any case, thanks for your help.


    Glad I could at least get you to the end of the issue, even though the
    outcome wasn't desirable. Having lost data myself, I know what you're
    going through....

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  10. #10

    Default Re: Truecrypt - Error: mount: you must specify the filesystem type

    Hi,
    Run your installed copy of TrueCrypt. The application version must match the driver version.

    It sounds like you installed 6.0a, and have the USB key set up with a traveler copy of TrueCrypt, which is what you double clicked on. Thats what produced the error.

    Start the TC application installed on your system (start menu shortcut or whatever) then attempt to mount the TC container on the USB stick and you should be just fine.

    Truecrypt error: Truecrypt cannot be opened | Techyv.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •