Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Copying is very very CPU intensive

  1. #1

    Default Copying is very very CPU intensive

    Hi,

    I just switched from Windows to OpenSUSE, and my problem is the following:
    Copying is very cpu intensive, the kworker processes starts to use the whole cpu capacity and my system become unresponsive. If I copy with mc, it uses too a lot of cpu with the kworkers, but if I copy with Krusader, Krusader's cpu usage is ok (but not the kworkers!).
    When I copy (from one dir to another in the same drive) with Krusader I can see that the transfer rates sometimes goes up in my system irrealy high 60-70MB/s, and sometimes go down to real 20-30MB/sec, and to stalling(!?).

    (running badblocks is not cpu intensive, it uses 8% and the kworkers are 0-1%).

    I'm using OpenSUSE 12.1, kernel 3.1.9-1.4-desktop x86_64, KDE 4.7.2.
    I'm using lvm encrypted volumes.

    I tried the kernel-desktop-3.1.10~jng3-3.x86_64 without any luck.

    I have a HP 8510p notebook, with Intel(R) Core(TM)2 Duo T9300 @ 2.50GHz, and 8GB RAM.

    What can I do, what can be wrong, and how can I fix it?
    If you can, please help.

    Thank you forward,

    atskler

    (sorry for my poor English)

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Copying is very very CPU intensive

    On 2012-02-19 00:56, atskler wrote:

    > I just switched from Windows to OpenSUSE, and my problem is the
    > following:


    Is the source or the destination of your copy one of your old windows
    partitions? The ntfs driver is very much cpu intensive.

    Another possibility is that i/o on your disk is not using DMA.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3

    Default Re: Copying is very very CPU intensive

    I'm using lvm encrypted volumes.
    using encryption will be slow
    And on a notebook with one drive it will be very slow



  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Copying is very very CPU intensive

    On 2012-02-19 02:16, JohnVV wrote:
    >> > I'm using lvm encrypted volumes.
    >> >

    > using encryption will be slow


    True, I missed that. Encryption needs cpu power.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5

    Default Re: Copying is very very CPU intensive

    First, thank you for the answers:

    To: #2 / robin_listas
    I know that the ntfs driver is cpu intensive.
    But I copied from ext4 partition to ext4 partition, and now from an external ext4 to my internal ext4.

    DMA: I hdparmed my disks and I see the following, and if I'm right with DMA everything is OK.


    >>> Internal sata disk: /dev/sda:

    Model=ST9320423AS, FwRev=0002SDM1, SerialNo=5VJ1JDYW
    Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
    RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
    BuffType=unknown, BuffSize=16384kB, MaxMultSect=16, MultSect=16
    CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=625142448
    IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
    PIO modes: pio0 pio1 pio2 pio3 pio4
    DMA modes: mdma0 mdma1 mdma2
    UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
    AdvancedPM=yes: unknown setting WriteCache=enabled
    Drive conforms to: unknown: ATA/ATAPI-4,5,6,7

    * signifies the current active mode

    Timing cached reads: 10748 MB in 1.99 seconds = 5393.46 MB/sec
    Timing buffered disk reads: 248 MB in 3.00 seconds = 82.58 MB/sec


    >>> External esata disk with pcmcia adapter: /dev/sdb:

    Model=WDC WD10EURS-630AB1, FwRev=80.00A80, SerialNo=WD-WCAV5P255694
    Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
    RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=50
    BuffType=unknown, BuffSize=unknown, MaxMultSect=16, MultSect=off
    CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=1953525168
    IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
    PIO modes: pio0 pio3 pio4
    DMA modes: mdma0 mdma1 mdma2
    UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5 udma6
    AdvancedPM=yes: unknown setting WriteCache=enabled
    Drive conforms to: Unspecified: ATA/ATAPI-1,2,3,4,5,6,7

    * signifies the current active mode

    Timing cached reads: 7554 MB in 2.00 seconds = 3786.22 MB/sec
    Timing buffered disk reads: 180 MB in 3.02 seconds = 59.57 MB/sec



    To: #3 / JohnVV
    Concerning encryption: in Windows I used Truecrypt to encrypt my whole system, and I never experienced such high cpu usage when I copied something, even if I copied to an another external Truecrypt encrypted storage. I think my CPU is strong enough to calmly handle this kind of operations, at least in Windows with … I never really noticed that I'm encrypted under Windows.

    And I think if I'm right, the disk encryption should be done by kcryptd and kcryptd_io but they do nothing.

    ---

    Addendum:
    I copied from my external ext4 pcmcia esata drive to my internal ext4 sata drive, and I do some top and iotop measurements. Please inspect not only the top and iotop indications, inspect the copy process window too (MiB/s, stalled, paused etc.).
    Please note that I can't capture really high cpu or system load because my system in this state unresponsive.

    Measurement screenshots are here – hi res. images:
    dbg - top, iotop



    Thank you forward for your further help.

  6. #6

    Default Re: Copying is very very CPU intensive

    The mc cp measurements. Same results.: > mc-cp <

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Copying is very very CPU intensive

    On 2012-02-19 16:46, atskler wrote:
    >
    > First, thank you for the answers:
    >
    > To: #2 / robin_listas
    > I know that the ntfs driver is cpu intensive.
    > But I copied from ext4 partition to ext4 partition, and now from an
    > external ext4 to my internal ext4.
    >
    > DMA: I hdparmed my disks and I see the following, and if I'm right with
    > DMA everything is OK.


    Ok.

    > Timing buffered disk reads: 248 MB in 3.00 seconds = 82.58 MB/sec


    So, your hardware is capable.


    (next time, please use code tags to post such text. Advanced editor, # button).


    > To: #3 / JohnVV
    > Concerning encryption: in Windows I used Truecrypt to encrypt my whole
    > system, and I never experienced such high cpu usage when I copied
    > something, even if I copied to an another external Truecrypt encrypted
    > storage. I think my CPU is strong enough to calmly handle this kind of
    > operations, at least in Windows with … I never really noticed that I'm
    > encrypted under Windows.


    Nor me in Linux, but things can change.

    > Measurement screenshots are here – hi res. images:
    > 'dbg - top, iotop' (http://atskler.net/dbg/)


    So, you are using krusader for the copy. There have been reports of slow
    response while using kde for copy operations. I think you have seen the thread.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  8. #8

    Default Re: Copying is very very CPU intensive

    > So, you are using krusader for the copy. There have been reports of slow
    > response while using kde for copy operations. I think you have seen the thread.


    Yes, and I tried mc and cp with the same results - under KDE Terminal if it matters. You can check it in: #6

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Copying is very very CPU intensive

    On 2012-02-19 23:06, atskler wrote:
    > Yes, and I tried mc and cp with the same results - under KDE Terminal
    > if it matters. You can check it in: #6


    Then try in text mode (ctrl-alt-f1), outside of kde. Even better, before
    you log into kde.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  10. #10

    Default Re: Copying is very very CPU intensive

    > Then try in text mode (ctrl-alt-f1), outside of kde. Even better, before
    > you log into kde.


    Tried. I started my system without xdm, KDE. The situation is exactly the same.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •