Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: ./configure problem

  1. #1

    Default ./configure problem

    A library that is there is not getting recognized. I might be that it is in a in /usr/lib64 because am on 64 bit. How do I direct ./config to it? Thanks

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,076

    Default Re: ./configure problem

    On Fri, 17 Feb 2012 22:26:02 +0000, verticals wrote:

    > A library that is there is not getting recognized. I might be that it is
    > in a in /usr/lib64 because am on 64 bit. How do I direct ./config to it?
    > Thanks


    What specifically are you trying to do, and what software are you trying
    to build?

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3

    Default Re: ./configure problem

    On SuSE 11.4 and need webkit 1.6 for xxxterm to use vim type commands. SuSE 12.1 has it, and I was well into compiling webkit, lots of deps were added OK, and even though I do have libsoup 2.4 it says I don't. Not clear on how to tell ./configure to find it and I know it is possible.

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,076

    Default Re: ./configure problem

    On Fri, 17 Feb 2012 22:46:02 +0000, verticals wrote:

    > On SuSE 11.4 and need webkit 1.6 for xxxterm to use vim type commands.
    > SuSE 12.1 has it, and I was well into compiling webkit, lots of deps
    > were added OK, and even though I do have libsoup 2.4 it says I don't.
    > Not clear on how to tell ./configure to find it and I know it is
    > possible.


    Is it libwebkit3 you're looking to build? I found a downloadable RPM in
    the 11.4 GNOME 3.2 stable repo, you might look at that and see if it
    meets your needs rather than building it from scratch.

    If you still want to build, did you install the libsoup 2.4 devel package?

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5

    Default Re: ./configure problem

    Yes have all the dev stuff for libsoup. Will take a look at libwebkit3 and see if it works. Question is it in the SuSE repos under 11.4?

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,076

    Default Re: ./configure problem

    On Fri, 17 Feb 2012 23:16:03 +0000, verticals wrote:

    > Yes have all the dev stuff for libsoup. Will take a look at libwebkit3
    > and see if it works. Question is it in the SuSE repos under 11.4?


    I did a search at software.opensuse.org/search and selected the option to
    include everything - then searched on webkit and "1.6" and it turned up a
    few hits.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  7. #7

    Default Re: ./configure problem

    No, that isn't what I need - been with SuSE for 20 years and even when one has the most recent release it doesn't give one fresh stuff. Think it might be time to move to something like Arch. Sorry for the rant and this detail holds up a big project. Sigh ... Thanks for trying.

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: ./configure problem

    xxxterm is available here
    http://download.opensuse.org/reposit.../openSUSE_11.4
    libwebkitgtk3 is available here (version 1.6)
    http://download.opensuse.org/reposit...openSUSE_11.4/

    when your configure says it cannot find libsoup you have to check
    configure.log what really is the problem often enough configure scripts
    give completely misleading messages and what you miss really is a
    library which is needed to compile a test programm configure uses to see
    if the library is supported.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
    nVidia ION | 3GB Ram

  9. #9

    Default Re: ./configure problem

    martin_helm, thank you - have xxxterm running. It's a great compliment to vim and my WM spectrwm. The lightest and fastest tiling WM I've ever used. The vimyist

    Regarding the configure stuff, didn't know, (remember), how to deal with it. (am 70 and so what, hugh) Again thanks.

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: ./configure problem

    Am 18.02.2012 02:36, schrieb verticals:
    >
    > martin_helm, thank you - have xxxterm running. It's a great compliment
    > to vim and my WM spectrwm. The lightest and fastest tiling WM I've ever
    > used. The vimyist


    I am not sure if you say your problem is solved now but it sounds like
    that and I am happy your xxxterm works.

    >
    > Regarding the configure stuff, didn't know, (remember), how to deal
    > with it. (am 70 and so what, hugh) Again thanks.
    >
    >

    Just in case you run at some time again into a similar problem when
    trying to compile a software you can post the content of the following
    files to susepaste.org and post the links here

    config.log
    config.status

    that way helpers can see what really happens in your configure process.


    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
    nVidia ION | 3GB Ram

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •