Results 1 to 6 of 6

Thread: Wlan Schnittstelle (AR5001/Fujitsu Esprimo V6535) deinstalliert sich nach "Tiefschlaf"

  1. #1
    Join Date
    May 2011
    Location
    Südwest D
    Posts
    7

    Default Wlan Schnittstelle (AR5001/Fujitsu Esprimo V6535) deinstalliert sich nach "Tiefschlaf"

    Ich habe o.g. Notebook bis Dezember mit Suse 11.4 betrieben.
    Wlan eingerichtet traditionell mit ifup, Wlan-Schnittstelle "hot plugged" und "eingewählt" mit KInternet.
    Seit Installation von Suse 12.1 verschwindet die Schnittstelle aus dem KInternet Auswahlmenu, wenn ich die Internetverbindung trenne und/oder den Rechner nicht komplett ausschalte, sondern in "Tiefschlaf" schicke. Schalte ich den Rechner dann wieder an, zeigt mir KInternet nur noch dsl0 als Schnittstelle und ich muss über Yast - Netzwerkdienste - die Wlan-Schnittstelle erneut installieren ..
    Starte ich neu oder fahre den Rechner komplett runter und boote neu, ist die Schnittstelle da und lässt sich auch korrekt ansprechen.

    Was übersehe ich?

    LG
    CAT

  2. #2
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    507

    Default Re: Wlan Schnittstelle (AR5001/Fujitsu Esprimo V6535) deinstalliert sich nach "Tiefschlaf"

    Manche Kernelmodule hängen sich beim Tiefschlaf auf und müssen neu geladen
    werden. Versuch mal rauszufinden, wie das Kernelmodul für deine Hardware
    heißt. (lsmod zeigt alle geladenen Module an)

    Mit
    ----
    modprobe -r <modul>
    modprobe <modul>
    ----
    kannst du das Modul dann neu laden.

  3. #3
    Join Date
    May 2011
    Location
    Südwest D
    Posts
    7

    Default AW: Re: Wlan Schnittstelle (AR5001/Fujitsu Esprimo V6535) deinstalliert sich nach "Tiefschlaf"

    Herzlichen Dank - das hat gleich beim ersten Versuch funktioniert!
    Nur .. das sollte natürlich nicht wirklich ein Dauerzustand sein, dass ich das Modul jedes Mal starte, da es ja unter 11.4 ohne Probleme ging.
    Noch eine Idee .. oder zwei .. oder drei ?

    VG
    CAT

  4. #4
    Siegfried Richter NNTP User

    Default Re: Wlan Schnittstelle (AR5001/Fujitsu Esprimo V6535) deinstalliertsich nach "Tiefschlaf"

    Am 19.02.2012 16:46, schrieb Katzemit9leben:
    >
    > Herzlichen Dank - das hat gleich beim ersten Versuch funktioniert!
    > Nur .. das sollte natürlich nicht wirklich ein Dauerzustand sein, dass
    > ich das Modul jedes Mal starte, da es ja unter 11.4 ohne Probleme ging.
    > Noch eine Idee .. oder zwei .. oder drei ?
    >
    > VG
    > CAT
    >
    >

    Hallo Katze,

    ich hatte ein ähnliches Problem, hier sollte nach dem Systemstart der
    Samba-Server neu gestartet werden.
    Das habe ich mit Hilfe einer "Crontab" gelöst.
    In Deinem Fall würde ich mir folgende Krücke bauen:

    Erstelle eine Systemcrontab über das Terminalprogramm -->
    su crontab -e

    Du landest dann im Editor "Vi"
    Hier folgendes einfügen -->

    @reboot modprobe -r <modul>;modprobe <modul>

    Zeile mit ENTER abschließen und danach ESC (um den INSERT Mode zu verlassen.
    Dann ":wq" (write & quit) und ENTER um die Crontab zu speichern.

    Hoffe es funktioniert.





    --
    Gruß Sigi

  5. #5
    Siegfried Richter NNTP User

    Default Re: Wlan Schnittstelle (AR5001/Fujitsu Esprimo V6535) deinstalliertsich nach "Tiefschlaf"

    Am 19.02.2012 18:28, schrieb Siegfried Richter:

    > [..]
    > @reboot modprobe -r <modul>;modprobe <modul>
    > [..]


    Habe mir Dein Problem nicht bis zum Ende durchgelesen.
    Du schreibst, dass nach einem Rechnerneustart wieder alles funktionieren
    würde.
    Mit dem o.a. Crontab Befehl würdest Du nach dem Reboot des Rechners das
    Modul neu laden, was zu diesem Zeitpunkt nicht nötig ist.

    Entschuldige meine vorschnelle Antwort.


    --
    Gruß Sigi

  6. #6
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    507

    Default Re: Wlan Schnittstelle (AR5001/Fujitsu Esprimo V6535) deinstalliert sich nach "Tiefschlaf"

    Trag folgende Zeile in die Datei /etc/pm/config.d/modules.config ein:

    -----
    SUSPEND_MODULES="<modulname>"
    -----

    Wobei <modulname>, der Name des Kernelmodules ist.

    Ich musste erst wieder raus suchen, wie die Datei hieß. Sonst wäre der
    Hinweis gleich beim ersten mal gekommen ;-)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •