Results 1 to 6 of 6

Thread: 12.1: Emacs takes exceptionally long time to launch

  1. #1
    Join Date
    Feb 2012
    Posts
    10

    Default 12.1: Emacs takes exceptionally long time to launch

    Hi does anybody encounter this same issue?

    openSUSE 12.1 x86-64 KDE, fully updated. VMs on Latest versions of VirtualBox and VMWare Workstation.

    Emacs 23.3-6.1 installed. It takes 18~20 seconds to launch. removing emacs-x11 and trying emacs-nox, almost same. Trying Xemacs, some improvement --- it takes around 15 seconds to launch. Then I tried 24.0.93 from /repositories/home:/AndreasSchwab/12.1, both x11/nox, not much difference.

    Generally I am quite impressed on the application-friendliness and openness of openSUSE 12.1 for experimenting with new programming features: GCC 4.6.2 and Clang/LLVM 3.0 out-of-box, Google Chrome beta (18.0.1025.33) and Oracle JDK 1.7.0_03 by installing the rpm packages downloaded directly from their websites, and following the instruction http://forums.opensuse.org/english/g...a-dafault.html (post #2 by lenwolf) I got Oracle JDK to function as default properly. So far so good ... only to the point that I started to edit my programs - with Emacs. It works fine, just as expected. The only issue is that it takes exceptionally, 15~20 seconds are really really EXCEPTIONALLY long time to launch. g++/clang++/java/javac/vim all launch instantly, even the GUI Google Chrome.

    Emacs launches almost instantly on all major Linux Distros that I have success VMed them, and FreeBSD/PC-BSD 9.0, and Windows 7 x64, both real and VMed. AND, I just finished VMing openSUSE 12.2 Milestone1, getting emacs installed (still 23.3-6.1), launching it ... ALMOST INSTANTLY!

    I don't know why but it must be a peculiar issue present specifically in the generally pleasing openSUSE 12.1 (what about previous versions?).

    Any idea? Any suggestion?

  2. #2
    Join Date
    Feb 2012
    Posts
    10

    Default Re: 12.1: Emacs takes exceptionally long time to launch

    upgrade to KDE 4.8, reboot and reinstall Emacs 24.0.93, ---> same behavior.

    It still takes 18~20 seconds for Emacs to appear. No difference whether launching in GUI or text mode.

    What's the matter?

  3. #3

    Default Re: 12.1: Emacs takes exceptionally long time to launch

    I have exactly the same problem!

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 12.1: Emacs takes exceptionally long time to launch

    On 02/29/2012 12:06 AM, senand wrote:
    >
    > I have exactly the same problem!


    for reference: with xemacs removed, emacs 23.2-7.4 problem not seen on
    openSUSE 11.4 with KDE4.6.0 either launching into GUI or CLI...

    with my (puny) Atom the X version is up in about 2.5 seconds and the CLI
    less than one second..

    but, i did have a problem with the install...because with xemacs already
    installed and putting emacs in later it seemed to want to tie into the
    pre-existing xemacs configs...but, emacs didn't do that well and
    complained about being unable to blah blah blah (and open its own configs)..

    since i'd just read (in the factory mail list) that xemacs is being
    dropped for 12.2, i uninstalled both it and emacs and then (using
    locate) purged the entire system of all traces of both emacs and xemacs..

    once done, i used YaST to instal emacs (and emacs-nox, emacs-x11) and
    while all complaints ceased (opening speed remained as expected, that
    is, with both installed it opened and complained quickly!)..

    my /home now has only an /.emacs.d, while the previous (troublesome)
    system had both ~/.emacs and ~/.xemacs, and locate turns up not a single
    instance of "xemacs"

    to me, it seems a good call to banish xemacs from 12.2 (and my 11.4) and
    you may like the results of cleaning it out of 12.1 also..

    then again, your launch speed problem my be associated (somehow) with
    systemd, or any of the many changes in kernel and other things since
    11.4, so ymmv!

    --
    DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
    http://tinyurl.com/DD-Software
    What does DistroWatch write about YOU?: http://tinyurl.com/SUSEonDW

  5. #5
    Join Date
    Feb 2012
    Posts
    10

    Default Re: 12.1: Emacs takes exceptionally long time to launch

    I don't know why you have xemacs preloaded on pre-12.1 versions. In 12.1 and 12.2 Factory/Milestone neither emacs nor xemacs are preinstalled.

    My "official" experience with openSUSE started with 12.1 last November when they touted LLVM/Clang 3.0 and latest Chromium, 17 (or 16?) at that time (though now I know Chromium != Google Chrome and I always prefer Google Chrome, dev channel). With minimal prior experience with UNIX/Linux I learned everything myself: setting up VMware and VirtualBox VMs, getting Clang-3.0/gcc-4.6 installed, and figuring out how to install and configure Oracle JDK7 and Google Chrome dev, so far so good, really impressed on the all-green KDE desktop and enjoy working in the all-black terminal --- no scroll barred, no menued, no bordered, wow it's so wonderful! Only to the point when I started to launch emacs ...

    And as I reported in my last post, 12.2 Milestone1 didn't have this issue. Emacs launched instantly, not almost instantly, but instantly! I decided to move on and never look back. However, at the very early days of Milestone1, it had some issue with repos not properly configured. I followed some advice on the web and got my system messed up, some packman.inode.at repo error persisted even though I had corrected my repo configuration.

    Today I tried the newest Factory 0207build: http://download.opensuse.org/factory...0207-Media.iso on VirtualBox and was really impressed on the no-brain and almost automated installation process. After fully updated the system, and a no scroll-barred, no menued, no bordered terminal configured, I 'zypper install emacs' and then 'emacs -nw HelloC++.cpp'. Wow! Emacs launched instantly, AND THE TERMINAL FREEZED, or CRASHED to be more accurately. I had to right-click on the panel icon to close the terminal. I tried several times, including restarting the system - same syndrome.

    I think openSUSE 12.x really has some issue with Emacs. For the past few months I had tried quite a couple of systems, only openSUSE 12.1 and today's 0207 Factory build didn't get on with Emacs.

    Please, openSUSE'ers, get this Emacs issue fixed, and fixed forever, on all future openSUSE builds. 12.2 seems to be quite promising, and overall I really enjoy this open (less restrictive on installing non-open-source packages) and beautiful platform. Don't get stumbled by this 'minor' inconvenience.

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 12.1: Emacs takes exceptionally long time to launch

    On 03/01/2012 03:16 PM, nmof wrote:
    > Please, openSUSE'ers, get this Emacs issue fixed, and fixed forever, on
    > all future openSUSE builds. 12.2 seems to be quite promising, and
    > overall I really enjoy this open (less restrictive on installing
    > non-open-source packages) and beautiful platform. Don't get stumbled by
    > this 'minor' inconvenience.
    >


    wrong forum for this discussion on pre-released software...your problem
    with 12.1 can continue here, but 12.2 problems are discussed with the
    other testers, in http://tinyurl.com/2du7r4s

    and, discussing it there does little to get the issue fixed--but see
    there if others can duplicate your problems and if so then log the bug,
    to http://tinyurl.com/nzhq7j

    --
    DD
    What does DistroWatch write about YOU?: http://tinyurl.com/SUSEonDW

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •