Results 1 to 4 of 4

Thread: OpenSUSE 12.1 upgrade doesn't work with ATI RADEON HD 4550

  1. #1
    Join Date
    Nov 2008
    Location
    France
    Posts
    17

    Default OpenSUSE 12.1 upgrade doesn't work with ATI RADEON HD 4550

    Hello,

    I've upgraded from OpenSUSE 11.3 to 12.1 three days ago.

    I've reinstalled flgrx drivers (Catalyst 11.3 or 12.1) with severals methods (AMD Drivers, Please_try_again repository, geeko.ioda.net repository) and I get a black screen at startup with the mouse waiting cursor, but no login. (SDB:ATI drivers - openSUSE, SDB:Configuring graphics cards - openSUSE)

    I've tried to boot with nomodeset, whith failsafe or Desktop falsafe, nothing worked.

    I've set NO_KMS_IN_INITRD to yes.

    If I try to stop xdm service, then startx, I can login in Itarc graphical interface.

    Has anyone some example of xorg.conf file that works in OpenSUSE 12.1 ? Mine has not been changed from OpenSUSE 11.3.

    Some ideas ?

  2. #2
    Join Date
    Jun 2008
    Location
    Windhoek, NAMIBIA
    Posts
    42

    Default Re: OpenSUSE 12.1 upgrade doesn't work with ATI RADEON HD 4550


  3. #3

    Default Re: OpenSUSE 12.1 upgrade doesn't work with ATI RADEON HD 4550

    Quote Originally Posted by chocho63 View Post
    Hello,

    I've upgraded from OpenSUSE 11.3 to 12.1 three days ago.
    This could explain half of the problem.


    Quote Originally Posted by chocho63 View Post
    I've reinstalled flgrx drivers (Catalyst 11.3 or 12.1) with severals methods
    And this could explain the other half.

    Quote Originally Posted by chocho63 View Post
    I've set NO_KMS_IN_INITRD to yes.
    If kms is present in initial ramdisk, it will be disabled by the installation script of the fglrx package (whether it was generated by atiupgrade or installed from a repo). Thus, this is not needed.


    Quote Originally Posted by chocho63 View Post
    Has anyone some example of xorg.conf file that works in OpenSUSE 12.1 ? Mine has not been changed from OpenSUSE 11.3.
    Then rename it and run:
    Code:
    aticonfig --initial
    (provided you have the ATI proprietary driver installed and the fglrx module for your kernel is present).

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenSUSE 12.1 upgrade doesn't work with ATI RADEON HD 4550

    On 2012-02-14 19:56, please try again wrote:
    >
    > chocho63;2440172 Wrote:
    >> Hello,
    >>
    >> I've upgraded from OpenSUSE *11.3 to 12.1* three days ago.
    >>

    >
    > This could explain half of the problem.


    We do not know yet what procedure he used to upgrade. Please OP, tell.

    One method I like is to install on another small partition an 12.1 fresh
    and see how it works. If all is well there, the configuration can be copied.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •