Page 1 of 6 123 ... LastLast
Results 1 to 10 of 53

Thread: Firefox 10 IcedTea crash

  1. #1
    Join Date
    Mar 2009
    Location
    Bangkok
    Posts
    431

    Default Firefox 10 IcedTea crash

    I've updated my 12.1 Xfce with "zypper up" today and got Firefox 10.0, now it crashes every time I visit my broker's site that requires Java and Iced Tea plugin.

    This is very unfortunate as Firefox was the only browser that worked on that site and the only browser that works on Linux.

    Reinstalling IcedTea doesn't help.

    What could I do now? Can I rollback Firefox? Uninstall from Yast then download .rpm and install it? Wouldn't it mess my default system settings as I believe FF is a bit more than just another package.

    Or could I install older Firefox in my home directory as some .bin file or something? Need it working by tomorrow.

  2. #2
    Vahis NNTP User

    Default Re: Firefox 10 IcedTea crash

    Stan Ice wrote:
    >
    > I've updated my 12.1 Xfce with "zypper up" today and got Firefox 10.0,
    > now it crashes every time I visit my broker's site that requires Java
    > and Iced Tea plugin.


    What site is that?
    I would like to see if it works here.
    >
    > This is very unfortunate as Firefox was the only browser that worked on
    > that site and the only browser that works on Linux.


    Sounds like a special site.
    >
    > Reinstalling IcedTea doesn't help.
    >
    > What could I do now? Can I rollback Firefox? Uninstall from Yast then
    > download .rpm and install it? Wouldn't it mess my default system
    > settings as I believe FF is a bit more than just another package.
    >
    > Or could I install older Firefox in my home directory as some .bin file
    > or something? Need it working by tomorrow.
    >


    Give the URL of the site.

    Vahis
    --
    http://waxborg.servepics.com
    openSUSE 11.4 (x86_64) 2.6.37.6-0.11-default main host
    openSUSE 12.1 (x86_64) 3.2.4-6-desktop Tumbleweed in VirtualBox
    openSUSE 12.1 (i586) 3.1.9-1.4-desktop in EeePC 900

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Firefox 10 IcedTea crash

    On 02/13/2012 02:06 PM, Stan Ice wrote:
    > got Firefox 10.0,
    > now it crashes every time I visit my broker's site that requires Java
    > and Iced Tea plugin.


    did you update both java and firefox?

    roll your firefox back to version 9:

    read my caveat, and if you wish then go to
    http://software.opensuse.org/search

    -scroll down until you find "MozillaFirefox" [NOT
    "MozillaFirefox-branding-basedonopensuse", NOT
    "MozillaFirefox-branding-openSUSE"]
    _only_ "MozillaFirefox"

    -CHECK the rpm name, do NOT pick one with "MozillaFirefox-7.something",
    or "MozillaFirefox-8.something" instead keep going to the next page
    until you find exactly "MozillaFirefox-9.0-2.6.1.something"

    -and carefully left click on the correct single RPM [do NOT click on the
    nearest 1-Click you see]....instead pick ONE:

    if you have a 32 bit system > MozillaFirefox-9.0-2.6.1.i586.rpm
    if you have a 64 bit system > MozillaFirefox-9.0-2.6.1.x86_64.rpm

    - there will be a pop up which tell WHICH RPM is gonna be used, READ it
    and make sure it is correct, then click on the "Open with" and spin to
    "Install/Remove Software (default)", then click ok

    - give your root password when asked and cross your fingers and wait for
    YaST to do its stuff..

    then, shut down and restart firefox, click Help > About Firefox and make
    sure you have version 9, then go to your broker and see if it works..

    if it does not, you probably have to roll back the java also...but first
    we need to make sure you actually did update java yesterday also..

    do that you....AH! see, you did not say your desktop environment...so
    can't tell you how...instead of telling you how, i'll tell you what:
    look at /var/log/zypp/history and you will see a list of updates listed
    by the date they were installed...look at 'yesterday' and see if there
    are any "java" packages....if there are, note their exact name and
    report back..

    and, while you are paying attention let me mention to NOT use "zypper
    up" again until you have learned how to make sure this doesn't happen again.

    instead of "zypper up", use YaST Online Update *or* "zypper patch" to
    fetch and install the needed security patches and major bug fixes, and
    use YaST Software Management for installing or removing software, and
    always follow the advice in the paragraph beginning with "IMPORTANT" in
    this posting: http://tinyurl.com/33qc9vu

    now, that advice is for new folks....here is my repo setup
    http://paste.opensuse.org/81397698 because i am new!

    --
    DD http://tinyurl.com/DD-Caveat
    Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

  4. #4
    Join Date
    Oct 2011
    Location
    Norway
    Posts
    21

    Default Re: Firefox 10 IcedTea crash

    Quote Originally Posted by Stan_Ice View Post
    I've updated my 12.1 Xfce with "zypper up" today and got Firefox 10.0, now it crashes every time I visit my broker's site that requires Java and Iced Tea plugin.

    This is very unfortunate as Firefox was the only browser that worked on that site and the only browser that works on Linux.

    Reinstalling IcedTea doesn't help.

    What could I do now? Can I rollback Firefox? Uninstall from Yast then download .rpm and install it? Wouldn't it mess my default system settings as I believe FF is a bit more than just another package.

    Or could I install older Firefox in my home directory as some .bin file or something? Need it working by tomorrow.
    Same problem here. I could not log into my bank (java is used). Firefox crashed. I went back to Firefox v9 which I found thanks to DenverD. It seems ok now.

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Firefox 10 IcedTea crash

    On 02/13/2012 10:16 PM, bkv1 wrote:
    > It seems ok now.


    please log a bug against FF10 and JDK, begin here: http://tinyurl.com/nzhq7j

    reference this thread in the bug, and tell them you back leveled to FF9
    and it works..

    when you have a bug number please return here and post it so those
    following in via Google can also go to the bug for the latest info..

    thanks...OH, and please say how did you install FF10?
    1. YaST Online Update
    2. Zypper patch
    3. Zypper up
    4. Zypper dup

    thank you for your contribution to FOSS..

    --
    DD http://tinyurl.com/DD-Caveat
    Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,162
    Blog Entries
    3

    Default Re: Firefox 10 IcedTea crash

    I'm using firefox 10. The java sudoku game at the New York Times worked fine for me this morning.

    On two different older systems, when I started firefox after the 10.0 upgrade, it crashed. However, on restarting, it ran just fine.

    (just a couple of related data points)
    openSUSE Leap 15.1; KDE Plasma 5;

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Firefox 10 IcedTea crash

    On 02/13/2012 11:06 PM, nrickert wrote:
    > The java sudoku game


    with openJDK?
    installed FF10 how? (YOU or "zypper [what?]"

    --
    DD http://tinyurl.com/DD-Caveat
    Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,162
    Blog Entries
    3

    Default Re: Firefox 10 IcedTea crash

    Quote Originally Posted by DenverD View Post
    with openJDK?
    installed FF10 how? (YOU or "zypper [what?]"
    Sorry for lack of clarity.

    Yes, using openJDK. And ff10 installed via online update.
    openSUSE Leap 15.1; KDE Plasma 5;

  9. #9
    Join Date
    Mar 2009
    Location
    Bangkok
    Posts
    431

    Default Re: Firefox 10 IcedTea crash

    There were no java updates, only Firefox and Thunderbird and some vlc related stuff.

    I'm on Xfce but can also login to KDE.

    Update thingy pops up every now and then but rarely completes its work, hanging on "refreshing software stage" or something. On KDE I was advised to uninstall "kpackagekit" or what's it called altogether. Online Update in Yast requires too many clicks to get to, I thought "zypper up" would do the same thing and faster but, apparently, I was wrong.

    My site is Maybank Kim Eng Securities (Thailand) Plc. The Java page is called KELiberty but you won't see the link unless you create at least a trial account. Their problem is certificates, all browsers, including IE, throw certificate error (and they describe it in manuals) but on Linux only Firefox can get past it and display all java applets on the page, Chrome and Opera allow the page itself but not connections for individual applets. I'd love to know how to solve that, too, but that's not important right now.

    NYTimes Sudoku hangs on "Loading files, one moment please" but at least it doesn't kill Firefox.

    I was hoping for separate Firefox install in my home directory that I could use for this particular site, if anybody can shed a light on, please? In the meantime I'll go download FF9 and prepare for system wide reinstall.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Firefox 10 IcedTea crash

    NYTimes Sudoku hangs on "Loading files, one moment please" but at least it doesn't kill Firefox.
    Works here
    12.1 kde4 default java stuff
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 6 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •