Results 1 to 10 of 10

Thread: Local time zone

  1. #1

    Default Local time zone

    Hi everybody,

    Since KDE 4 has been released there is no more possible to alter Time Zone. When I installed openSuse I have correctly selected my country (Slovenia) and town (Ljubljana).Also, when checking with Yast, all the date/time settings are correct. However, both the digital clock and the analog clock show Time Zone as Belgrade (in Serbia). When trying to change Time zone with KDE System settings/Date & Time, Belgrade is always selected regardless of which Area one selects. If I select Ljubljana, I am asked for the root password and after typing it, everything remains unchanged. Very annoying thing; imagine that somebody from New York has a time zone setting to Cairo without any chance to alter it.

    Now, I useopenSUSE 12.1 (x86_64 , KDE 4.8.00 (4.8.0 "release 462").

    Any suggestion.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,585
    Blog Entries
    14

    Default Re: Local time zone

    Use Yast - System - Date & Time to configure NTP. That should give you the exact local time, since it updates from an NTP server on the web.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Local time zone

    Thanks. But that I already have set. I mentioned in my contribution above that all settings are correctly set. The only problem is (as far as I can see) when hoovering with mouse over digital/analog clock and a small window pops-up indicating Current Time. Nothing wrong with that but the city is Belgrade instead of Ljubljana.

  4. #4

    Default Re: Local time zone

    Another thing. I also found out that Belgrade (instead of Ljubljana) is shown as local in all PIM software which belongs to KDE. Impossible to change it.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Local time zone

    On 2012-02-10 12:36, Knurpht wrote:
    >
    > Use Yast - System - Date & Time to configure NTP. That should give you
    > the exact local time, since it updates from an NTP server on the web.


    That only sets the system time, not the time zone of the users in KDE.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,176
    Blog Entries
    3

    Default Re: Local time zone

    Open a terminal.
    Type the command:
    Code:
    echo $TZ
    What does that show?

    It should give an empty line, or perhaps an error message. If it actually gives a timezone, then that could be related to your problem.
    openSUSE Leap 15.1; KDE Plasma 5;

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Local time zone

    On 2012-02-10 12:26, bivancic wrote:

    > Now, I useopenSUSE 12.1 (x86_64 , KDE 4.8.00 (4.8.0 "release 462").


    Check the time in text mode, or in another desktop (gnome, xfce, whatever).
    If it is correctly there, then it is a problem in KDE.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  8. #8

    Default Re: Local time zone

    Nothing, just empty line.

  9. #9

    Default Re: Local time zone

    There is no problem in time/date per se, the problem is that the wrong town/country is shown as my local area. As I already said, Yast shows correct town/country setting. I also set NTP server in our country. So, in general everything is fine. The KDE is that does not understand the local settings nor will it allow to change them.

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Local time zone

    On 2012-02-10 12:56, bivancic wrote:
    >
    > Another thing. I also found out that Belgrade (instead of Ljubljana) is
    > shown as local in all PIM software which belongs to KDE. Impossible to
    > change it.


    Report as bug.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •