Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Kdenlive rendering - corrupted files

  1. #1
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    42

    Default Kdenlive rendering - corrupted files

    I don't know whether this is the right place for this inquiry, but I have recently made a new installation of both openSUSE 11.4 and 12.1 on two separate computers and have installed kdenlive Version 0.8.2.1. from SUSE's repositories.

    I have been using kdenlive on open SUSE 11.4 in the past without any problems, but now find that at the end of the rendering process this error occurs (on both computers):

    "Rendering of /home/dick/kdenlive/untitled.mpg aborted, resulting video will probably be corrupted."

    As a result I cannot burn a DVD.

    I have posted this problem on the Kdenlive forum and have got no response.

    I am wondering whether a library (such as ffmpeg) could be responsible, but I don't know how to get older versions to try, or other similar programs used in kdenlive. The problem occurs with all output formats.

    Since I am keen to use kdenlive I would like to solve this problem. Any ideas?

  2. #2

    Default Re: Kdenlive rendering - corrupted files

    I have yet to successfully render anything with KdenLive without an error.
    both 11.4 and 12.1
    and in ArchLinux and Ubuntu.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,569
    Blog Entries
    38

    Default Re: Kdenlive rendering - corrupted files

    On my 64-bit openSUSE-11.4 kdenlive works ok (although some output codecs don't function - ie h264 has hiccups).

    As a test, 2 minutes ago, I finished encoding a 10 minute video clip with MPEG-4 output code.

    My kdenlive version:
    kdenlive-0.8.2.1-1.11.x86_64

    My mlt version: mlt-0.7.6-1.8.x86_64
    libmlt++3-0.7.6-1.8.x86_64
    libmlt4-0.7.6-1.8.x86_64

    My view is you are not trying enough different codecs if this fails for you.

  4. #4
    Join Date
    Oct 2011
    Location
    Germany (Ore Mountains)
    Posts
    428

    Default Re: Kdenlive rendering - corrupted files

    I have the same problem. There seems to be a bug/problem in the memory cleanup code of melt at the end of rendering. It crashes there always, but sometimes the resulting output file is usable.
    I compiled the new version of melt (0.7.7; together with the corresponding kdenlive version) from source and did not have this problem any more.
    I am not shure, if this is because of the new version or of the compiling on my machine.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,569
    Blog Entries
    38

    Default Re: Kdenlive rendering - corrupted files

    Quote Originally Posted by dick222 View Post
    As a result I cannot burn a DVD.
    wrt creating a DVD, I typically use kdenlive to create a video at 720p at a high bit rate (blue ray quality or better), which is MUCH higher than DVD quality. And then I convert the video with 'tovid' to a DVD compatible lower quality (than 720p) video bit rate/resolution.

    With tovid one can also check to see if a video is DVD compliant prior to burning with:
    Code:
    tovid id somevideo.mpg

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    42

    Default Re: Kdenlive rendering - corrupted files

    Thank you all for your suggestions.
    I am trying to recompile melt as suggested by hendwolt, who has experienced the same problem.
    I cannot find the source of melt, and indeed melt does not show on the software management in YaST.
    Could you help me here? Also I have not compiled in linux, but I will give a go.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,569
    Blog Entries
    38

    Default Re: Kdenlive rendering - corrupted files

    Quote Originally Posted by dick222 View Post
    Thank you all for your suggestions.
    I am trying to recompile melt as suggested by hendwolt, who has experienced the same problem.
    I cannot find the source of melt, and indeed melt does not show on the software management in YaST.
    Could you help me here? Also I have not compiled in linux, but I will give a go.
    I suspect he may mean the 'media lovin toolkit' (mlt) WebHome < MLT < MLT Wiki

    Recompiling is NOT the nominal openSUSE way to fix problems, although a lot of users who are happy to compile will do so. Its not the way I recommend.

    Instead, if there is a definite problem (and not finger trouble) that one can point to, then its better to go to the packager of the application and ask them to fix it. That way EVERYONE benefits and not just one's self. THATS how things progress in a distribution and by doing such our own efforts are amplified ....

    mlt is packaged by the packman packagers: PackMan :: Informationen zum Paket mlt One can contact them by joining the Packman packager mailing list, with instructions here how to do so Packman Info Page ... and advise them on that mailing list that one is having corruption with kdenlive and that one suspects the corruption is in 'mlt' and ask that they rebuild it.

  8. #8
    Join Date
    Oct 2011
    Location
    Germany (Ore Mountains)
    Posts
    428

    Default Re: Kdenlive rendering - corrupted files

    I followed the instructions on this page: BuildScripts < MLT < MLT Wiki
    and used the script: build-kdenlive.sh

    This version includes mlt, because kdenlive and mlt must be used in versions that fit together. The result of the compiling does not provide all codes available, so self-compiling is not the perfect solution in more than one way.
    In the kdenlive/mlt bug tracker are more the two bugs for this crash problem. I don't know, if the packman people can do anything about this, but I did not look at that mailing list.

  9. #9

    Default Re: Kdenlive rendering - corrupted files

    On 02/04/2012 04:06 PM, dick222 wrote:

    > Since I am keen to use kdenlive I would like to solve this problem. Any
    > ideas?


    I haven't had a problem lately, but when I was using openSUSE 11.0 or
    11.3 (IIRC) it would sometimes blow up towards the end. The solution
    for me was to break up the video into chapters and render each one. As
    long as they were below 30 minutes or so it seemed to work OK. If I
    went longer they ab-ended.

    I had plenty of disk space, could have used more RAM but probably had
    around a gig so it wasn't too starved. But something would get
    confused. Anyway, you might try that and see if it helps...

    ....Kevin
    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://linuxcounter.net

  10. #10

    Default Re: Kdenlive rendering - corrupted files

    Yes, this problem is real – not just fat finger disease. It is discussed at length in the kdenlive forum: Any rendering crashes! | Kdenlive starting 21JAN12.

    One of our Ubuntu brethren patched by means he described in this way:

    ------------------
    first I removed my existing ppa:sunab entries from the sources.
    next, using synaptic, I removed kdenlive and kdenlive-data, then melt, AND the associated mlt librarys. Three of them. If you just remove melt and not the libs it won't get fixed.
    from the command line I used this command:
    sudo add-apt-repository ppa:sunab/kdenlive-release && sudo apt-get update && sudo apt-get install kdenlive.
    when it comes back, melt and the librarys are downgraded to 0.7.6 and everything works, for me.
    ------------------

    Unfortunately, I think we are at the mercy of library maintainers to patch and distribute.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •