Page 1 of 12 12311 ... LastLast
Results 1 to 10 of 111

Thread: 12.1 64 bit won't boot

Hybrid View

  1. #1

    Default 12.1 64 bit won't boot

    I'll start by saying I'm a linux noob, so please excuse my ignorance! I tried to install it from a DVD, and everything seemed ok until it said something along the lines of "changing to text-based installation, graphics card may not be supported" when it went in to the Configuration section of the install. I let it finish, and it came up with the command line so i rebooted. Up came the GRUB and I chose the Desktop option, but it got stuck on the OpenSUSE splash screen. So i rebooted, chose the Failsafe option this time and it froze at (something like):

    Code:
    booting /windows/C
    [long number]HDMI Status: codec=0  pin=5  presence-detect=0  ELD_Valid=0
    I'm dual-booting with 64-Bit Windows 7, my graphics card is an nVidia GeForce GTX460.

    Any help is greatly appreciated!

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: 12.1 64 bit won't boot

    Quote Originally Posted by Camalus28 View Post
    I'll start by saying I'm a linux noob, so please excuse my ignorance! I tried to install it from a DVD, and everything seemed ok until it said something along the lines of "changing to text-based installation, graphics card may not be supported" when it went in to the Configuration section of the install. I let it finish, and it came up with the command line so i rebooted. Up came the GRUB and I chose the Desktop option, but it got stuck on the OpenSUSE splash screen. So i rebooted, chose the Failsafe option this time and it froze at (something like):

    Code:
    booting /windows/C
    [long number]HDMI Status: codec=0  pin=5  presence-detect=0  ELD_Valid=0
    I'm dual-booting with 64-Bit Windows 7, my graphics card is an nVidia GeForce GTX460.

    Any help is greatly appreciated!
    Here is a copy from a recent article on the subject. You most likely need to use the nomodeset kernel load option as shown below:

    1st thing to try (nomodeset)


    • The 1st thing to try is to boot from grub with boot code: nomodeset . This is per the guidance in the openSUSE-12.1 release notes. ie in grub's option line enter:

    nomodeset
    New users, to explain better for you, please note you enter this boot code in the very first openSUSE menu you see when you switch ON your PC. Just start typing and you will see the letters for 'nomodeset' appear in the options line of the menu.

    Boot with nomodeset boot code


    Then after entering that, press <enter> and let your PC boot. Hopefully that will be sufficient and you will have a functional desktop at that time. The openSUSE-12.1 release notes provide more detail, especially on how to make this permanent.

    If this helps, you may want to know how to install the proprietary nvidia video driver you can read about here: Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

    and I have a bash utility you can use here: LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.20 - Blogs - openSUSE Forums

    and read all of the links to get the full picture on the issue and good luck.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: 12.1 64 bit won't boot

    With "nomodeset", the desktop option still freezes at a splash screen, but a smaller one. Failsafe still freezes as well.

  4. #4

    Default Re: 12.1 64 bit won't boot

    Quote Originally Posted by Camalus28 View Post
    With "nomodeset", the desktop option still freezes at a splash screen, but a smaller one. Failsafe still freezes as well.
    You should boot in console mode (not try to start X at all), login as root and install the nvidia driver from repo.

    Code:
    zypper ar ftp://download.nvidia.com/opensuse/12.1/  nvidia
    zypper refresh
    zypper install x11-video-nvidiaG02
    You need an Internet connection at this point though.

  5. #5

    Default Re: 12.1 64 bit won't boot

    I have an internet connection. But what do you mean not start X? How do I boot in to console mode? Also, how do I log in as root? Sorry, I'm a really big noob...

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: 12.1 64 bit won't boot

    Quote Originally Posted by Camalus28 View Post
    I have an internet connection. But what do you mean not start X? How do I boot in to console mode? Also, how do I log in as root? Sorry, I'm a really big noob...
    In my example above, you enter the kernel load option nomodeset. Imagine that in addition, you add the number 3, which sends you to run level 3. So, you would enter: nomodeset 3 which would leave you at the terminal prompt, able to enter the root user name and password and then able to enter the command please_try__again suggests above to load the nVIDIA driver.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7

    Default Re: 12.1 64 bit won't boot

    Quote Originally Posted by Camalus28 View Post
    I have an internet connection.
    I bet you do, but it must be available in console mode - which might not be the case if you setup your nic with network manager. If you used the ifup method, it will be OK.

    Quote Originally Posted by Camalus28 View Post
    But what do you mean not start X? How do I boot in to console mode?
    You would add "3" in the Boot Options line. I'm not sure it works in systemd. If it does not, press F5 (Init Program), select "System V", add "3" to the Boot Options and boot the normal kernel (not failsafe!). It should bring you to a console login prompt.

  8. #8

    Default Re: 12.1 64 bit won't boot

    None of it worked... It just got stuck. I tried everything on everything

  9. #9

    Default Re: 12.1 64 bit won't boot

    Boot from a live CD and post the output of these two commands:

    Code:
    lspci
    hwinfo --gfxcard

  10. #10

    Default Re: 12.1 64 bit won't boot

    Sorry for the double-post! would changing the DE matter? I installed with GNOME but would have no problem using KDE or XFCE

    *EDIT*
    Ok, I'll go downlaod the Live CD now, but the download is going surprisingly slow so looks like I won't have it until tomorrow (I'm downloading the KDE Live CD, if it matters)

Page 1 of 12 12311 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •