Page 2 of 12 FirstFirst 1234 ... LastLast
Results 11 to 20 of 111

Thread: 12.1 64 bit won't boot

  1. #11

    Default Re: 12.1 64 bit won't boot

    I don't know if it matters or not, but I'm running the KDE Live CD but installed as GNOME... anyways here are the results of the commands:

    lspci
    Code:
    00:00.0 Host bridge: Advanced Micro Devices [AMD] RS880 Host Bridge
    00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
    00:09.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 4)
    00:0a.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 5)
    00:11.0 SATA controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode] (rev 40)
    00:12.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
    00:12.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
    00:13.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
    00:13.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
    00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 42)
    00:14.1 IDE interface: ATI Technologies Inc SB7x0/SB8x0/SB9x0 IDE Controller (rev 40)
    00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
    00:14.3 ISA bridge: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
    00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
    00:14.5 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
    00:16.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
    00:16.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
    00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
    00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
    01:00.0 VGA compatible controller: nVidia Corporation GF104 [GeForce GTX 460] (rev a1)
    01:00.1 Audio device: nVidia Corporation GF104 High Definition Audio Controller (rev a1)
    02:00.0 IDE interface: VIA Technologies, Inc. VT6415 PATA IDE Host Controller
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
    hwinfo --gfxcard
    Code:
    31: PCI 100.0: 0300 VGA compatible controller (VGA)                                                                                  
      [Created at pci.319]                                                                                                               
      Unique ID: VCu0.BEZbHPpl76F                                                                                                        
      Parent ID: _Znp.UAx368lzOkB                                                                                                        
      SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0                                                                            
      SysFS BusID: 0000:01:00.0                                                                                                          
      Hardware Class: graphics card                                                                                                      
      Model: "nVidia VGA compatible controller"                                                                                          
      Vendor: pci 0x10de "nVidia Corporation"                                                                                            
      Device: pci 0x0e22                                                                                                                 
      SubVendor: pci 0x3842 "eVga.com. Corp."                                                                                            
      SubDevice: pci 0x1370                                                                                                              
      Revision: 0xa1                                                                                                                     
      Driver: "nouveau"                                                                                                                  
      Driver Modules: "drm"                                                                                                              
      Memory Range: 0xfc000000-0xfdffffff (rw,non-prefetchable)                                                                          
      Memory Range: 0xd8000000-0xdfffffff (ro,non-prefetchable)                                                                          
      Memory Range: 0xd4000000-0xd7ffffff (ro,non-prefetchable)                                                                          
      I/O Ports: 0xcc00-0xcc7f (rw)                                                                                                      
      Memory Range: 0xfea80000-0xfeafffff (ro,non-prefetchable,disabled)                                                                 
      IRQ: 18 (10541 events)                                                                                                             
      I/O Ports: 0x3c0-0x3df (rw)                                                                                                        
      Module Alias: "pci:v000010DEd00000E22sv00003842sd00001370bc03sc00i00"                                                              
      Driver Info #0:                                                                                                                    
        Driver Status: nvidiafb is not active                                                                                            
        Driver Activation Cmd: "modprobe nvidiafb"                                                                                       
      Driver Info #1:                                                                                                                    
        Driver Status: nouveau is active                                                                                                 
        Driver Activation Cmd: "modprobe nouveau"                                                                                        
      Config Status: cfg=new, avail=yes, need=no, active=unknown                                                                         
      Attached to: #10 (PCI bridge)                                                                                                      
                                                                                                                                         
    Primary display adapter: #31

  2. #12

    Default Re: 12.1 64 bit won't boot

    I reinstalled once again with KDE this time, and a command-line came up immediate after installation so I managed to run these commands:

    Quote Originally Posted by please_try_again View Post
    You should boot in console mode (not try to start X at all), login as root and install the nvidia driver from repo.

    Code:
    zypper ar ftp://download.nvidia.com/opensuse/12.1/  nvidia
    zypper refresh
    zypper install x11-video-nvidiaG02
    You need an Internet connection at this point though.
    Still no luck...

  3. #13

    Default Re: 12.1 64 bit won't boot

    Whether you use KDE or Gnome doesn't matter, to answer your question a bit late. I wanted to make sure that you didn't have a hybrid graphic card (nvidia + somethng else), but it looks like you don't. What happened when you ran the zypper commands? Did they install the nvidia driver? Are you able to get a console login now? If you do, what is the output of this command now:
    Code:
    hwinfo --gfxcard
    and the result of these commands:

    Code:
    lsmod | grep -i -e nvidia -e nouveau
    rpm -qa | grep nvidia
    lsinitrd /boot/initrd | grep nouveau

  4. #14

    Default Re: 12.1 64 bit won't boot

    It went through the motion's, I guess. Everything downloaded, completed, refreshed, installed without error. I'll go try to get in to the command-line again, and report back.

  5. #15

    Default Re: 12.1 64 bit won't boot

    Command line still won't boot either.

  6. #16

    Default Re: 12.1 64 bit won't boot

    Well, I had pretty much given up on OpenSUSE until last night I left windows on to finish a download, came to check the download/turn of my computer, and somehow it was booted in to OpenSUSE! Here's the result of the commands, please_try_again, and I'm hoping it'll boot again:

    hwinfo --gfxcard
    Code:
    31: PCI 100.0: 0300 VGA compatible controller (VGA)             
      [Created at pci.319]
      Unique ID: VCu0.BEZbHPpl76F
      Parent ID: _Znp.UAx368lzOkB
      SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "nVidia VGA compatible controller"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x0e22 
      SubVendor: pci 0x3842 "eVga.com. Corp."
      SubDevice: pci 0x1370 
      Revision: 0xa1
      Driver: "nvidia"
      Driver Modules: "nvidia"
      Memory Range: 0xfc000000-0xfdffffff (rw,non-prefetchable)
      Memory Range: 0xd8000000-0xdfffffff (ro,non-prefetchable)
      Memory Range: 0xd4000000-0xd7ffffff (ro,non-prefetchable)
      I/O Ports: 0xcc00-0xcc7f (rw)
      Memory Range: 0xfea80000-0xfeafffff (ro,non-prefetchable,disabled)
      IRQ: 18 (828794 events)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v000010DEd00000E22sv00003842sd00001370bc03sc00i00"
      Driver Info #0:
        Driver Status: nvidiafb is not active
        Driver Activation Cmd: "modprobe nvidiafb"
      Driver Info #1:
        Driver Status: nouveau is not active
        Driver Activation Cmd: "modprobe nouveau"
      Driver Info #2:
        Driver Status: nvidia is active
        Driver Activation Cmd: "modprobe nvidia"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #10 (PCI bridge)
    
    Primary display adapter: #31
    lsmod | grep -i -e nvidia -e nouveau
    Code:
    nvidia              12136858  40
    rpm -qa | grep nvidia
    Code:
    nvidia-computeG02-290.10-13.1.x86_64
    x11-video-nvidiaG02-290.10-13.1.x86_64
    nvidia-gfxG02-kmp-desktop-290.10_k3.1.0_1.2-12.1.x86_64
    lsinitrd /boot/initrd | grep nouveau
    ...nothing happens.

  7. #17

    Default Re: 12.1 64 bit won't boot

    You were using 'nouveau' before. Now you're using the nvidia proprietary driver. That's the difference. It should be OK now.

  8. #18

    Default Re: 12.1 64 bit won't boot

    Alright! Thanks a ton, then! If it's not too much bother, could you explain why it suddenly worked now?

  9. #19

    Default Re: 12.1 64 bit won't boot

    Quote Originally Posted by Camalus28 View Post
    Alright! Thanks a ton, then! If it's not too much bother, could you explain why it suddenly worked now?
    To give a short and incomplete answer, the 'nouveau' driver, which is open source and installed by default, uses a feature named "kernel mode setting" (that you can deactivate with the option 'nomodeset', although it doesn't always work). Some models of Nvidia cards simply don't work with kernel mode setting. Most of them will work with the 'nomodeset' option but not all. The nvidia driver doesn't use "kernel mode setting" and it does deactivate it (removes the feature from initrd). It also blacklists the 'nouveau' driver. And this is why it finally worked.

  10. #20

    Default Re: 12.1 64 bit won't boot

    Well it froze up as soon as my disc finished burning, so I did a manual restart and it won't boot in to it, again. This is getting really irritating lol. Any more ideas?

Page 2 of 12 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •