Results 1 to 8 of 8

Thread: [Solved] MuseScore in OpenSuse 12.1

  1. #1

    Default [Solved] MuseScore in OpenSuse 12.1

    Hello,

    This was really really really painful for me, so I think it is worth sharing how I installed MuseScore, a music notation software, in OpenSuse 12.1

    1. Install MuseScore from the Education repository, or click here for manual download

    2. Use your package manager or zypper to install the package, accept the extra packages and repositories which need to be downloaded, if needed.

    3. Open MuseScore and you will find a problem: no sound... something essential if you need to use some music notation software!

    What causes it?

    You don't have a SoundFont installed.

    How to solve that

    1. Visit this MuseScore page. You will find links to three SoundFonts there. Choose whichever you want.

    2. Un-package the file.

    3. Open a file manager and copy or move the name.sf2 file to the /usr/share/sounds/sf2/ directory. You will need root access.

    4. Install jack, pulseaudio-module-jack, and qsynth using Yast2 or Zypper.

    5. Open qsynth

    6. Click on Setup..., then to SoundFonts, and open the file you saved in the /usr/share/sounds/sf2/ directory. Save.

    7. Open MuseScore again. Go to Edit > Preferences > I/O

    8. Activate Jack as audio server.

    9. Close and restart MuseScore.

    10. Thank me.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: [Solved] MuseScore in OpenSuse 12.1

    On 02/03/2012 05:36 AM, Tedel wrote:
    >
    > 10. Thank me.


    -=WELCOME=- new poster..

    thank you for your contribution to free and open software..

    hope you enjoy makin' music with openSUSE!

    Have a lot of fun.

    --
    DD
    Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

  3. #3
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: [Solved] MuseScore in OpenSuse 12.1

    I second that, well done

    You actually have some sound-fonts available from various OpenSuSE repoes already, including both 'fluid' and 'generaluser' which I saw was on the Muse site. You find them in the packman and the OpenSuSE multimedia repoes.
    By the way, you don't need to install the sound-fonts under the /usr/share/sounds/sf2/ directory, you may create your own folder in your home dir and have them there as well.

    If you're interested in more sound fonts there are some here:
    - HammerSound
    - KVR: Virtual Instruments, Virtual Effects, VST Plugins, Audio Units (AU), AAX & RTAS Audio Plugin News, Reviews and Community - plus iOS (iPhone and iPad) and Android Audio App News Too
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  4. #4

    Default Re: [Solved] MuseScore in OpenSuse 12.1

    Oh, more soundfonts!? I'll take a look at them.

  5. #5

    Default Re: [Solved] MuseScore in OpenSuse 12.1

    Thank you for your detailed post, Tedel. It seems that you wrote it precisely, so I was very hopeful that it would work for me. But it did not.

    Maybe there is something obvious that I am not understanding in the error messages below.

    I am running opensuse 12.1 on an HP 4530s. Here I indicate what happened WRT your instructions when I tried them:

    I opened qsynth and got a message like:

    Qsynth1: Failed to create the MIDI driver (alsa_seq). No MIDI input will be available.

    I followed your instructions regarding the font. I chose the TimGM6mb.sf2 font. I opened that font in qsynth, then closed qsynth and reopened qsynth, then got a message like:

    Qsynth1: Failed to create the audio driver (jack). Cannot continue without it.

    I closed qsynth and reopened it, then got the first message about alsa_seq again.

    I quit qsynth and used yast to look for a package named alsa_seq and didn't find one.


    When I click Display in musescore, the Synthesizer button is shaded and inactive.

    I got messages like the following when typing either

    mscore -F &

    or

    mscore &

    at the command line:

    ALSA lib pcm_dmix.c:1018: (snd_pcm_dmix_open) unable to open slave
    ALSA lib pcm.c:2212: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
    ALSA lib pcm.c:2212: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
    ALSA lib pcm.c:2212: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
    ALSA lib pcm_dmix.c:957: (snd_pcm_dmix_open) The dmix plugin supports only playback stream
    ALSA lib pcm_dmix.c:1018: (snd_pcm_dmix_open) unable to open slave
    Cannot connect to server socket err = No such file or directory
    Cannot connect to server socket
    jack server is not running or cannot be started
    ALSA lib seq_hw.c:457: (snd_seq_hw_open) open /dev/snd/seq failed: Permission denied
    Init midi driver failed
    no audio output found
    init audio driver failed
    sequencer init failed
    registerPlugin: add action idx 1
    Load plugin: no menu property
    preferences.checkUpdateStartup: 0
    lastupdate: 10.05.2012 13:28:42.400


    Note that I had to modify the above error messages by inserting spaces into the "" (colon, left paren) sequences, because the forum software turned them into frownies and I don't know how to turn off that effect.


    Thanks if anyone can help with this (musescore, not the frownies).

    When it is solved, we need to get this information to whomever is packaging Musescore for opensuse.

  6. #6

    Default Re: [Solved] MuseScore in OpenSuse 12.1

    Oh boy ... it works!

    I have a dual boot system, and after I couldn't get MuseScore to work with opensuse, I shut down opensuse and booted into Windows 7. I installed MuseScore on W7, and it worked right away. Then I shut down Windows and booted back into opensuse, and it worked.

    So thank you Tedel, and maybe you should add to your instructions that a system reboot might help.

    Probably something less drastic than a reboot would be adequate, but I can't say what it is.

    I think we need to find out who is packaging MuseScore for openSuse and get these instructions to them so they can make it work right out of the box.

    Thanks again.

  7. #7
    Join Date
    Dec 2008
    Location
    Antwerp, Belgium
    Posts
    140

    Default Re: [Solved] MuseScore in OpenSuse 12.1

    Ok, almost there... now I have the play buton (not grayed out anymor). It's playing... but no sound yet...



    Quote Originally Posted by Tedel View Post
    Hello,

    This was really really really painful for me, so I think it is worth sharing how I installed MuseScore, a music notation software, in OpenSuse 12.1

    1. Install MuseScore from the Education repository, or click here for manual download

    2. Use your package manager or zypper to install the package, accept the extra packages and repositories which need to be downloaded, if needed.

    3. Open MuseScore and you will find a problem: no sound... something essential if you need to use some music notation software!

    What causes it?

    You don't have a SoundFont installed.

    How to solve that

    1. Visit this MuseScore page. You will find links to three SoundFonts there. Choose whichever you want.

    2. Un-package the file.

    3. Open a file manager and copy or move the name.sf2 file to the /usr/share/sounds/sf2/ directory. You will need root access.

    4. Install jack, pulseaudio-module-jack, and qsynth using Yast2 or Zypper.

    5. Open qsynth

    6. Click on Setup..., then to SoundFonts, and open the file you saved in the /usr/share/sounds/sf2/ directory. Save.

    7. Open MuseScore again. Go to Edit > Preferences > I/O

    8. Activate Jack as audio server.

    9. Close and restart MuseScore.

    10. Thank me.

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: [Solved] MuseScore in OpenSuse 12.1

    On 2012-05-10 21:06, LizardBoy wrote:
    > Note that I had to modify the above error messages by inserting spaces
    > into the "" (colon, left paren) sequences, because the forum software
    > turned them into frownies and I don't know how to turn off that effect.


    That's why you have to post computer code text inside code tags. Advanced
    editor, # button.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •