Results 1 to 7 of 7

Thread: KDE 4.8.0: Gwenview won't display .xcf files (error while reading metadata)

  1. #1

    Default KDE 4.8.0: Gwenview won't display .xcf files (error while reading metadata)

    Hello,

    after upgrading from KDE 4.7.4 to 4.8.0 (stable version) Gwenview (version 2.8.0) can't display .xcf files (from Gimp) in full view. Thumbnails and previews are shown as usual. But when I click on the thumbnail of a .xcf file to display the file in its actual size, a blank window with an error message appears; similar: Display of file blah.xcf not possible - metadata not readable (in German, it's a German localisation). Digikam and showFoto can display the files without error. It's an annoying behavior, because I have .xcf and other image files in the same folder and now cannot browse the folder in full view.

    Is there a solution of the problem? In forum.kde.org is a discussion about a similar topic with .psd files; possibly a wrong "kdelibs" was shipped with the final KDE 4.8.0.

    BTW: The birds eye view in the new Gwenview is annoying, because the mouse wheel doesn't work now. A possibility to toggle between the old and new behavior (side bars and birds eye view) would be very nice, or at least a working mouse wheel.

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: KDE 4.8.0: Gwenview won't display .xcf files (error while reading metadata)

    This is something you should mention in the mailing list (opensuse-kde@opensuse.org)
    And also at upstream bugs
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: KDE 4.8.0: Gwenview won't display .xcf files (error while readingmetadata)

    On 03/02/12 02:16, TomWed wrote:
    > after upgrading from KDE 4.7.4 to 4.8.0 (stable version) Gwenview
    > (version 2.8.0) can't display .xcf files (from Gimp) in full view.
    > Thumbnails and previews are shown as usual. But when I click on the
    > thumbnail of a .xcf file to display the file in its actual size, a blank
    > window with an error message appears; similar: Display of file blah.xcf
    > not possible - metadata not readable (in German, it's a German
    > localisation). Digikam and showFoto can display the files without error.
    > It's an annoying behavior, because I have .xcf and other image files in
    > the same folder and now cannot browse the folder in full view.


    I've found that Gwenview also cannot display some PNG images whilst all
    the other applications have no trouble. There is no error message as the
    problem is that Gwenview simply shows a message to say it's loading the
    image and does no more. I've switched back from KDE 4.8 to 4.7.4 and the
    problem has gone.

    Reported as bug #745220.

    --
    Graham Davis, Bracknell, Berks.
    openSUSE 12.1 (64-bit); KDE 4.7.4; AMD Phenom II X2 550 Processor;
    Video: nVidia GeForce 210 (using nouveau driver);
    Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: KDE 4.8.0: Gwenview won't display .xcf files (error while readingmetadata)

    No issue here with 4.8 and .png
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: KDE 4.8.0: Gwenview won't display .xcf files (error while readingmetadata)

    On 04/02/12 16:16, caf4926 wrote:
    >
    > No issue here with 4.8 and .png
    >
    >


    That's probably true with about 90% of my PNG files. It's the 10% that's
    bothering me. ;-)

    Graham

  6. #6
    Join Date
    Jul 2009
    Location
    Spain
    Posts
    52

    Thumbs down Re: KDE 4.8.0: Gwenview won't display .xcf files (error while readingmetadata)

    Same issue. After upgrading to KDE 4.8, Gwenview doesn't show thumbnails of XCF files. Digikam does it.

    OpenSUSE 11.4

  7. #7
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: KDE 4.8.0: Gwenview won't display .xcf files (error while readingmetadata)

    On Mon, 06 Feb 2012 06:06:03 +0530, faleloncio
    <faleloncio@no-mx.forums.opensuse.org> wrote:

    >
    > Same issue. After upgrading to KDE 4.8, Gwenview doesn't show thumbnails
    > of XCF files. Digikam does it.
    >
    > OpenSUSE 11.4
    >


    for me, neither gwenview nor digikam showed thumbnails of xcf files
    anymore using KDE 4.8 from the KDE/Release repo. today i upgraded to KDE
    4.8 from KDE/Distro:/Factory, and now xcf thumbnails show again. (not
    saying that using KDF is a good idea in general; it's just what i usually
    have the best experience with, since bug fixes show up faster.)

    --
    phani.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •