Results 1 to 7 of 7

Thread: Qt4.8 Designer QWebView missing

  1. #1

    Default Qt4.8 Designer QWebView missing

    OpenSuse 11.4
    KDE 4.8 release 462
    Qt 4.8

    After updating all qt4 related files available via yast the only issue I have so far is
    the QwebView widget in Qt Designer missing or not showing.

    What needs to be done ? Anyone else having this issue ?

    Db

  2. #2

    Default Re: Qt4.8 Designer QWebView missing

    Having made a stock install of opensuse 12.1 the QWebView widget plugin in Qt Designer
    is also missing there. It is an issue which happens when compilation is done in the
    wrong order.
    Also see here which describes this issue:
    https://bugs.launchpad.net/ubuntu/+s...ce/+bug/674367

    Any ideas ?

    Db

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Qt4.8 Designer QWebView missing

    Am 27.02.2012 09:06, schrieb Darkblue2:
    >
    > Having made a stock install of opensuse 12.1 the QWebView widget plugin
    > in Qt Designer
    > is also missing there. It is an issue which happens when compilation is
    > done in the
    > wrong order.
    > Also see here which describes this issue:
    > https://bugs.launchpad.net/ubuntu/+s...ce/+bug/674367
    >
    > Any ideas ?
    >
    > Db
    >
    >

    The missing .so file mentioned in the launchpad report seems to be only
    in libQtWebKit4-32bit on my 64bit 11.4 system.
    Code:
    martinh@ganymed:~> rpm -qf /usr/lib/qt4/plugins/designer/libqwebview.so
    libQtWebKit4-32bit-4.7.1-8.17.1.x86_64
    Can you check if the same is true on your 12.1 with qt4.8?

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
    nVidia ION | 3GB Ram

  4. #4

    Default Re: Qt4.8 Designer QWebView missing

    On qt4.8

    rpm -qf /usr/lib/qt4/plugins/designer/libqwebview.so
    /usr/lib/qt4/plugins/designer/libqwebview.so: No such file or directory

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Qt4.8 Designer QWebView missing

    Am 27.02.2012 10:26, schrieb Darkblue2:
    >
    > On qt4.8
    >
    > rpm -qf /usr/lib/qt4/plugins/designer/libqwebview.so
    > /usr/lib/qt4/plugins/designer/libqwebview.so: No such file or directory
    >
    >

    Of course not, since you have the rpm not installed, the idea was to
    download it and see if it also contains the file. I should have been
    clearer.
    Or you can try the command
    Code:
    sudo zypper install libqwebview.so
    and see what it wants to install (if you do not want to install what it
    shows just select no then).

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
    nVidia ION | 3GB Ram

  6. #6

    Default Re: Qt4.8 Designer QWebView missing

    I know, I tried this before but did not go ahead because of this zypper output and the fear to break something else in due course :

    downgrade of libQtWebKit4-32bit-4.8.0+2.2.0-18.1.x86_64 to libQtWebKit4-32bit-4.7.1-8.17.1.x86_64
    install libQtWebKit4-32bit-4.7.1-8.17.1.x86_64 (with vendor change)
    obs://build.opensuse.org/KDE --> openSUSE

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Qt4.8 Designer QWebView missing

    Am 27.02.2012 11:16, schrieb Darkblue2:
    >
    > I know, I tried this before but did not go ahead because of this zypper
    > output and the fear to break something else in due course :
    >
    > downgrade of libQtWebKit4-32bit-4.8.0+2.2.0-18.1.x86_64 to
    > libQtWebKit4-32bit-4.7.1-8.17.1.x86_64
    > install libQtWebKit4-32bit-4.7.1-8.17.1.x86_64 (with vendor change)
    > obs://build.opensuse.org/KDE --> openSUSE
    >
    >

    Report a bug, that the file is missing in the 64bit packages is
    definitely not ok, it seems to be a packaging error.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
    nVidia ION | 3GB Ram

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •