Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: GNOME session won't start in VNC

  1. #11

    Default Re: GNOME session won't start in VNC

    Quote Originally Posted by glistwan View Post
    For running the some GUI apps alone (not the whole desktop) X11 forwarding over ssh should be sufficient and is very easy to configure IMHO. (changing simply one parameter in the server and client config) If You're accessing your linux machine from windows You also need to install Xserver for windows in order for X11 forwarding to work but that's as simple as downloading Xming install and clicking next.
    Thanks, that is a great tip and I use X forwarding any time I work on a real computer (normally I'm accessing my Linux machine from another Linux machine). My specific issue here is working with a tablet. It's just unbeatable when I'm working from underway because it's battery holds for a good couple of days. The only problem is that Android doesn't have an X server (there's only one site that advertises it and the site seems to be dead for quite some time). So I'm stuck working with VNC on my Android - at least until the Spark comes out (assuming that it's got an X server! I hope so! ). That's why I'd like to get the more touch-friendly GNOME running in VNC.

    Best,
    Daniel

  2. #12
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Question AW: Re: GNOME session won't start in VNC

    Quote Originally Posted by erget View Post
    [...]Any more ideas?[...]
    Hi Daniel, it's only me again...

    Searching for "gnome-session-is-accelerated" gives me for example this:
    Gnome 3 Standard mode not working (on FedoraForum.org starting with 2011-11-22) or
    More GNOME Shell Customization (blog.fpmurphy.com in May 2011 about the system of graphics software and hardware working together in GNOME3)
    So maybe there is something going wrong with the 3D hardware acceleration?
    Is your system trying to use the 3D hardware acceleration of your tablet or has no access to the 3D hardware acceleration of your bigger computer (server)?

    Have you tried using the (forced) fallback mode of GNOME3 (normally automatically used for systems with not enough capaticities for 3D hardware acceleration - a bit like GNOME 2.x)?

    On behalf localizing the problem a bit:
    Have you tried access to the same VNC server with an other VNC client (a normal computer/laptop that could use GNOME3 in a locate session)?

    Just a bit amateurish (I am only a lawyer ) guessing...

    I wish you good luck (and maybe an other, better guess[er])

    Regards
    Martin
    Martin

  3. #13
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: GNOME session won't start in VNC

    On 2012-02-06 09:26, erget wrote:
    >
    > I use it because I make a lot of maps and need to see them... Normally I
    > make them in a terminal, but then I also need to put them together and
    > proof them graphically.


    You do not need VNC to see your graphics program. This ability is native to
    Linux.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  4. #14
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: GNOME session won't start in VNC

    On 2012-02-06 09:36, erget wrote:
    > My specific issue here is working with a tablet. It's
    > just unbeatable when I'm working from underway because it's battery
    > holds for a good couple of days. The only problem is that Android
    > doesn't have an X server (there's only one site that advertises it and
    > the site seems to be dead for quite some time).


    /That/ is a good reason.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #15
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,669
    Blog Entries
    15

    Default Re: GNOME session won't start in VNC

    Quote Originally Posted by erget
    glistwan;2437797 Wrote:
    > For running the some GUI apps alone (not the whole desktop) X11
    > forwarding over ssh should be sufficient and is very easy to configure
    > IMHO. (changing simply one parameter in the server and client config)
    > If You're accessing your linux machine from windows You also need to
    > install Xserver for windows in order for X11 forwarding to work but
    > that's as simple as downloading Xming install and clicking next.


    Thanks, that is a great tip and I use X forwarding any time I work on a
    real computer (normally I'm accessing my Linux machine from another
    Linux machine). My specific issue here is working with a tablet. It's
    just unbeatable when I'm working from underway because it's battery
    holds for a good couple of days. The only problem is that Android
    doesn't have an X server (there's only one site that advertises it and
    the site seems to be dead for quite some time). So I'm stuck working
    with VNC on my Android - at least until the Spark comes out (assuming
    that it's got an X server! I hope so! ). That's why I'd like to get
    the more touch-friendly GNOME running in VNC.

    Best,
    Daniel

    Hi
    There is a Xvnc/X11 server with vnc backend on the Apps Market?
    https://market.android.com/details?i...eqvd.android.x

    Installed it fine on my Transformer tablet...

    Have you tried teamviewer?

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.1 (x86_64) Kernel 3.1.9-1.4-desktop
    up 1 day 17:47, 3 users, load average: 0.11, 0.06, 0.05
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


  6. #16
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: GNOME session won't start in VNC

    Am 06.02.2012 15:27, schrieb malcolmlewis:
    > Hi
    > There is a Xvnc/X11 server with vnc backend on the Apps Market?
    > https://market.android.com/details?i...eqvd.android.x

    A very nice program, installed it on my tablet now. Thanks for the info
    about it.


    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
    nVidia ION | 3GB Ram

  7. #17

    Default Re: GNOME session won't start in VNC

    Hi,

    That's some great info. I have to admit, though, if I'm already working graphically I do like to have a complete environment. It would be realky nice to have GNOME running. I don't understand why it doesn't work - I think that somehow GNOME has a problem using any session other than :1.

    On another note, though, that app for Android seems really cool. How does it work? Do I just need to forward the right ports and then when I open a program in e.g. sshDroid it pops up in the VNC monitor?

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •