Results 1 to 3 of 3

Thread: libktexteditor missing - kile won't zypper in

  1. #1

    Default libktexteditor missing - kile won't zypper in

    Hi there,

    I installed openSuSE 11.4 32bit from a network installer CD (as the machine cannot boot DVDs).

    After

    zypper ref (with Oss, Non-Oss, Updates, nVidia, Packman, Mozilla, Libreoffice, KDEApps, KDEextra and Education)
    zypper -n dup -l
    zypper -n inr

    I went for

    zypper in kile

    and zypper claimed that the package 'libktexteditor' is a dependancy of kile, but no repository would provide it.

    This has never happend with both 32bit or 64bit installer DVD, why now? And how to fix it?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,719

    Default Re: libktexteditor missing - kile won't zypper in

    Hm, strange

    I have libktexteditor 4.7.2-2.2.1-i586 on my system. YaST says it is from obs//build.opensuse.org/KDE. I do not have such a repo in my repos list. I also do not know why it is installed. Maybe some 1-click (I do uncheck the "keep this repo" normaly).

    Hope this helps.
    Henk van Velden

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: libktexteditor missing - kile won't zypper in

    On 2012-02-01 19:16, NobodyHasThisNickname wrote:
    >
    > Hi there,
    >
    > I installed openSuSE 11.4 32bit from a network installer CD (as the
    > machine cannot boot DVDs).


    Ok...

    > After
    >
    > zypper ref (with Oss, Non-Oss, Updates, nVidia, Packman, Mozilla,
    > Libreoffice, KDEApps, KDEextra and Education)


    Ok...

    > zypper -n dup -l


    Why???

    > zypper -n inr
    >
    > I went for
    >
    > zypper in kile
    >
    > and zypper claimed that the package 'libktexteditor' is a dependancy of
    > kile, but no repository would provide it.


    After you did a dup with so many repos configured, no wonder, because
    libktexteditor is in oss repo. It comes in libkde4-devel*rpm, libkde4*rpm,
    etc. You may have a conflicting package from who knows where.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •