Results 1 to 5 of 5

Thread: mysql weird error in 12.1

  1. #1

    Default mysql weird error in 12.1

    hey guys,

    I get a weird error when I try to run mysql for the first time

    Code:
    linux-h6kn:/home/harvested # mysql -hlocalhost -uroot -pas
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (111)
    even if the file exists and it's empty it still can't connect to the mysql server
    i've chect /etc/my.cnf and skip-networking is commented...
    i've read...countless forums for the last...4-5 hours and I still couldn't find a solution...

    thanks,
    Andrei

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,586
    Blog Entries
    14

    Default Re: mysql weird error in 12.1

    Yast - System - runlevel editor. Activate mysqld to start.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: mysql weird error in 12.1

    hey,
    thanks for the info
    unfortunately i got this error
    Code:
    /etc/init.d/mysql start returned 1 (unspecified error):

  4. #4

    Default Re: mysql weird error in 12.1

    harvested wrote:
    > hey,
    > thanks for the info
    > unfortunately i got this error
    >
    > Code:
    > --------------------
    >
    > /etc/init.d/mysql start returned 1 (unspecified error):
    >
    > --------------------


    so what is in the log?

  5. #5

    Default Re: mysql weird error in 12.1

    ok, I've managed to solve the problem
    so, mym mistake was...after I zypper-ed in mysql I've run
    Code:
    mysql_install_db
    which I shouldn't
    the proper way is to install mysql and then
    Code:
    service mysql start
    which starts the server and the connect to it..using the client..
    I've removed the server and installed it again..and now it works fine...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •