Results 1 to 4 of 4

Thread: KDE Desktop Switching Limited to Two Desktops After Logout/Login

  1. #1

    Default KDE Desktop Switching Limited to Two Desktops After Logout/Login

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Dell Latitude E6410
    01:00.0 VGA compatible controller: nVidia Corporation GT218 [NVS 3100M]
    (rev a2)
    NVidia proprietary drivers
    OpenSUSE 12.1 x86_64
    KDE 4.7 (I think... whatever is default)
    All patches as of yesterday (2012-01-30) morning, MST.

    With all of that out there, Disclaimer: I'm not as familiar with KDE as
    with Gnome. I have stumbled upon what I am fairly sure is a bug and
    while I will report it I am curious if there are ideas for workarounds.

    When I setup my system I wanted it to work a little more like my old
    Gnome 2.x system did, specifically with four workspaces (desktops)
    organized laterally. Why? Because I do. I found how to enable
    shortcuts to move between desktops in a relative way (from left to
    right) so I have setup Ctrl+Alt+[arrow] (left or right) to move through
    them. I renamed the desktops 0, 1, 2, and 3 because I like it that way,
    though that's likely irrelevant. After setting this up I removed the
    Desktop pager because I don't need it and it wastes (imo) panel space.
    Voila, everything is bliss.

    Logout/Login

    In a reproducible way (every time I logout/login) I find that while my
    customized shortcuts to move through desktops/workspaces still work (I
    can still move to the next/previous desktop) I can only do so between
    the current one and one other. I cannot, for example, go from 0 -> 1 ->
    2 -> 3 -> 0 -> 1 as usual.... I can only go from 0 -> 1 -> 0 -> 1; it is
    wrapping around too soon. Wrapping around is enabled so that's okay,
    but it seems to ignore my other desktops. If I use the default
    shortcuts to go directly to a specific desktop (Ctrl+F3 for example)
    then I can swap between that one and one other beside it... but only to
    one other (and then back and forth, back and forth). So to summarize I
    can get to any desktop using Ctrl+F[1-4], and I can even send windows to
    any desktop (To Desktop -> [choose desktop, as they are all listed
    correctly) but I cannot use the Ctrl+Alt keys to switch among all of them.

    Clear as mud? Here's where the bug part comes in. If I go to the
    Virtual Desktop pager settings and increase the 'Number of rows' to 2,
    then put it back down to 1 (I have it set to 1 normally) the entire
    problem goes away and my Ctrl+Alt+[arrow] functionality is perfectly
    restored until the next time I logout/login. Basically I am doing
    nothing other than refreshing the system since I'm changing from 1, to
    2, then back to 1, but it seems to be enough. I have not (yet) tried
    making other changes to see if it is nothing more than a refresh or if
    it has to do with this specific setting. To test this setting, though,
    I have tried moving "down" to other desktops but they are not accessible
    as far as I can tell. My testing may be off on this one, so I'm open
    for any input.

    Happy Computing.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.18 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJPKAD2AAoJEF+XTK08PnB5uSIP/2iKIrx8vJJpJcKmqf3NGmQl
    MlLuP7ZSey3OAQ4FWzJjLfnQQrRCrQ32SMyx3sB9sctfYv7Z/ZWsQUcGpRKScQjS
    fhpHrniGu4hKDfVLKzFTtaLkHSYi489r4bqkT4qWOIys1Bb1DD8f7NrO0d1L6Iy0
    Xw1wJdLNkbx0lO54oW8oRJ5Jy6J17xGaumiBxi9hAJfay2N5E6c50dm518C2X1iN
    ctKzvLkZbsBdEXJp1G0InzXkzoLLak3GzSdaPQ8waDeMcqEI1e3hvVdTD7a4sIYk
    4+d8FWIYypYqWlLvUS8AMgMtn6P+0bG4621gCuh93LfeZtYIRgw1WRzFYMfKBDmu
    lptZHwhBMIROrFG1u8cg6O87uwMQYNn/Zf+Fa4G23Tx9+ntTbrXqQcTeL2M1M9ye
    q4y/mOZksOGTOLShuZVO169fVk2OQizsybSqLQSJcvxT0COm1g5QnINZveiuph4L
    ZeucEo2zQYDpn0wsU09g8JFfw0jfz9ueNoy8yUZ9mCsghUfd5JVKRgdoRFoBgVts
    vD3ZZ1Qg5TJGe7xXDsGHWl2b9VfMQl0IgNC8+Y2/ZNzEGDypbm5UNcRXieOvex7s
    EmQo/5lMa7gvFnafOTHmY7bOHD+GdXp4ENTLbb9LLi5+QzmVDuFd5SQp55skg048
    xTwEBRnWGpc4SaaXWFO9
    =Dsf/
    -----END PGP SIGNATURE-----

  2. #2
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: KDE Desktop Switching Limited to Two Desktops After Logout/Login

    On Tue, 31 Jan 2012 20:25:51 +0530, ab <ab@novell.com> wrote:

    > In a reproducible way (every time I logout/login) I find that while my
    > customized shortcuts to move through desktops/workspaces still work (I
    > can still move to the next/previous desktop) I can only do so between
    > the current one and one other. I cannot, for example, go from 0 -> 1 ->
    > 2 -> 3 -> 0 -> 1 as usual.... I can only go from 0 -> 1 -> 0 -> 1; it is
    > wrapping around too soon. Wrapping around is enabled so that's okay,
    > but it seems to ignore my other desktops. If I use the default
    > shortcuts to go directly to a specific desktop (Ctrl+F3 for example)
    > then I can swap between that one and one other beside it... but only to
    > one other (and then back and forth, back and forth). So to summarize I
    > can get to any desktop using Ctrl+F[1-4], and I can even send windows to
    > any desktop (To Desktop -> [choose desktop, as they are all listed
    > correctly) but I cannot use the Ctrl+Alt keys to switch among all of
    > them.
    >Clear as mud? Here's where the bug part comes in. If I go to the
    > Virtual Desktop pager settings and increase the 'Number of rows' to 2,
    > then put it back down to 1 (I have it set to 1 normally) the entire
    > problem goes away and my Ctrl+Alt+[arrow] functionality is perfectly
    > restored until the next time I logout/login. Basically I am doing
    > nothing other than refreshing the system since I'm changing from 1, to
    > 2, then back to 1, but it seems to be enough. I have not (yet) tried
    > making other changes to see if it is nothing more than a refresh or if
    > it has to do with this specific setting. To test this setting, though,
    > I have tried moving "down" to other desktops but they are not accessible
    > as far as I can tell. My testing may be off on this one, so I'm open
    > for any input.



    i think you're correct that there is a bug somewhere, but i'm not sure
    what the intended behavior really is.

    it appears that the spacial arrangement of desktops is always taken from
    the pager in the original panel at the bottom of the screen -- and if
    there isn't any pager in that panel, or no panel at all, then it's taken
    from the pager that _would_ be there by default.

    i'm using 9 desktops arranged in 3 rows / 3 columns with a pager in a
    vertical panel at the right side of my screen, and unless i put an
    identical, tiny pager into the default panel at the bottom of the screen,
    movement through the available desktops jumps erratically after
    login/logout.

    i must admit that i'm too lazy to take this up as a bug report, since i'm
    pretty sure a huge discussion would ensure, with people / developers
    claiming that it should behave in this, that, or some other way, everybody
    getting emotional, etc.

    i just live with a tiny additional pager in the bottom panel which is
    pretty useless because of it's size, but doesn't really bother me, for the
    same reason.


    you write that you can access only 2 of your 4 desktops; are you sure
    you're using the shortcuts for "next desktop," not "desktop to the right?"
    because if you have more than one row, "desktop to the right" will keep
    you rotating in one and the same row, while "next desktop" will actually
    go through all the available desktops, even if erratically if you don't
    have the same layout in the bottom panel pager.

    --
    phani.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,352
    Blog Entries
    3

    Default Re: KDE Desktop Switching Limited to Two Desktops After Logout/Login

    Try this:

    Logout from your desktop.

    Use CTRL-ALT-F1 to get a virtual console, and login there.

    While logged into the virtual console:
    Code:
    cd /var/tmp
    rm -rf kdecache-$USER
    Then logout from the virtual console, and log back into the desktop.

    I don't know if that will help. It forces the cache to be rebuilt. From your description, it sounds as if there might be stale information in the cache causing problem.
    openSUSE Leap 15.1; KDE Plasma 5;

  4. #4

    Default Re: KDE Desktop Switching Limited to Two Desktops After Logout/Login

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Adding the pager to my desktop works around the problem. The ideas
    about defaults make sense. I'll try to do some additional testing and
    will see what comes of a bug; I'll post back if/when I create it.

    Thanks, both of you, for your time.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.18 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJPKHx2AAoJEF+XTK08PnB5sk0P/jKKpi5VTPfdiLnnRYNoc/Ku
    ZbR/HurAjOnE0F2nzPUwoB1lNF+JrswKxNQOhHrG3n/ysS5Hh5ElEyaxIWjNChUl
    yaX4jyIrv4OO9KGsV1l1AAsLkX2XiN+uoG1pYbwBF5YCPNOZEpSMbQxEKU/Ae3vn
    TnSCLG1h59b3IqIzZKSIXqPbvZfseZ0z4tP9E9UyrRs1cJjc4l2CkdUdJjqwMQg2
    wObzaBW/WJeSWRc4vQDQAXfRN8Uhty2fVbScX2IdfGFFwrwrAbCU4QNEzL6pLtkR
    Yeuj9L8c0gOBUmL47uvOffjcVT8WN59gAspHL+aAhRVrGLd1ZGowKLusrcbrKHZZ
    j936xb4V9k0Z94ouvf1c5eGdzSPC0GQ+d+eYMeivC0m/nuWDTB6lmOQkbNdpK1/t
    +XVzLW7QlgsyiYEHT80LiAMFURtAlnkNHtek+F9XjISEdR859TCyIyT6GAxDaKhD
    FsL5KJKNY5nkxDeWsXnzUpIgUsNaZ1tzD13TUGVW9SNSyykPFj/oxILBRWkuwipD
    Shurjf6F+wTZsn7hheSLClrFxCAn5/6bn3rRdhcmiqWrqNSVzw98FFYxfgxgLwnl
    92QaqiS0R18m03M1y7ZsbI733tSZdie15Hn5jgjjeYa5QXQV99EmLnDLOSMbhdiJ
    jsyHD6ii8jkB+sJRmVbG
    =XluD
    -----END PGP SIGNATURE-----

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •