Results 1 to 9 of 9

Thread: Digikam will not run under KDE 4.8

  1. #1
    Join Date
    Nov 2010
    Location
    Denmark
    Posts
    11

    Default Digikam will not run under KDE 4.8

    After updating my Opensuse 12.1 installation to KDE 4.8, Digikam will no longer run. I get this output:

    thomas@machine:~> digikam
    digikam: symbol lookup error: /usr/lib/libIlmImf.so.6: undefined symbol: _ZTIN9IlmThread5MutexE

    Here are my repositories:

    thomas@machine:~> sudo zypper repos
    root's password:
    # | Alias | Navn | Aktiveret | Genopfrisk
    ---+-----------------------+----------------------------+-----------+-----------
    1 | KR48 | KR48 | Ja | Ja
    2 | devel:libraries:c_c++ | devel:libraries:c_c++ | Ja | Ja
    3 | home:garminplugin | home:garminplugin | Ja | Ja
    4 | openSUSE_12.1 | App:Geo | Ja | Ja
    5 | packman-essentials | packman-essentials | Ja | Ja
    6 | packman-multimedia | packman-multimedia | Ja | Ja
    7 | repo-debug | openSUSE-12.1-Debug | Nej | Ja
    8 | repo-debug-update | openSUSE-12.1-Update-Debug | Nej | Ja
    9 | repo-non-oss | openSUSE-12.1-Non-Oss | Ja | Ja
    10 | repo-oss | openSUSE-12.1-Oss | Ja | Ja
    11 | repo-source | openSUSE-12.1-Source | Nej | Ja
    12 | repo-update | openSUSE-12.1-Update | Ja | Ja

    Any ideas how to solve it?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: Digikam will not run under KDE 4.8

    Please use CODE tags around computer text: http://forums.opensuse.org/english/i...ags-guide.html
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,048
    Blog Entries
    14

    Default Re: Digikam will not run under KDE 4.8

    Question: how did you update to KDE 4.8 ? Digikam works fine here.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Nov 2010
    Location
    Denmark
    Posts
    11

    Default Re: Digikam will not run under KDE 4.8

    Quote Originally Posted by Knurpht View Post
    Question: how did you update to KDE 4.8 ? Digikam works fine here.
    Just added the KR48 repo and removed the KR47 and then did a
    Code:
    sudo zypper -v update
    and
    Code:
    suco zypper dup

  5. #5
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,507

    Default Re: Digikam will not run under KDE 4.8

    Digikam is used at least weekly without problems

    Code:
    <2012Feb01><18:11><~/Updates/Tumbleweed_12.1/repos> sh repos.sh
    #  | Name                               | Enabled | Refresh | Priority | Type     | URI                                                                                   | Service
    ---+------------------------------------+---------+---------+----------+----------+---------------------------------------------------------------------------------------+--------
     1 | google-earth                       | Yes     | No      |   98     | rpm-md   | http://dl.google.com/linux/earth/rpm/stable/x86_64                                    |        
     2 | manual_installs                    | No      | No      |   99     | plaindir | dir:///home/michael/Updates/Tumbleweed_12.1/rpm                                       |        
     3 | openSUSE-Current_non-oss           | Yes     | No      |   98     | yast2    | http://download.opensuse.org:80/distribution/openSUSE-current/repo/non-oss/           |        
     4 | openSUSE-Current_oss               | Yes     | No      |   98     | yast2    | http://download.opensuse.org:80/distribution/openSUSE-current/repo/oss/               |        
     5 | openSUSE-Current_update            | Yes     | No      |   98     | rpm-md   | http://download.opensuse.org:80/update/openSUSE-current/                              |        
     6 | openSUSE-KDE4.8_12.1               | Yes     | No      |   96     | rpm-md   | http://download.opensuse.org:80/repositories/KDE:/Release:/48/openSUSE_12.1/          |        
     7 | openSUSE-Kernel_3.2                | Yes     | No      |   96     | rpm-md   | http://download.opensuse.org:80/repositories/Kernel%3a/stable/standard/               |        
     8 | openSUSE-Mozilla_12.1              | Yes     | No      |   96     | rpm-md   | http://download.opensuse.org:80/repositories/mozilla/openSUSE_12.1/                   |        
     9 | openSUSE-Tumbleweed-Packman_Bremen | Yes     | No      |   97     | rpm-md   | http://packman.iu-bremen.de:80/suse/openSUSE_Tumbleweed/                              |        
    10 | openSUSE-Tumbleweed-Packman_inode  | No      | No      |   99     | rpm-md   | http://packman.inode.at/suse/openSUSE_Tumbleweed/                                     |        
    11 | openSUSE-Tumbleweed                | Yes     | No      |   97     | rpm-md   | http://download.opensuse.org:80/repositories/openSUSE:/Tumbleweed/standard/           |        
    12 | openSUSE-Tumbleweed_LibreOffice    | Yes     | No      |   97     | rpm-md   | http://download.opensuse.org:80/repositories/LibreOffice:/Stable/openSUSE_Tumbleweed/ |
    Possibly your files
    digikam4.db
    or
    thumbnails-digikam.db
    have not been updated from an older version

    Linux linux-qz4c 3.2.2-4-desktop #1 SMP PREEMPT Sun Jan 29 21:07:58 UTC 2012 (62fc2fa) x86_64 x86_64 x86_64 GNU/Linux

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: Digikam will not run under KDE 4.8

    Quote Originally Posted by keellambert View Post
    Digikam is used at least weekly without problems

    Code:
    <2012Feb01><18:11><~/Updates/Tumbleweed_12.1/repos> sh repos.sh
    #  | Name                               | Enabled | Refresh | Priority | Type     | URI                                                                                   | Service
    ---+------------------------------------+---------+---------+----------+----------+---------------------------------------------------------------------------------------+--------
     1 | google-earth                       | Yes     | No      |   98     | rpm-md   | http://dl.google.com/linux/earth/rpm/stable/x86_64                                    |        
     2 | manual_installs                    | No      | No      |   99     | plaindir | dir:///home/michael/Updates/Tumbleweed_12.1/rpm                                       |        
     3 | openSUSE-Current_non-oss           | Yes     | No      |   98     | yast2    | http://download.opensuse.org:80/distribution/openSUSE-current/repo/non-oss/           |        
     4 | openSUSE-Current_oss               | Yes     | No      |   98     | yast2    | http://download.opensuse.org:80/distribution/openSUSE-current/repo/oss/               |        
     5 | openSUSE-Current_update            | Yes     | No      |   98     | rpm-md   | http://download.opensuse.org:80/update/openSUSE-current/                              |        
     6 | openSUSE-KDE4.8_12.1               | Yes     | No      |   96     | rpm-md   | http://download.opensuse.org:80/repositories/KDE:/Release:/48/openSUSE_12.1/          |        
     7 | openSUSE-Kernel_3.2                | Yes     | No      |   96     | rpm-md   | http://download.opensuse.org:80/repositories/Kernel%3a/stable/standard/               |        
     8 | openSUSE-Mozilla_12.1              | Yes     | No      |   96     | rpm-md   | http://download.opensuse.org:80/repositories/mozilla/openSUSE_12.1/                   |        
     9 | openSUSE-Tumbleweed-Packman_Bremen | Yes     | No      |   97     | rpm-md   | http://packman.iu-bremen.de:80/suse/openSUSE_Tumbleweed/                              |        
    10 | openSUSE-Tumbleweed-Packman_inode  | No      | No      |   99     | rpm-md   | http://packman.inode.at/suse/openSUSE_Tumbleweed/                                     |        
    11 | openSUSE-Tumbleweed                | Yes     | No      |   97     | rpm-md   | http://download.opensuse.org:80/repositories/openSUSE:/Tumbleweed/standard/           |        
    12 | openSUSE-Tumbleweed_LibreOffice    | Yes     | No      |   97     | rpm-md   | http://download.opensuse.org:80/repositories/LibreOffice:/Stable/openSUSE_Tumbleweed/ |
    Possibly your files
    digikam4.db
    or
    thumbnails-digikam.db
    have not been updated from an older version

    Linux linux-qz4c 3.2.2-4-desktop #1 SMP PREEMPT Sun Jan 29 21:07:58 UTC 2012 (62fc2fa) x86_64 x86_64 x86_64 GNU/Linux
    You use Tumbleweed repos and the OP doesn't. And there is a special Tumbleweed subforum to avoid such misunderstandings.
    Henk van Velden

  7. #7
    Join Date
    Nov 2010
    Location
    Denmark
    Posts
    11

    Default Re: Digikam will not run under KDE 4.8

    Tried creating new user, but the problem persists, so this is not related to database- or config-files. And yes, I am not using Tumbleweed.

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,048
    Blog Entries
    14

    Default Re: Digikam will not run under KDE 4.8

    Quote Originally Posted by whomas View Post
    Tried creating new user, but the problem persists, so this is not related to database- or config-files. And yes, I am not using Tumbleweed.
    run
    Code:
    zypper dup --from KR48
    If the problem persists, start digikam from a terminal window by entering "digikam" (without the quotes) on the command line. It will generate output in the terminal window. Post that here, between CODE tags.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Nov 2010
    Location
    Denmark
    Posts
    11

    Default Re: Digikam will not run under KDE 4.8

    Quote Originally Posted by Knurpht View Post
    run
    Code:
    zypper dup --from KR48
    If the problem persists, start digikam from a terminal window by entering "digikam" (without the quotes) on the command line. It will generate output in the terminal window. Post that here, between CODE tags.
    Hello,

    I managed to solve the problem now by removing the devel:libraries:c_c++ repository which I had enabled (I think maybe because of the garminplugin package I use). This repo had a nonworking libIlmImf package.

    Thanks for your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •