Results 1 to 7 of 7

Thread: can't update one program?

  1. #1

    Default can't update one program?

    Hi, Apper can't find something for an openSUSE update. Its hanging there
    for awhile.

    Message from Apper is this
    Code:
    patch:openSUSE-2012-36-1.noarch conflicts with
    libpixman-1-0-32bit.x86_64 < 0.24.0-2.3.1 provided by
    libpixman-1-0-32bit-0.22.2-666.1.x86_64
    Zypper brings me that message.

    Code:
    linux-7tnd:~ # zypper up
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
    ffmpeg lensfun-data libavcodec53 libavdevice53 libavfilter2
    libavformat53
    libavutil51 libepub0 libggz2 libiodbc3 liblensfun0 liblqr-1-0
    libpixman-1-0
    libpixman-1-0-32bit libqoauth1 libswscale2 smplayer vlc-noX xine-ui
    
    Nothing to do.
    Is there a way to update it or to kill it?

    I run 12.1 (x64) KDE 4.8


    --

    Windows, supports nearly all software, hardware, and viruses.
    Linux Counter: 548299 https://linuxcounter.net/

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: can't update one program?

    On 2012-01-31 00:59, JoergJaeger wrote:
    > Is there a way to update it or to kill it?


    Uninstall apper.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3

    Default Re: can't update one program?

    On 30.01.2012 16:38, Carlos E. R. wrote:
    > On 2012-01-31 00:59, JoergJaeger wrote:
    >> Is there a way to update it or to kill it?

    >
    > Uninstall apper.
    >


    Ok will do. But don't they fix apper sometime?
    Also, and that confuses me always, do i need these updates that are
    stored (from zypper)?

    --

    Windows, supports nearly all software, hardware, and viruses.
    Linux Counter: 548299 https://linuxcounter.net/

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: can't update one program?

    On 2012-01-31 01:56, JoergJaeger wrote:

    > Ok will do. But don't they fix apper sometime?


    Possibly, you can report the bug in bugzilla, or post somewhere where they
    are interested in apper, like the mail list. :-)

    Here you know that the general advice is to not use it at all.

    > Also, and that confuses me always, do i need these updates that are stored
    > (from zypper)?


    The problem is, that as I don't use apper I can not guess what it is trying
    to do or complaining about. I would try first the yast update manager, and
    if this one has nothing to update, then I would see the plain (yast)
    package manager, see what it says in the version tab for libpixman.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5

    Default Re: can't update one program?

    On 30.01.2012 17:13, Carlos E. R. wrote:
    > On 2012-01-31 01:56, JoergJaeger wrote:
    >
    >> Ok will do. But don't they fix apper sometime?

    >
    > Possibly, you can report the bug in bugzilla, or post somewhere where they
    > are interested in apper, like the mail list. :-)
    >
    > Here you know that the general advice is to not use it at all.
    >
    >> Also, and that confuses me always, do i need these updates that are stored
    >> (from zypper)?

    >
    > The problem is, that as I don't use apper I can not guess what it is trying
    > to do or complaining about. I would try first the yast update manager, and
    > if this one has nothing to update, then I would see the plain (yast)
    > package manager, see what it says in the version tab for libpixman.
    >


    Oh i think you misunderstood me. No this is not about the apper. This if
    i see zypper in terminal and it shows that there are some updates but
    they are not installed.
    I always wondered why it is there. Are those files that aren't important
    to be updated or from a different repository?

    --

    Windows, supports nearly all software, hardware, and viruses.
    Linux Counter: 548299 https://linuxcounter.net/

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: can't update one program?

    On 2012-01-31 02:19, JoergJaeger wrote:
    > Oh i think you misunderstood me. No this is not about the apper. This if i
    > see zypper in terminal and it shows that there are some updates but they
    > are not installed.
    > I always wondered why it is there. Are those files that aren't important to
    > be updated or from a different repository?


    Many possible reasons. That the possible updates have lower priority, or
    that they need a vendor change.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: can't update one program?

    On 01/31/2012 02:19 AM, JoergJaeger wrote:
    > This if i see zypper in terminal and it shows that there are some
    > updates but they are not installed.
    > I always wondered why it is there.


    if you had used apper and then looked at YaST Online Update or "zypper
    patch" and seen that apper was not installing _all_ patches which YaST
    wanted to--then you would know why we say to uninstall apper..

    or, if you installed all security updates with YaST Online Update or
    "zypper patch" and then saw things remaining to be installed by apper
    you would see another reason we say to unistall apper..

    or, if you installed all security updates with YaST Online Update and
    then ran "zypper up" and saw remaining 'updates' that would be because
    YaST Online Update and "zypper up" are *NOT* the same thing..

    YaST Online Update and "zypper patch" *are* the same thing! both of
    those do security patches and major bug fixes which flow via the update
    repo _only_ (no other repo)

    "zypper up" has _nothing_ to do with the security patches and major bug
    fixes in the update repo, instead it is like opening YaST Software
    Manager and looking for all the the applications with newer dates (or
    later version numbers) than installed, which are available in all
    enabled repos that would not require vendor change to install..

    that is, "zypper up" will offer all installable updates which have no
    dependency problems, or which do not change package vendor...and that
    list is inherently different than the list available from YaST Online
    Update (and who knows [not me] what the list in apper offers)

    and, if looking in YaST Software Management for all packages with newer
    dates/version, including those which would require a vendor change, is
    like using the command "zypper update --all" (or "zypper up -a")

    note: it is possible that i don't know what i'm talking about...a
    through inspection of man zypper is in order for you [not for me because
    i stick to YaST, which is both less confusing and (if one stays away
    from "change vendor" and bleeding edge repos) most often produces a
    stable environment and almost _never_ mixes software in ways which
    causes a lot (most?) of the problems seen which are described as
    "suddenly" or "after today's update my blah blah is broken")]..

    ymmv

    --
    DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
    http://tinyurl.com/DD-Software
    Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •