Results 1 to 7 of 7

Thread: ffmpeg ask to uninstall libpostproc51-0.9.1-1.1.x86_64

  1. #1

    Default ffmpeg ask to uninstall libpostproc51-0.9.1-1.1.x86_64

    on my suse tumbleweed if I update ffmpeg and other software yast gives me this message:
    Code:
    #### YaST2 conflicts list - generated 2012-01-30 18:41:57 ####
    
    ffmpeg-0.10-1.2.x86_64 requires libavutil51 = 0.10-1.2, but this requirement cannot be provided
    uninstallable providers: libavutil51-0.10-1.2.i586[tumbleweed-packman]
                       libavutil51-0.10-1.2.x86_64[tumbleweed-packman]
        [ ] do not install ffmpeg-0.10-1.2.x86_64
    
        [ ] do not install ffmpeg-0.10-1.2.x86_64
    
        [ ] Following actions will be done:
    deinstallation of libpostproc51-0.9.1-1.1.x86_64
    downgrade of libxine1-codecs-1.1.20.1-60.2.x86_64 to libxine1-codecs-1.1.20.1-52.1.x86_64
        [ ] break ffmpeg by ignoring some of its dependencies
    
    
    
    
    #### YaST2 conflicts list END ###
    what is better to do? is it safe to uninstall libpostproc51-0.9.1-1.1.x86_64??? have I to wait??

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,884

    Default Re: ffmpeg ask to uninstall libpostproc51-0.9.1-1.1.x86_64

    I got the same on plain 11.4 when updating from Packman. There were a few downgrades also.

    I checked a bit around to see what levels were installed from where. There are also libpostproc51 and ..52 versions of this library available and I assumed that one of hem would be installed instead. Thus decided to choose the uninstall option (I choose to do the four downgrades in any case). All installed after this. I did not see any problems.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,102

    Default Re: ffmpeg ask to uninstall libpostproc51-0.9.1-1.1.x86_64

    libpostproc51 has been replaced by libpostproc52

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,884

    Default Re: ffmpeg ask to uninstall libpostproc51-0.9.1-1.1.x86_64

    Quote Originally Posted by dth2 View Post
    libpostproc51 has been replaced by libpostproc52
    It seems so. It is bit a pity that this is not resolved automaticaly.
    Henk van Velden

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: ffmpeg ask to uninstall libpostproc51-0.9.1-1.1.x86_64

    On 2012-01-30 22:36, hcvv wrote:
    >
    > dth2;2435624 Wrote:
    >> libpostproc51 has been replaced by libpostproc52

    > It seems so. It is bit a pity that this is not resolved automaticaly.


    Maybe it can not be done. It would work if the version number was part of
    the version number, not of the name.

    Or perhaps it could be done if the packager does something in the spec file
    to say that this file obsoletes such other file. Rings a bell, I don't know
    the details.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: ffmpeg ask to uninstall libpostproc51-0.9.1-1.1.x86_64

    Saw this too, seemes to be solved today.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: ffmpeg ask to uninstall libpostproc51-0.9.1-1.1.x86_64

    Quote Originally Posted by Knurpht View Post
    Saw this too, seemes to be solved today.
    oooookkkk, uninstalled, let's see whthappen maaaanythanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •