Results 1 to 6 of 6

Thread: Time Wrong After Reboot; Timeservers Unreachable

  1. #1

    Default Time Wrong After Reboot; Timeservers Unreachable

    The time displayed on the KDE panel is wrong after every restart. It's 5 hours early. I can't tell it to use a timeserver, either. Using the "Date/Time" section of "Personal Settings", it says every timeserver is unreachable. (And it asks me for a password on each attempt, which is ridiculous. Those of us who work alone or in a trusted environment should have an option of turning off all these incessant password demands.)

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,651

    Default Re: Time Wrong After Reboot; Timeservers Unreachable

    Are you dual booting with Windows? Windows assumes the internal clock is at local time and Linux assumes it is UTC. Set the clock to Local. Not sure why time server would be unreachable. But that seems like a network problem.

    Those passwords are there for protection. With out them you would just be running Windows and be vulnerable to any old virus that came along. Any changers to the system must know the root password and time is a system level process.

  3. #3

    Default Re: Time Wrong After Reboot; Timeservers Unreachable

    Quote Originally Posted by gogalthorp View Post
    Are you dual booting with Windows? Windows assumes the internal clock is at local time and Linux assumes it is UTC. Set the clock to Local. Not sure why time server would be unreachable. But that seems like a network problem.
    No dual booting here. The network is otherwise fine.

    Those passwords are there for protection. With out them you would just be running Windows and be vulnerable to any old virus that came along. Any changers to the system must know the root password and time is a system level process.
    I have to disagree. I was asked for my password when I opened the date/time widget, then I was asked again for my password when I clicked on the URL of each individual timeserver. That is not necessary and no additional protection comes from it. I'm not sure how allowing me to click on the URL of a timeserver in a fundamental KDE configuration tool without repeatedly entering my password poses any kind of security threat. This, frankly, smacks of unthinking overzealousness.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,370
    Blog Entries
    3

    Default Re: Time Wrong After Reboot; Timeservers Unreachable

    Quote Originally Posted by wagerrard View Post
    The time displayed on the KDE panel is wrong after every restart. It's 5 hours early.
    I might be wrong. But it looks to me as if the time is not being saved to the system clock on shutdown. That's probably a "systemd" related bug.

    After next setting the time correct, run
    Code:
    /sbin/hwclock -w
    as root. That should get your CMOS clock set correctly.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Time Wrong After Reboot; Timeservers Unreachable

    On 2012-01-29 15:06, wagerrard wrote:

    > I have to disagree. I was asked for my password when I opened the
    > date/time widget, then I was asked again for my password when I clicked
    > on the URL of each individual timeserver. That is not necessary and no
    > additional protection comes from it. I'm not sure how allowing me to
    > click on the URL of a timeserver in a fundamental KDE configuration tool
    > without repeatedly entering my password poses any kind of security
    > threat. This, frankly, smacks of unthinking overzealousness.


    It happens that changing time in Linux requires administration privileges,
    and this is an intentional feature. If KDE requires you to enter the
    password more than once, is a bug you can report at the appropriate place
    (which is not here, we are just users helping users).

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Time Wrong After Reboot; Timeservers Unreachable

    On 2012-01-29 15:36, nrickert wrote:

    > After next setting the time correct, run
    >
    > Code:
    > --------------------
    >
    > /sbin/hwclock -w
    >
    > --------------------
    >
    > as root. That should get your CMOS clock set correctly.


    Don't forget to delete /etc/adjtime after it, and adjust the clock before it.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •