Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: policykit password unknown or broken

  1. #1

    Default policykit password unknown or broken

    I am at the moment unable to use wireless internet nor my UMTS Modem on my laptop. Why? I installed 12.1, that's why? Why trying to make secure what is already secure? Why annoying users with yet another password prompt when it simply comes to making an Internet connection?

    At the moment I tried every password known in this system but none allow me to change anything in networkmanager. What is the policykit password? How to change it? Can it be blank please or no prompt at all?
    I think my SIM card pin is secure enough to protect the UMTS

    Is this only in KDE or do they annoy me also in Gnome? Or should I reinstall Windows again after 10 years or buy a Mac OS for big $ ?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,015
    Blog Entries
    1

    Default Re: policykit password unknown or broken

    Normally, kwallet takes care of internet passphrase authentication. Is it possible you set it up with your root password, or maybe a wireless password unintentionally?

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,193
    Blog Entries
    3

    Default Re: policykit password unknown or broken

    Make sure that you are up to date with all system updates. Run online updates in Yast.

    What you are seeing is mostly a NetworkManager problem. However, since 12.1 came out, there was a major update to NetworkManager that greatly improved things. There are still problems, in my opinion. But, with the updates, privately setting up network connections works without the root password. In KDE, you will be asked for the kde-wallet password. If you setup kde-wallet to stay open, then that should only happen once per login session.

    If you have defined shared network connections (system connections), then any change to a defined connection will require the root password.
    openSUSE Leap 15.1; KDE Plasma 5;

  4. #4

    Lightbulb Get rid of Network-manager policykit prompts

    Yes, I am up-to-date, and yes that might have happened that unintentionally I set a kwallet password where there wasn't one before.

    Somebody gave me a better solution that gets rid of all password asking all together. I share it here for people with similar problems and annoyances:

    1. Edit /etc/polkit-default-privs.local and add the following lines:

      org.freedesktop.network-manager-settings.system.modify yes
      org.freedesktop.network-manager-settings.system.hostname.modify yes
      org.freedesktop.network-manager-settings.system.wifi.share.protected yes
      org.freedesktop.network-manager-settings.system.wifi.share.open yes
      org.freedesktop.NetworkManager.enable-disable-network yes
      org.freedesktop.NetworkManager.enable-disable-wifi yes
      org.freedesktop.NetworkManager.enable-disable-wwan yes
      org.freedesktop.NetworkManager.use-user-connections yes
      org.freedesktop.NetworkManager.network-control yes
      org.freedesktop.NetworkManager.sleep-wake yes
      # bnc#680140
      org.freedesktop.NetworkManager.enable-disable-wimax yes
      org.freedesktop.NetworkManager.wifi.share.protected yes
      org.freedesktop.NetworkManager.wifi.share.open yes
      org.freedesktop.NetworkManager.settings.modify.own yes
      org.freedesktop.NetworkManager.settings.modify.system yes
      org.freedesktop.NetworkManager.settings.modify.hostname yes

      org.freedesktop.packagekit.system-network-proxy-configure yes
      org.freedesktop.ModemManager.Device.Control yes

      Whenever you still get a password prompt, let it fail on you with a wrong password and the last dialog window the org.freedesktop parameter that is still missing. Simply copy and past it to the end of the file with a yes. In fact the last line I added was done in this way, because I could not enter my SIM prompt without a password prompt.
    2. run from the console command line:

      /sbin/set_polkit_default_privs as root to compile the changes

    This effectively eliminated all policy kit prompts.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,015
    Blog Entries
    1

    Default Re: Get rid of Network-manager policykit prompts

    There is a guide on that here:

    Chapter

    However, for security reasons I don't like the idea of doing away with authentication completely.

  6. #6

    Default Re: Get rid of Network-manager policykit prompts

    Still having problems. Now apparently the package update also uses policykit and again my root password is not recognised. What is wront here? Is there a way to get policykit recognise the root password, reset or sync it somehow?

  7. #7

    Default Re: Get rid of Network-manager policykit prompts

    /etc/PolicyKit/PolicyKit.conf is empty, I mean it only has:

    <?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->

    <!DOCTYPE pkconfig PUBLIC "-//freedesktop//DTD PolicyKit Configuration 1.0//EN"
    "http://hal.freedesktop.org/releases/PolicyKit/1.0/config.dtd">

    <!-- See the manual page PolicyKit.conf(5) for file format -->

    <config version="0.1">
    </config>
    Is that normal?

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: policykit password unknown or broken

    On 2012-02-04 23:06, erniecom wrote:
    > Is that normal?


    Yes.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  9. #9

    Default Re: policykit password unknown or broken

    The policykit password is still bothering me with the apper upgrade. It asks authentication, I give the root password, just like on my desktop, but on my laptop it fails to authenticate. How to reset / resync Policykit password or how to make it authenticate with the root password (again)?

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,015
    Blog Entries
    1

    Default Re: policykit password unknown or broken

    I don't use apper, so I can't advise directly. Can you update via zypper instead?

    In a terminal (as root)
    Code:
    zypper up

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •