Results 1 to 6 of 6

Thread: KDE Logout

  1. #1

    Default KDE Logout

    I wonder why, if i log out of KDE, the screen is filled with all kinds
    of image junk.
    Is there a way to prevent that?
    Observed on 12.1 KDE 4.7

    ---
    Windows, supports nearly all software, hardware, and viruses.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: KDE Logout

    On 01/28/2012 10:37 PM, JoergJaeger wrote:
    > I wonder why, if i log out of KDE, the screen is filled with all kinds
    > of image junk.
    > Is there a way to prevent that?
    > Observed on 12.1 KDE 4.7


    -has it always done that?
    -does it do it every log out?
    -how did you initiate the log out?
    -do you have other DEs installed? if so do they do it also?
    -any other video abnormalities?
    -what video/graphic adapter, and what driver?
    -are you running Tumbleweed?

    --
    DD
    Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

  3. #3

    Default Re: KDE Logout

    On 28.01.2012 13:56, DenverD wrote:
    > On 01/28/2012 10:37 PM, JoergJaeger wrote:
    >> I wonder why, if i log out of KDE, the screen is filled with all kinds
    >> of image junk.
    >> Is there a way to prevent that?
    >> Observed on 12.1 KDE 4.7

    >
    > -has it always done that?
    > -does it do it every log out?
    > -how did you initiate the log out?
    > -do you have other DEs installed? if so do they do it also?
    > -any other video abnormalities?
    > -what video/graphic adapter, and what driver?
    > -are you running Tumbleweed?
    >


    Aeh....

    1) yes
    2) yes
    3) menu
    4) standard KDE (and whatever is installed at default)
    5) no
    6) Evga8800GT / Nvidia repo (ftp://download.nvidia.com/opensuse/12.1/)
    7) no

    This is actually going since i have KDE 4. But i just like to find out
    if i can prevent it or if i have to live with it.
    Also it is, to some extend, a security issue since the last status is in
    the pixel junk. Maybe its a buffer issue.
    Not sure if i can track something like that with a command.

    --

    Windows, supports nearly all software, hardware, and viruses.
    Linux Counter: 548299 https://linuxcounter.net/

  4. #4

    Default Re: KDE Logout

    On 28.01.2012 15:25, JoergJaeger wrote:
    > On 28.01.2012 13:56, DenverD wrote:
    >> On 01/28/2012 10:37 PM, JoergJaeger wrote:
    >>> I wonder why, if i log out of KDE, the screen is filled with all kinds
    >>> of image junk.
    >>> Is there a way to prevent that?
    >>> Observed on 12.1 KDE 4.7

    >>
    >> -has it always done that?
    >> -does it do it every log out?
    >> -how did you initiate the log out?
    >> -do you have other DEs installed? if so do they do it also?
    >> -any other video abnormalities?
    >> -what video/graphic adapter, and what driver?
    >> -are you running Tumbleweed?
    >>

    >
    > Aeh....
    >
    > 1) yes
    > 2) yes
    > 3) menu
    > 4) standard KDE (and whatever is installed at default)
    > 5) no
    > 6) Evga8800GT / Nvidia repo (ftp://download.nvidia.com/opensuse/12.1/)
    > 7) no
    >
    > This is actually going since i have KDE 4. But i just like to find out
    > if i can prevent it or if i have to live with it.
    > Also it is, to some extend, a security issue since the last status is in
    > the pixel junk. Maybe its a buffer issue.
    > Not sure if i can track something like that with a command.
    >


    I updated to 4.8 now and it appears that (if its a buffer issue) it goes
    really blank with a second still having pixel junk. So in essence it is
    solved since the log out screen or shutdown etc.. is blank with the menu
    bar visible in the center.
    Have to observe this a little more.

    --

    Windows, supports nearly all software, hardware, and viruses.
    Linux Counter: 548299 https://linuxcounter.net/

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,880
    Blog Entries
    3

    Default Re: KDE Logout

    Quote Originally Posted by yester64 View Post
    I wonder why, if i log out of KDE, the screen is filled with all kinds
    of image junk.
    That happened to me, also. I saw this on a computer with nvidia graphics, and on another computer with radeon graphics. However, a system with intel graphics was fine.

    For both nvidia and radeon graphics, I was using the standard drivers that came with the install. Switching to the proprietary nvidia drivers might help, though I haven't tried that.

    Somebody suggested defining
    XLIB_SKIP_ARGB_VISUALS=1
    in the environment. Doing this is supposedly incompatible with desktop effects. But I turn off desktop effects anyway, so I tried that environment setting. It completely solved the problem.

    To set, you could put in your $HOME/.profile
    Code:
    XLIB_SKIP_ARGB_VISUALS=1
    export XLIB_SKIP_ARGB_VISUALS
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6

    Default Re: KDE Logout

    On 28.01.2012 15:46, nrickert wrote:
    >
    > yester64;2435019 Wrote:
    >> I wonder why, if i log out of KDE, the screen is filled with all kinds
    >> of image junk.

    >
    > That happened to me, also. I saw this on a computer with nvidia
    > graphics, and on another computer with radeon graphics. However, a
    > system with intel graphics was fine.
    >
    > For both nvidia and radeon graphics, I was using the standard drivers
    > that came with the install. Switching to the proprietary nvidia drivers
    > might help, though I haven't tried that.
    >
    > Somebody suggested defining
    > XLIB_SKIP_ARGB_VISUALS=1
    > in the environment. Doing this is supposedly incompatible with desktop
    > effects. But I turn off desktop effects anyway, so I tried that
    > environment setting. It completely solved the problem.
    >
    > To set, you could put in your $HOME/.profile
    >
    > Code:
    > --------------------
    >
    > XLIB_SKIP_ARGB_VISUALS=1
    > export XLIB_SKIP_ARGB_VISUALS
    >
    > --------------------
    >
    >


    Ah, there we getting somewhere.
    Ok, i will try the setting. Though,like i mentioned, with 4.8 it seems
    to be almost fine in default.
    I use the standard candies with the KDE.
    Still, i have the feeling its a buffer issue. Perhaps it doesn't get
    flushed or something.

    --

    Windows, supports nearly all software, hardware, and viruses.
    Linux Counter: 548299 https://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •