Results 1 to 7 of 7

Thread: BOINC + openSUSE 12.1 = failure

  1. #1

    Default BOINC + openSUSE 12.1 = failure

    Hi all: I am getting a bit frustrated trying to get BOINC running on my freshly installed opensuse 12.1 box. I have tried to get things running two different ways, with each met with failure.

    1. I installed BOINC client and manager via the opensuse repositories. There is a bug in the repository install involving a missed-named file (for launching the manager gui) which I fixed. However, I cannot successfully launch the client as it returns an error stating it needs to be initialized. That's fine but I can't initialize it via the manager without the client running.

    Does anyone have a proven recipe to get BOINC running via the repository install?

    2. I have also tried installing via the latest installer from BOINC. Installer runs fine and I can get the boinc-client running without issue. However, I cannot get the manager to run to a library mismatch with opensuse 12.1 (needs libnotify1 but opensuse provides libnotify4).

    So, does anyone have a suggestion on how to get this install method working?

    Thanks, Chris.

  2. #2
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,120

    Default Re: BOINC + openSUSE 12.1 = failure

    I've been running boinc 6.10.58 from the berkely site for quite some time. Upgrading to 12.1 caused no problems. Perhaps this older version will work for you. If not, search the berkley forums for linux. Though not as friendly as this forum, they can probably get you started. Another thought: did you try to find libnotify1 and put it where boinc wants it?
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  3. #3

    Default Re: BOINC + openSUSE 12.1 = failure

    Thanks for the reply. I suspect your upgraded system still has all the needed dependencies. My problem is I have a fresh install and the boinc implementation is broken. Per your advice and that from the boinc site, I have tried the downloaded version and created a soft link for libnotify.so.1, but still no joy.

    What bugs me is that openSUSE documentation on setting up the boinc-client is very poor, almost non-existent.

  4. #4
    Join Date
    Feb 2012
    Location
    Swansea
    Posts
    13

    Default Re: BOINC + openSUSE 12.1 = failure

    how did you fixed the boinc manager issue. I have same problem.

  5. #5

    Default Re: BOINC + openSUSE 12.1 = failure

    Yes I did, and I should have reported back. First off I made sure to blow away all traces on the BOINC client installed via the repo. I then downloaded the BOINC client for opensuse 11.4, which is version 6.12.22. Following the download I copied the install file (something.sh) to /opt and made sure it was executable. I then ran the install which created /opt/BOINC.

    Following the install I changed ownership to BOINC (I was doing all the install stuff as root). I created a new user BOINC and group BOINC which is the user I used. At this point you should have a working BOINC client and manager. Lastly I downloaded a startup script for BOINC, edited it to point to correct location, and placed it in /etc/init.d.

    But alas it still has issues. Apparently there is a bug which prevents this client from attaching to a project manager like BAMstats. I just attached to my projects directly.

    I have reported these bugs to bugzilla but I suspect nothing much will come of it. One of the bugs is so blatantly obvious I wonder how it made it out of beta (wrongly named file boinc_gui instead of boinc-gui).

    Good luck. Report back if this helps or if you have more troubles.

  6. #6
    Join Date
    Feb 2012
    Location
    Swansea
    Posts
    13

    Default Re: BOINC + openSUSE 12.1 = failure

    Which startup script?

    Also


    ./boincmgr: error while loading shared libraries: libnotify.so.1: cannot open shared object file: No such file or directory

  7. #7

    Default Re: BOINC + openSUSE 12.1 = failure

    Quote Originally Posted by nox331 View Post
    Which startup script?

    Also


    ./boincmgr: error while loading shared libraries: libnotify.so.1: cannot open shared object file: No such file or directory
    Download version 1.1.1 of the script from here: rigo's Homepage - Tools

    As far as the binary goes, download 6.12.22 here: 64 (and 32) bit Linux BOINC OpenSuse (english version is listed second).

    Give that a try. Good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •