Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Autodesk Maya 2012

  1. #1
    Join Date
    Feb 2011
    Location
    Athens, Greece
    Posts
    47

    Default Autodesk Maya 2012

    Hello all,

    I am using openSuSE 12.1 with KDE 4.7 (Plasma Desktop).
    Over the past few months I made quite a few attempts to install Maya 2012 with no success, so I decided to ask some help.

    I downloaded Maya 2012 SAP.
    Installed the rpms through apper, dependencies solved etc.
    I click on the "Autodesk Maya 2012" icon, I get the bouncing icon of Maya next to my cursor, but the program does not start.

    Any ideas?

    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: Autodesk Maya 2012

    FInd out what the executable is to start Maya, then start it from a terminal. It will throw output in the terminal, copy and paste that here, between CODE tags.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Feb 2011
    Location
    Athens, Greece
    Posts
    47

    Default Re: Autodesk Maya 2012

    Quote Originally Posted by Knurpht View Post
    FInd out what the executable is to start Maya, then start it from a terminal. It will throw output in the terminal, copy and paste that here, between CODE tags.
    Ok here it is:
    On
    Code:
    ./maya2012-x64
    the output is:
    Code:
    bash: ./maya2012-x64: Too many levels of symbolic links
    In addition, here are the ls -l output from /usr/autodesk
    Code:
    /usr/autodesk # ls -l                                                     
    total 12                                                                                            
    drwxr-xr-x 12 root root 4096 Jan 26 13:00 Composite_2012                                            
    drwxr-xr-x  4 root root 4096 Jan 26 13:15 matchmover2012-x64                                        
    lrwxrwxrwx  1 root root   12 Jan 26 13:00 maya -> maya2012-x64
    drwxr-xr-x 28 root root 4096 Jan 26 13:15 maya2012-x64
    and form /usr/autodesk/maya2012-x64
    Code:
    /usr/autodesk/maya2012-x64> ls -l
    total 252
    drwxr-xr-x  5 root root  4096 Sep 26 21:31 adlm
    drwxr-xr-x  2 root root  4096 Jan 26 13:14 app-defaults
    drwxr-xr-x  3 root root  4096 Sep 26 21:31 assets
    drwxr-xr-x 13 root root  4096 Jan 26 13:15 bin
    drwxr-xr-x 41 root root  4096 Sep 26 21:31 brushes
    drwxr-xr-x  2 root root  4096 Jan 26 13:14 brushImages
    drwxr-xr-x  3 root root  4096 Jan 26 13:14 brushShapes
    drwxr-xr-x  2 root root  4096 Jan 26 13:14 desktop
    drwxr-xr-x 17 root root  4096 Sep 26 21:31 devkit
    drwxr-xr-x  4 root root  4096 Sep 26 21:31 docs
    drwxr-xr-x  6 root root  4096 Sep 26 21:31 ExternalWebBrowser
    drwxr-xr-x 15 root root  4096 Sep 26 21:31 GettingStarted
    drwxr-xr-x  4 root root  4096 Jan 26 13:14 Gifts
    drwxr-xr-x  8 root root 40960 Jan 26 13:14 icons
    drwxr-xr-x  5 root root  4096 Sep 26 21:31 include
    drwxr-xr-x  4 root root 12288 Jan 26 13:15 lib
    drwxr-xr-x  2 root root  4096 Sep 26 21:31 license_data
    -rw-r--r--  1 root root     4 Sep 26 21:37 license.type
    lrwxrwxrwx  1 root root    12 Jan 26 13:15 maya2012-x64 -> maya2012-x64
    drwxr-xr-x  5 root root  4096 Jan 26 13:14 mentalray
    drwxr-xr-x 14 root root  4096 Sep 26 21:31 presets
    drwxr-xr-x  2 root root  4096 Sep 26 21:31 Public
    -rwxr-xr-x  1 root root 39001 Sep 26 21:31 PYTHON_LICENSE
    -rw-r--r--  1 root root 54933 Sep 26 21:37 PYTHON_README
    drwxr-xr-x 10 root root  4096 Sep 26 21:31 qt-plugins
    drwxr-xr-x  2 root root  4096 Jan 26 13:15 qt-translations
    drwxr-xr-x  4 root root  4096 Jan 26 13:15 resources
    drwxr-xr-x 12 root root  4096 Jan 26 13:15 scripts
    drwxr-xr-x  2 root root  4096 Jan 26 13:15 substances
    drwxr-xr-x  5 root root  4096 Sep 26 21:31 support
    I guess these links are creating the problem? Maybe you can figure it out?

    Thanks for the help.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: Autodesk Maya 2012

    Well, I cannot look into your folders, but this
    Code:
    lrwxrwxrwx  1 root root    12 Jan 26 13:15 maya2012-x64 -> maya2012-x64
    is not OK. It's a symlink linked to itself, hence the error message. My guess is that it should be something like below, but it's up to you to check that
    Code:
    lrwxrwxrwx  1 root root    12 Jan 26 13:15 maya2012-x64 -> bin/maya2012-x64
    Anyway, normally the Maya executable would reside in the bin folder, take a look in there for the maya executable. If you doubt, post the content of that folder.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Feb 2011
    Location
    Athens, Greece
    Posts
    47

    Default Re: Autodesk Maya 2012

    Quote Originally Posted by Knurpht View Post
    Well, I cannot look into your folders
    Hence the copy paste of the "ls -l" output

    Ok, you were correct. There is a maya2012 executable file with the "maya" file linked to it, I guess for purposes of simplification.

    Here is the output when I run the file.
    Code:
    /usr/autodesk/maya2012-x64/bin> ./maya2012
    /usr/autodesk/maya2012-x64/bin/maya.bin: error while loading shared libraries: libssl.so.6: cannot open shared object file: No such file or directory
    A google search provided that "libssl.so.6" is in the openssl packages which I have installed but the only similar file I find is "libssl.so.1.0.0()(64bit)".

    Hope that tells you something. Thanks for you time.

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: Autodesk Maya 2012

    So, Maya uses an older version of libssl. You could try to create a symlink to the one that's installed, must be done with root permissions
    Code:
    su
    (enter rootpassword)
    ln -s /lib64/libssl.so.1.0.0 /lib64/libssl.so.6
    but I cannot guarantee this is going to work, yet it might.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Autodesk Maya 2012

    Am 27.01.2012 12:56, schrieb Knurpht:
    >
    > So, Maya uses an older version of libssl. You could try to create a
    > symlink to the one that's installed, must be done with root permissions
    >
    > Code:
    > --------------------
    >
    > su
    > (enter rootpassword)
    > ln -s /lib64/libssl.so.1.0.0 /lib64/libssl.so.6
    >
    > --------------------
    >
    > but I cannot guarantee this is going to work, yet it might.
    >
    >

    There are openssl compatibility packages if you search with zypper or
    yast, not sure if they contain exactly the needed version.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
    nVidia ION | 3GB Ram

  8. #8
    Join Date
    Feb 2011
    Location
    Athens, Greece
    Posts
    47

    Default Re: Autodesk Maya 2012

    Quote Originally Posted by Knurpht View Post
    So, Maya uses an older version of libssl. You could try to create a symlink to the one that's installed, must be done with root permissions
    Code:
    su
    (enter rootpassword)
    ln -s /lib64/libssl.so.1.0.0 /lib64/libssl.so.6
    but I cannot guarantee this is going to work, yet it might.
    Woohooo. That worked!! Now I am getting license errors but I guess that is a topic for another thread prolly in a nother forum maybe another time too

    Thanks, that was driving me mad.

    @martin_helm
    Thanks for your respond. I guess problem solved now but if I had to, how would I look for the compatibility packages you mentioned?

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Autodesk Maya 2012

    Am 27.01.2012 13:16, schrieb k-a:
    > @martin_helm
    > Thanks for your respond. I guess problem solved now but if I had to,
    > how would I look for the compatibility packages you mentioned?
    >

    I remember there were some programs which needed openssl 0.9.8 for
    example, so I did a
    Code:
    zypper search openssl
    on 12.1 which shows (beside a lot of other results)
    compat-openssl097g
    libopenssl0_9_8

    To be sure what .so versions they contain, I would download the rpms and
    run a "rpm -qlp the_downloaded.rpm" on them.

    But since the symlink works for you, it seems there is no need for this.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.8.0 |
    nVidia ION | 3GB Ram

  10. #10
    Join Date
    Feb 2011
    Location
    Athens, Greece
    Posts
    47

    Default Re: Autodesk Maya 2012

    Aye got it, that helpfull to know.

    In any case apparently Autodesk was aware of the issues with the libssl.so.6 and proposed softlinks as well. as first approach and as second the compatibility packages.

    So I guess we went the right way.

    Thanks again for both your responses and time.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •