Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Firefox, boot screen, internet and permission problem.

Hybrid View

  1. #1
    Join Date
    Jul 2011
    Location
    India
    Posts
    81

    Default Firefox, boot screen, internet and permission problem.

    Hi friends,
    I've 4 problems concerned with my opensuse 12.1 with gnome 3

    1. Randomly, i get a error message any time(i dont know what is provoking this message).
    Code:
    icedteanp plugin error: Failed to run /usr/lib64/jvm/jre//bin/java.  For more detail rerun "firefox -g" in a terminal window.
    2. I've installed windows 7 along with openSUSE. The boot screen (which asks to choose opensuse or windows) sometimes appears animated (like tuxes going here and there in snow) and sometimes the normal green screen. I did do nothing.

    3. Ever since i configured the wvdial.conf file for my new wireless modem(i just changed the username and password) in that file, i am not able to use my wired broadband. It shows as connected but firefox cannot even display google.

    4. I can only read my windows partition with my user account. I want permission to write and delete files in my windows partitions like the root account.


    It would be great if all these are solved.
    Thanks in advance.


    Regards,
    Anish

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Firefox, boot screen, internet and permission problem.

    2. Don't worry about it. It's the holiday theme. It will be normal all the time soon

    4. Post the result of this: cat /etc/fstab
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,402

    Default Re: Firefox, boot screen, internet and permission problem.

    And please, please. Do not ask several things in one thread. The answers will tuble around and make any insight by us (and I guess even you) into who answered what about whar impossible. throwing four different discussions in one bin must make a big mess. Or don't you think so?
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: Firefox, boot screen, internet and permission problem.

    Re. 1: Like the message says, run Firefox from a terminal window, and use the -g option
    Re. 3. Since you configured wvdial on sysem level, the system assumes that's the connection to be used in all cases. Hence no wired broadband. AFAIK you should configure the username and password on user level.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jul 2011
    Location
    India
    Posts
    81

    Default Re: Firefox, boot screen, internet and permission problem.

    @caf4926 :
    anish@linux-jmbg:~> cat /etc/fstab
    /dev/disk/by-id/ata-HITACHI_HTS543225L9SA00_090627FB2F32YLHJMG1B-part5 swap swap defaults 0 0
    /dev/disk/by-id/ata-HITACHI_HTS543225L9SA00_090627FB2F32YLHJMG1B-part7 / ext4 acl,user_xattr 1 1
    /dev/disk/by-id/ata-HITACHI_HTS543225L9SA00_090627FB2F32YLHJMG1B-part6 /boot ext4 acl,user_xattr 1 2
    /dev/disk/by-id/ata-HITACHI_HTS543225L9SA00_090627FB2F32YLHJMG1B-part8 /home ext4 defaults 1 2
    /dev/disk/by-id/ata-HITACHI_HTS543225L9SA00_090627FB2F32YLHJMG1B-part2 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-HITACHI_HTS543225L9SA00_090627FB2F32YLHJMG1B-part3 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    anish@linux-jmbg:~>
    @hcvv :
    I thought it would become something like trolling or unnecessarily increase the post count. If its not so, i would have gladly post it in different threads. Next time, i will do it.

    @knurpht :
    When i run firefox like firefox -g, firefox opens up. But the problem continues.
    i tried restoring the wvdial.conf file to its original form. but it shows in taskbar as wired connection is connected but firefox cannot access the internet.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,402

    Default Re: Firefox, boot screen, internet and permission problem.

    Post count is unimportant. Important is if you get an as good as possible and as soon as possible answer to your problems. And that is promoted by clear, single problem threads with a good title

    I will now teach you the next importat thing here. In order to make computer output readable on the forums, please put such output between CODE tags. As this is not easily be found how to do this, here is a guide: http://forums.opensuse.org/english/i...ags-guide.html

    Then about the execution of
    Code:
    firefox -g
    This does of course not cure the problem, but it is intended to see more information. Is there no output to report in that terminal window? When I do it , I get the following:
    Code:
    henk@boven:~> firefox -g
    Xlib:  extension "GLX" missing on display ":0".
    henk@boven:~>
    That is of coutse NOT the same as your problem, but just to show you that you must report what you get when you are asked to execute a statement.
    Henk van Velden

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Firefox, boot screen, internet and permission problem.

    Edit these lines

    Code:
    /dev/disk/by-id/ata-HITACHI_HTS543225L9SA00_090627FB2F32YLHJMG1B-part2  /windows/C           ntfs-3g     users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-HITACHI_HTS543225L9SA00_090627FB2F32YLHJMG1B-part3  /windows/D           ntfs-3g     users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0

    to

    Code:
    /dev/disk/by-id/ata-HITACHI_HTS543225L9SA00_090627FB2F32YLHJMG1B-part2  /windows/C           ntfs-3g defaults 0 0
    /dev/disk/by-id/ata-HITACHI_HTS543225L9SA00_090627FB2F32YLHJMG1B-part3  /windows/D           ntfs-3g defaults 0 0
    http://forums.opensuse.org/how-faq-r...-manually.html
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Jul 2011
    Location
    India
    Posts
    81

    Default Re: Firefox, boot screen, internet and permission problem.

    @caf4926: Thats indeed impressive explanation given by your link. I still wonder how you guys manage to get these thing into your skull. I try really hard to grab the roots of linux. Thankyou verymuch man. Since its mentioned everywhere, that we must be very careful in giving write permission to windows partitions, i would rather split a partition from my harddisk with FAT32 as file system usable by both Suse and the other one.

    @hcvv: I usually use code tags for terminal stuff. But I searched for the tag option on the top in the quick reply and since i cant find it, i used quote option - sorry for that will correct it.
    running firefox or firefox -g runs firefox and outputs the following in the terminal.
    Code:
    anish@linux-jmbg:~> firefox -g
    *** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).
    Also, i now could not access the internet from my suse. Even the software manager cannot access the internet. But the task bar shows that internet is connected. Firefox is firing up slowly (i mean very slowly i hit it for the second time impatiently and getting a error message stating that its already running)

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Firefox, boot screen, internet and permission problem.

    Quote Originally Posted by thinkanish View Post
    @caf4926: Thats indeed impressive explanation given by your link. I still wonder how you guys manage to get these thing into your skull. I try really hard to grab the roots of linux. Thankyou verymuch man. Since its mentioned everywhere, that we must be very careful in giving write permission to windows partitions, i would rather split a partition from my harddisk with FAT32 as file system usable by both Suse and the other one.

    @hcvv: I usually use code tags for terminal stuff. But I searched for the tag option on the top in the quick reply and since i cant find it, i used quote option - sorry for that will correct it.
    running firefox or firefox -g runs firefox and outputs the following in the terminal.
    Code:
    anish@linux-jmbg:~> firefox -g
    *** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).
    Also, i now could not access the internet from my suse. Even the software manager cannot access the internet. But the task bar shows that internet is connected. Firefox is firing up slowly (i mean very slowly i hit it for the second time impatiently and getting a error message stating that its already running)
    That error starting Firefox is normal

    Check this: https://bugzilla.novell.com/show_bug.cgi?id=704419
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,402

    Default Re: Firefox, boot screen, internet and permission problem.

    1) We know the CODE tags button is hard to find, that is why I tell you and why caf4926 cretaed that howto page.

    2) Now you have posted what FF says, I hope someone has an idea about it.

    3) When you have no connection to the Internet (for whatever reason) it is logical that the software manager hasn't either. what made you think that a/the software manager would have a sort of secret way to the internet while all other programs on your system haven't?

    4) I do not understand what you mean with "But the task bar shows that internet is connected". Only thing I know about networking and task bars is that when you use network manager, then it will show if you have network connection. While you must have of course network connection to be able to reach the Internet, it is not enough and I doubt the network manager applet shows ever anything about the Internet.

    5) To be able to reach the internet, you normaly must have a physical connection (a modem/router) between your LAN and the Internet and a route that tells your system to use that router for all non LAN addresses (the so called: deafult route). I assume you have the physical router and cable/wifi in place (you do not say so). Then looking at (and posting here) the default route with
    Code:
    /sbin/route -n
    Check your connection to the Internet with:
    Code:
    ping www.google.com
    when this gives you lines like mine:
    Code:
    henk@boven:~> ping www.google.com
    PING www.l.google.com (74.125.79.104) 56(84) bytes of data.
    64 bytes from ey-in-f104.1e100.net (74.125.79.104): icmp_req=1 ttl=55 time=10.2 ms
    64 bytes from ey-in-f104.1e100.net (74.125.79.104): icmp_req=2 ttl=55 time=10.2 ms
    64 bytes from ey-in-f104.1e100.net (74.125.79.104): icmp_req=3 ttl=55 time=10.2 ms
    you have connection. When it stays silent, you haven't. Stop this by typing Ctrl-C.
    When you have connection you might still be unable to resolve host/domainnames. For this post
    Code:
    grep -v '^#' /etc/resolv.conf
    6) When FF is very slow in showing pages from the Internet it could be that you have a non IPv6 ready Internet Provider. But in your case, having other FF problems, that is not for sure.
    When incorrect IPv6 behaviour is involved, switch it off in your system. YaST > Network devices > Network configuration. Then the Global options tab and there the second item from the top, uncheck the IPv6 box. A reboot is needed after this. But I repeat, this only a guess.
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •