Results 1 to 5 of 5

Thread: Software distribution site is incorrect

  1. #1

    Default Software distribution site is incorrect

    opensuse v12.1
    linux 3.1.0-1.2-desktop x86_64

    I went to install wxWidgets. It failed because the distribution URL is incorrect: <download.opensuse.org/distribution/12.1/repo/oss/]Index/distribution/12.1/repo/oss/openSUSE-12.1-Oss (Medium 0)>. This is true, there is no folder named <openSUSE-12.1-Oss ...> in <http://download.opensuse.org/distribution/12.1/repo/oss/> although there is one named <suse/> that seems to lead to a repository.

    How do I correct the download sites for online updates?
    Is there an automated way to do so? Or is manual intervention required?

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,131

    Default Re: Software distribution site is incorrect

    Please explain what you are doing.

    The wxWidgets packages are in the OSS repository. This repository is at this URI:
    http://download.opensuse.org/distribution/12.1/repo/oss/
    and should be part of your 12.1 installation unless you have removed it.
    Packages are installed using:
    YaST >> Software >> Software Manager.

    If the OSS repository has been removed, it can be added using
    YaST >> Software >> Software Repositories.

  3. #3
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,131

    Default Re: Software distribution site is incorrect

    The only repository required for On-Line Updates to function is found at this URI:
    http://download.opensuse.org/update/12.1/

    As with the OSS repository, it would have been added as part of a standard installation. To use it just select On-Line Update in YaST2, or use
    YaST >> Software >> Online Update Configuration
    to enable automatic security and recommended updates.

  4. #4

    Default Re: Software distribution site is incorrect

    The repository <http://download.opensuse.org/distribution/12.1/repo/oss/> exists in the configuration. AFAICT it is some sub-directory that is incorrect.

    I go to "YaST >> Software >> Software Management" and search for wxWidgets. I select the two "compat" packages, click Apply. I then get the message:

    Cannot access installation media
    Index of /distribution/12.1/repo/oss
    openSUSE-12.1-Oss (Medium 0).
    Check whether the server is accessible.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,650
    Blog Entries
    15

    Default Re: Software distribution site is incorrect

    Quote Originally Posted by jimoe666
    The repository
    <http://download.opensuse.org/distribution/12.1/repo/oss/> exists in the
    configuration. AFAICT it is some sub-directory that is incorrect.

    I go to "YaST >> Software >> Software Management" and search for
    wxWidgets. I select the two "compat" packages, click Apply. I then get
    the message:

    Cannot access installation media
    'Index of /distribution/12.1/repo/oss'
    (http://download.opensuse.org/distrib...12.1/repo/oss/)
    openSUSE-12.1-Oss (Medium 0).
    Check whether the server is accessible.

    Hi
    You might be striking a faulty mirror. Select a mirror in your locale;
    http://download.opensuse.org/distrib...rpm.mirrorlist

    It may also be related to the outage over the weekend to access
    http://mirrors.opensuse.org/
    http://en.opensuse.org/Portal:Mirrors

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.1 (x86_64) Kernel 3.1.0-1.2-desktop
    up 5:35, 3 users, load average: 0.10, 0.07, 0.09
    CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •