Results 1 to 7 of 7

Thread: Losing Sleep over Postfix, need alternative....

  1. #1

    Question Losing Sleep over Postfix, need alternative....

    I've read on some forums that Postfix and openSuSE 12.1 aren't a happy marriage, and I can see why.

    I'm running openSuSE 12.1 32bit as a "local" linux box running several services and using KDE as the desktop. For the most part, I'm very happy with the setup, and it works well for what I need.

    My problem is I'm not able to configure Postfix. I've tried everything I can find on Google. (edit mail.cf directly) I need mail to go out via a relay server and not use port 25. Setting up sendmail on CentOS 5.x was a breeze. For some reason, Postfix on SuSE doesn't want to play.

    I would like the linux box to send out logwatch and fail2ban notifications to my primary e-mail address. I have my own VPS in Texas and that will be my relay server (tried my ISP as relay and Postfix still wanted to do port 25 directly to the destination MX servers).

    Is there an alternative I can use to Postfix that is easier to configure? I just need something that will use my relay server, custom port, SSL with a known account name and password. Can I uninstall postfix via Yast2 and reinstall sendmail ?

    Thanks for the help

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,130

    Default Re: Losing Sleep over Postfix, need alternative....

    Nothing is easier or more reliable than Postfix. To set the MTA to do nothing, but forward to a relay server, do not try to modify any of the configuration files. I use the text/ncurses YaST2 -- the graphical version may look slightly different.

    Yast >> Network Services >> Mail Server
    Standard >> Next >> Permanent >> Next >>
    and configure Outgoing Mail
    The server can be entered as e.g. mail.example.com:65025 or 10.10.10.10:8825 to specify an alternate SMTP port.

  3. #3
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: Losing Sleep over Postfix, need alternative....

    You can give exim a test drive. However, it may be overkill for just forwarding a few mails to a relay server. To install on OpenSUSE 12.1:

    zypper install exim

    See:

    Exim Internet Mailer

    If you want a web interface see:

    Exim4U Home - Web Interface for The Exim MTA

    FYI, Gordon

  4. #4

    Default Re: Losing Sleep over Postfix, need alternative....

    Quote Originally Posted by eng-int View Post
    Nothing is easier or more reliable than Postfix. To set the MTA to do nothing, but forward to a relay server, do not try to modify any of the configuration files. I use the text/ncurses YaST2 -- the graphical version may look slightly different.

    Yast >> Network Services >> Mail Server
    Standard >> Next >> Permanent >> Next >>
    and configure Outgoing Mail
    The server can be entered as e.g. mail.example.com:65025 or 10.10.10.10:8825 to specify an alternate SMTP port.
    I wish it were that easy, but it isn't.

    I configured the Outgoing Mail and Authentication up, but it still ignores the outgoing name server.
    Here is a log from tail -f /var/log/mail I've removed my 'personal' info..

    Jan 16 16:53:19 linux-zitz postfix/pickup[9181]: E7F54116F0: uid=1000 from=<Liquid_Squelch>
    Jan 16 16:53:19 linux-zitz postfix/cleanup[9921]: E7F54116F0: message-id=<20120116215319.E7F54116F0@linux-zitz>
    Jan 16 16:53:20 linux-zitz postfix/qmgr[9182]: E7F54116F0: from=<Liquid_Squelch@linux-zitz>, size=452, nrcpt=1 (queue active)
    Jan 16 16:53:20 linux-zitz postfix/error[9923]: E7F54116F0: to=<account@domain.tld>, relay=none, delay=0.3, delays=0.17/0.03/0/0.1, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to domain.tld[xxx.xxx.xxx.xxx]:25: Connection timed out)

    As you can see, it still tried to send the messages directly out to port 25 and I specify mail.domain.tld:26 as my outgoing. (again domain.tld is a replacement for the actual domain)

    Thanks for the help.


    And If I can't get this working, I will certainly try Exim.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,178
    Blog Entries
    3

    Default Re: Losing Sleep over Postfix, need alternative....

    Quote Originally Posted by Liquid_Squelch View Post
    Setting up sendmail on CentOS 5.x was a breeze.
    If you are congenial with sendmail, just install that.

    Open Yast, click on "software manager". Then type "sendmail" into the search box. Click "search".

    If you then select sendmail, it will automatically delete postfix (after asking you) and install sendmail.

    I have sendmail working here. Installing was easy. I actually selected in the software part of the original install. Even doing it that way, the installer first installed postfix, then deleted postfix and installed sendmail.
    openSUSE Leap 15.1; KDE Plasma 5;

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: Losing Sleep over Postfix, need alternative....

    On Mon, 16 Jan 2012 22:06:02 +0000, Liquid Squelch wrote:

    > I configured the Outgoing Mail and Authentication up, but it still
    > ignores the outgoing name server.
    > Here is a log from tail -f /var/log/mail I've removed my 'personal'
    > info..


    Maybe if you did the same (removing personal info) from the config file
    and post that (between code tags, please - that'll make it more readable
    for those helping), someone can identify what's wrong in the config.

    As with eng-int's experience, I found setting it up with YaST to be
    pretty painless (my ISP requires I relay through their SMTP server, so I
    don't have a choice but to get it to work), and it's also an
    authenticated server.

    I'm sure someone will be able to help you get the config working.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  7. #7
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,130

    Default Re: Losing Sleep over Postfix, need alternative....

    Once anything has been changed, YaST tends not to overwrite it.

    Execute the following as root, substituting <mail-relay.example.com> with either the name or IP address of your relay.
    Code:
     
    cd  /etc/postfix/
    mv transport transport.old
     cat > transport <<EndOfTransport
    
    $HOSTNAME       :
    *               smtp:mail-relay.example.com:26
    EndOfTransport
    
    postmap transport
    rcpostfix restart
    You should ensure that you do not have port 25 open to the world.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •