Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Graphics card power saving mode workaround for dual monitor setup

  1. #1
    Join Date
    May 2011
    Location
    The Netherlands
    Posts
    44

    Default Graphics card power saving mode workaround for dual monitor setup

    Hi all, (Sorry if the title is a little messy - it sounds like just a bunch of random words when I read it out loud to myself )

    For a while I have been using a dual monitor setup, which has the adverse effect of permanently keeping the graphics card in 3d high performance mode. This leads to increased power consumption and higher card temperatures (mine (Nvidia) is 70-75*C when idle).

    Although I tried to find a solution in the beginning, I found out that there is none and just decided to live with the increased fan noise. Now recently I stumbled upon this software workaround that is supposed to fix this issue, but it appears to be available for Windows only. I was wondering, though, and that's why searched the forums/internet and decided to post this, whether anyone knows if this (or something similar) is available for OpenSUSE as well?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Graphics card power saving mode workaround for dual monitor setup

    Quote Originally Posted by john_jtvds View Post
    Hi all, (Sorry if the title is a little messy - it sounds like just a bunch of random words when I read it out loud to myself )

    For a while I have been using a dual monitor setup, which has the adverse effect of permanently keeping the graphics card in 3d high performance mode. This leads to increased power consumption and higher card temperatures (mine (Nvidia) is 70-75*C when idle).

    Although I tried to find a solution in the beginning, I found out that there is none and just decided to live with the increased fan noise. Now recently I stumbled upon this software workaround that is supposed to fix this issue, but it appears to be available for Windows only. I was wondering, though, and that's why searched the forums/internet and decided to post this, whether anyone knows if this (or something similar) is available for OpenSUSE as well?
    If you load the proprietary video driver and install nvidia-settings, seems like you can control your power saving settings. What nVIDIA card do you have and are you loading their proprietary video drive?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    May 2011
    Location
    The Netherlands
    Posts
    44

    Default Re: Graphics card power saving mode workaround for dual monitor setup

    Thanks James for your fast reply. I have an nVIDIA Quadro FX 700M and nvidia-settings installed, but although I can choose the 'PowerMizer Settings' 'Preferred Mode' (Adaptive or Prefer Maximum Performance) it doesn't ever drop below the highest performance level with a second monitor hooked up. Even though I have selected 'Adaptive', it says the performance mode is 'Maximum Performance'. Am I maybe overlooking something?

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Graphics card power saving mode workaround for dual monitor setup

    Quote Originally Posted by john_jtvds View Post
    Thanks James for your fast reply. I have an nVIDIA Quadro FX 700M and nvidia-settings installed, but although I can choose the 'PowerMizer Settings' 'Preferred Mode' (Adaptive or Prefer Maximum Performance) it doesn't ever drop below the highest performance level with a second monitor hooked up. Even though I have selected 'Adaptive', it says the performance mode is 'Maximum Performance'. Am I maybe overlooking something?
    So, looking through the many posts on this subject I did find this:

    • I have a multimonitor setup and the video card is always at max speed even with PowerMizer disabled.
      When the graphic card detects two or more monitors, it will clock itself to Max. performance profile no matter what the PowerMizer parameters are. This is in the NVIDIA specs.
    Their reasoning is said to be because driving dual monitors and power saving at the same time will produce bad results and I guess they think cooling will take care of its self. Can you tell us more about your computer, its hardware, its age, openSUSE version, Desktop used, kernel version? Anything could be of value for us to know and forgive me if you have specified any of this before.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    May 2011
    Location
    The Netherlands
    Posts
    44

    Default Re: Graphics card power saving mode workaround for dual monitor setup

    I'm using a 2.5 yrs old HP EliteBook 8530w laptop with the following specs:
    • Intel Centrino 2 CPU,
    • Nvidia Quadro FX 770M GPU,
    • 4 GB RAM
    • Samsung Syncmaster as a second screen


    • OpenSUSE 11.4
    • kernel 2.6.37.6-0.9-desktop
    • KDE 4.6.0
    • nvidia-settings installed (twinview enabled)


    (By the way, I have always assumed this issue to be a dead end. This was also the main message of the author you quoted and in line with about everything I have ever read about this. Until I stumbled upon the tool that I linked to in the OP, that is. This basically got me hoping that there had been new developments in this field.)

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Graphics card power saving mode workaround for dual monitor setup

    Quote Originally Posted by john_jtvds View Post
    I'm using a 2.5 yrs old HP EliteBook 8530w laptop with the following specs:
    • Intel Centrino 2 CPU,
    • Nvidia Quadro FX 770M GPU,
    • 4 GB RAM
    • Samsung Syncmaster as a second screen


    • OpenSUSE 11.4
    • kernel 2.6.37.6-0.9-desktop
    • KDE 4.6.0
    • nvidia-settings installed (twinview enabled)


    (By the way, I have always assumed this issue to be a dead end. This was also the main message of the author you quoted and in line with about everything I have ever read about this. Until I stumbled upon the tool that I linked to in the OP, that is. This basically got me hoping that there had been new developments in this field.)
    So, my very first question is have you blown out the heat sinks, to remove dust, through the case vents lately? You may do this often, but if not, you need to do this right away and in particular if it has not been done in the last year of operation. My main PC is a desktop, not a laptop, but it is running openSUSE 11.4, but I have updated the kernel clear up to version 3.2.1, not that is known to help heating, in fact it may do the opposite unfortunately, though there are some work a round’s.

    GNU/Linux and openSUSE power management regressions - Blogs - openSUSE Forums

    You can have an effect on heat by controlling your CPU speed with these utilities:

    C.F.U. - CPU Frequency Utilitiy - Version 1.10 - For use with the cpufrequtils package - Blogs - openSUSE Forums

    AND

    YaST Power Management - Control Your CPU Energy Usage How To & FAQ - Blogs - openSUSE Forums

    It would be nice to know your power default Governor.

    And for anyone that would like to try a newer kernel version, considering it does not do away with your old one look here:

    S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.50 - Blogs - openSUSE Forums

    And anyone who is using the nVIDIA video card needs to know about these:

    Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

    And

    LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.20 - Blogs - openSUSE Forums

    And so in keeping with the thought that if you don't know the actual answer, try to blow them away with bull s*, oh ops, you know what I mean.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    May 2011
    Location
    The Netherlands
    Posts
    44

    Default Re: Graphics card power saving mode workaround for dual monitor setup

    Actually I really think it's just the permanent high performance mode that's causing the high temperatures. It's just that I'm looking for ways to get it out of high performance mode once in a while. Without the second monitor enabled the temperature is just fine, around 45*C. When I'm really pushing it to the limit (i.e. so that it is in high performance mode for a reason, for a change ) it goes up to 90-100*C (which is normal under those conditions, as far as I know), no difference whether the second monitor is hooked up or not.

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: Graphics card power saving mode workaround for dual monitor setup

    Quote Originally Posted by john_jtvds View Post
    Actually I really think it's just the permanent high performance mode that's causing the high temperatures. It's just that I'm looking for ways to get it out of high performance mode once in a while. Without the second monitor enabled the temperature is just fine, around 45*C. When I'm really pushing it to the limit (i.e. so that it is in high performance mode for a reason, for a change ) it goes up to 90-100*C (which is normal under those conditions, as far as I know), no difference whether the second monitor is hooked up or not.
    None the less, if you have not blown out the dust and can't tell me if you have ever done this, then you need to do so. Consider that while Linux might not be as good at heat control as Windows may be, due to better driver support, dirty heat sinks don't help at all when used under Linux. Again, if you have not recently blown out this dust, you just must humor me and give it a try. I normally use duster spray, just cans of compressed air. I turn off the computer, unplug from the wall and remove the battery for any laptop and then blast away. Be prepared to be amazed at your dust build up. Trust me on this one.

    Thank You,
    Last edited by jdmcdaniel3; 15-Jan-2012 at 12:12.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9
    Join Date
    May 2011
    Location
    The Netherlands
    Posts
    44

    Default Re: Graphics card power saving mode workaround for dual monitor setup

    I blow out the dust regularly (though just using my own lungs), but I'll give your more thorough suggestion a try some time!

  10. #10
    Join Date
    May 2011
    Location
    The Netherlands
    Posts
    44

    Default Re: Graphics card power saving mode workaround for dual monitor setup

    OK. What I have been calling 'blowing the dust out' for years got a new meaning today. Apparently, up till now I have....let me put it this way: what I have been doing before compares to what I did today, as one brick does to a 10,000 sq ft mansion. Thanks, James, this has been a wake up call. Temperatures have dropped by almost 20 C when idle and a whopping 30 C when watching 720p video. My laptop's life time has been extended by many, many years. Thanks!

    EDIT: I even get to hear my hard disk being active now because the fans don't need to run at maximum speed all the time!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •