Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: 64bit skype install problem in 11.4

  1. #1

    Default 64bit skype install problem in 11.4

    I have tried installing the 32 bit packages for 64 bit 11.4 as described here:
    SDB:Skype - openSUSE

    however this is what terminal is telling me:

    Loading repository data...
    Reading installed packages...
    Package 'libpng12-0-32bit' not found.
    Package 'libqt4-32bit' not found.
    Package 'libqt4-x11-32bit' not found.
    Package 'xorg-x11-libXv-32bit' not found.
    Resolving package dependencies...

    Nothing to do.

    I've got all the standard repos subscribed to oss, non-oss, packman etc
    what i am i doing wrong?

    thanks
    Phil

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 64bit skype install problem in 11.4

    On 01/13/2012 09:56 PM, philipgardner wrote:
    > Loading repository data...
    > Reading installed packages...
    > Package 'libpng12-0-32bit' not found.
    > Package 'libqt4-32bit' not found.
    > Package 'libqt4-x11-32bit' not found.
    > Package 'xorg-x11-libXv-32bit' not found.
    > Resolving package dependencies...


    please, show us the input string and the output string, because if you
    have openSUSE 11.4, as you said in your post then it looks like maybe
    you picked the wrong set of libs to ask for, it should be:

    and, please show us the terminal input/output from

    Code:
    zypper lr -d
    cat /etc/SuSE-release
    copy/paste the in/output back to this thread using the instructions
    here: http://goo.gl/i3wnr

    --
    DD http://tinyurl.com/DD-Caveat
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 64bit skype install problem in 11.4

    On 01/13/2012 10:56 PM, DenverD wrote:
    > maybe you picked the wrong set of libs to ask for, it should be:


    sorry, i forgot to put in:

    libasound2-32bit
    xorg-x11-libXv-32bit
    xorg-x11-libs-32bit
    libqt4-x11-32bit
    libpng12-0-32bit

    --
    DD
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  4. #4

    Default Re: 64bit skype install problem in 11.4

    Input/Output:

    Code:
    philip@linux-yzd2:~> zypper lr -d
    #  | Alias                            | Name                             | Enabled | Refresh | Priority | Type   | URI                                                                               | Service
    ---+----------------------------------+----------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------+--------
     1 | Banshee                          | Banshee                          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Banshee/11.4/                           |        
     2 | Education                        | Education                        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_11.4/                |        
     3 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/                                         |        
     4 | devel:languages:perl             | devel:languages:perl             | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_11.4/   |        
     5 | devel:languages:python           | devel:languages:python           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_11.4/ |        
     6 | mozilla                          | mozilla                          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/                  |        
     7 | openSUSE-11.4-11.4-0             | openSUSE-11.4-11.4-0             | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-LITE-ON_DVDRW_SHM-165P6S,/dev/sr0              |        
     8 | opensuse-guide.org-repo          | libdvdcss repository             | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/11.4/                                              |        
     9 | packman.inode.at-suse            | Packman Repository               | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_11.4/                                       |        
    10 | repo-debug                       | openSUSE-11.4-Debug              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/11.4/repo/oss/                    |        
    11 | repo-debug-update                | openSUSE-11.4-Update-Debug       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/11.4/                                   |        
    12 | repo-non-oss                     | openSUSE-11.4-Non-Oss            | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                      |        
    13 | repo-oss                         | openSUSE-11.4-Oss                | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                          |        
    14 | repo-source                      | openSUSE-11.4-Source             | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/11.4/repo/oss/                   |
    I enabled & refreshed all repos that i had just in case, i wouldn't normally have Banshee,Education,Mozilla,pearl or python in here.

    Input/Output:
    Code:
    philip@linux-yzd2:~> su -c 'zypper install libasound2-32bit xorg-x11-libXv-32bit xorg-x11-libs-32bit libqt4-x11-32bit libpng12-0-32bit'
    Code:
    Loading repository data...
    Reading installed packages...
    Package 'libasound2-32bit' not found.
    Package 'libpng12-0-32bit' not found.
    Package 'libqt4-x11-32bit' not found.
    Package 'xorg-x11-libXv-32bit' not found.
    Package 'xorg-x11-libs-32bit' not found.
    Resolving package dependencies...
    
    Nothing to do.
    Thanks Phil

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: 64bit skype install problem in 11.4

    Bizarre, those packages should be in the OSS repo. This is on 12.1 but I don't think it has changed since 11.4. Sorry, no ideas.

    Code:
    $ zypper info libpng12-0-32bit
    Loading repository data...
    Reading installed packages...
    
    
    Information for package libpng12-0-32bit:
    
    Repository: openSUSE-12.1-Oss
    Name: libpng12-0-32bit
    Version: 1.2.46-9.1.2
    Arch: x86_64
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 170.0 KiB
    Summary: Library for the Portable Network Graphics Format (PNG)
    Description: 
    libpng is the official reference library for the Portable Network
    Graphics format (PNG).

  6. #6

    Default Re: 64bit skype install problem in 11.4

    Strange,
    i found the packages manually in:
    Index of /distribution/11.4/repo/oss/suse/x86_64

    and downloaded manually, and they installed okay,
    i then followed rest of the guide: SDB:Skype - openSUSE

    and it works....
    if anyone has any advice regarding the way i set up my repo's and why it couldn't find these packages through zypper? i'd be grateful.
    Anyway we can skype mac friends now so my upgrade from 11.3 to 11.4 looks complete...

    Thanks
    Phil

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 64bit skype install problem in 11.4

    On 01/14/2012 07:56 AM, philipgardner wrote:
    > if anyone has any advice regarding the way i set up my repo's and why
    > it couldn't find these packages through zypper?


    only thing i could hypothesize would be that your system (through
    MirrorBrain <http://en.opensuse.org/openSUSE:Mirrors>) was connected to
    a mirror which was having problems with the oss repo at the exact point
    in time you were trying to fetch..

    and, the transient problem was so new that it had not been detected and
    therefore that mirror had not yet been marked unavailable....

    --
    DD http://tinyurl.com/DD-Caveat
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  8. #8

    Default Re: 64bit skype install problem in 11.4

    Interesting
    The mirror was warwick, uk. is this something i should contact someone about?
    It's failed to find these packages for about a week, whenever i have tried.
    Phil

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: 64bit skype install problem in 11.4

    On 01/14/2012 02:06 PM, philipgardner wrote:
    > The mirror was warwick


    how would you know that?

    mirrorBrain might have hooked you to Timbuktu or Arizona..

    --
    DD
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  10. #10

    Default Re: 64bit skype install problem in 11.4

    Yeah your right..!
    i thought i saw warwick in terminal, but obviously not, i tried again in terminal..no mention of which mirror....apologies to the fine citizens of warwick, as well as you DenverD (in case you don't live in warwick)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •