Results 1 to 3 of 3

Thread: gnucash will not start from KDE destop in 12.1

  1. #1

    Default gnucash will not start from KDE destop in 12.1

    I installed gnucash with yast2 software manager. When I attempt to open it, I get the bouncing icon indicating the program is loading, then the guncash splash (a small window with gnucash decorations, then immediately another gray window that covers that window for an instant, and then everything just goes away.

    If I enter "gnucash" in a terminal I get the following:

    rcdawson@linux-rrp3:~> gnucash
    gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

    WARNING: no socket to connect to
    ;;; note: auto-compilation is enabled, set GUILE_AUTO_COMPILE=0
    ;;; or pass the --no-auto-compile argument to disable.
    ;;; compiling /usr/share/gnucash/guile-modules/gnucash/main.scm
    ;;; compiling /usr/share/gnucash/guile-modules/gnucash/core-utils.scm
    ;;; WARNING: compilation of /usr/share/gnucash/guile-modules/gnucash/core-utils.scm failed:
    ;;; ERROR: no code for module (sw_core_utils)
    ;;; compiling /usr/share/gnucash/guile-modules/gnucash/gnc-module.scm
    ;;; WARNING: compilation of /usr/share/gnucash/guile-modules/gnucash/gnc-module.scm failed:
    ;;; ERROR: no code for module (sw_gnc_module)
    ;;; WARNING: compilation of /usr/share/gnucash/guile-modules/gnucash/main.scm failed:
    ;;; ERROR: In procedure debug-options-interface: Unknown option name: maxdepth
    Backtrace:
    In ice-9/boot-9.scm:
    170: 12 [catch #t #<catch-closure 8467e80> ...]
    In unknown file:
    ?: 11 [catch-closure]
    In ice-9/boot-9.scm:
    2497: 10 [#<procedure 8429430 at ice-9/boot-9.scm:2485:4 (name #ptional autoload version #:key ensure)> # ...]
    2763: 9 [try-module-autoload (gnucash main) #f]
    2103: 8 [save-module-excursion #<procedure 852a9c0 at ice-9/boot-9.scm:2764:17 ()>]
    2774: 7 [#<procedure 852a9c0 at ice-9/boot-9.scm:2764:17 ()>]
    In unknown file:
    ?: 6 [primitive-load-path "gnucash/main" #f]
    In ice-9/eval.scm:
    458: 5 [#<procedure 83c16c0 at ice-9/eval.scm:452:4 (exp)> #]
    In ice-9/psyntax.scm:
    1024: 4 [chi-top-sequence ((debug-set! maxdepth 100000)) () ...]
    922: 3 [scan ((debug-set! maxdepth 100000)) () ...]
    1015: 2 [scan ((#(syntax-object debug-options # ...) (# # #))) () ...]
    In ice-9/boot-9.scm:
    2854: 1 [debug-options (show-file-name #t stack ...)]
    In unknown file:
    ?: 0 [debug-options-interface (show-file-name #t stack ...)]

    ERROR: In procedure debug-options-interface:
    ERROR: In procedure debug-options-interface: Unknown option name: maxdepth
    rcdawson@linux-rrp3:~>

    Here again, I see the small window with gun decorations that usually proceeds the program opening, but it disappears almost as soon as it arrives.

    Help would be appreciated.

    Richard

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: gnucash will not start from KDE destop in 12.1

    Take a look at the following thread on the same subject.

    http://forums.opensuse.org/english/g...2-1-gnome.html

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: gnucash will not start from KDE destop in 12.1

    I don't know what happened to Richard Dawson, but had the same problem, and thought I had nothing to lose by trying a GNOME solution to my KDE problem.
    Index of /repositories/home:/j-engel/openSUSE_12.1 gives a choice of architectures, and a later version than given in the GNOME thread, so I used the latest gnucash (not devel) rpm.
    I similarly used Index of /repositories/home:/dimstar:/branches:/GNOME:/Apps/openSUSE_Factory for the latest libguile rpm (which hadn't advanced beyond the GNOME thread).
    They solved the basic problem, but exporting isn't a current issue for me, so I'm just hoping the version of GNUCash supplied as standard will be corrected before I need to do it.
    Now I find that help doesn't work. I've installed the package(s), but haven't even managed to find the files yet, and the KDE Help Centre tells me it can't find the documentation either. Yelp has changed, so I can't even use the files from openSUSE 11.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •