Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: new version of amule in opensuse 11.4

  1. #1

    Default new version of amule in opensuse 11.4

    Hello,

    Will you know if the new version of amule 2.3.1 for opensuse 11.4? For openSUSE 12.1 is now available.

    Thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: new version of amule in opensuse 11.4

    generally a version of openSUSE goes to its end of life with the same
    versions of applications it was born with..

    that is to say, that without other factors pushing (like horrible bugs
    or security problems) you won't ever see the amule (or any other
    applications) in the 12.1 repos move down to the 11.4 repos..

    there are, of course some exceptions..

    on the other hand there is nothing which stops you from downloading
    source and compiling it for your system..

    --
    DD http://tinyurl.com/DD-Caveat
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: new version of amule in opensuse 11.4

    Am 05.01.2012 20:54, schrieb DenverD:
    > generally a version of openSUSE goes to its end of life with the
    > same versions of applications it was born with..
    >

    In general yes, but this is an application from packman where usually
    all supported openSUSE versions get the same application version (as
    soon as as the build system builds it). Same for the community repos, so
    the general policy is not valid here.

    I would expect the updated application soon if there is no build problem
    for 11.4.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.4 |
    nVidia ION | 3GB Ram

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: new version of amule in opensuse 11.4

    I looked a bit more into the details and found that the newer amule
    cannot be built on 11.4 because the version o wxwidgets it needs to
    build is higher than what comes with 11.4 by default. So it is unlikely
    that packman can provide the newer version.

    But it is easy to build it yourself.
    Add the repository
    http://download.opensuse.org/reposit.../openSUSE_11.4
    and switch your existing wxwidgets to the versions from this repository.
    Download the source rpm for amule
    http://packman.links2linux.org/downl....1-1.1.src.rpm
    run
    Code:
    rpmbuild --rebuild aMule-2.3.1-1.1.src.rpm
    most likely it will complain about missing devel packages, install them
    and run the command again until you resolved all dependencies.
    At the end you have now a aMule-2.3.1-1.1.x86_64.rpm for example in my
    case which you can install with
    Code:
    sudo zypper in aMule-2.3.1-1.1.x86_64.rpm
    I tested right now that it really works.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.4 |
    nVidia ION | 3GB Ram

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: new version of amule in opensuse 11.4

    Or you can install one of the versions provided by some obs users if you
    like to do that
    http://software.opensuse.org/search?...ude_debug=true

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.4 |
    nVidia ION | 3GB Ram

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: new version of amule in opensuse 11.4

    On 01/05/2012 09:10 PM, Martin Helm wrote:
    > this is an application from packman where usually
    > all supported openSUSE versions get the same application version (as
    > soon as as the build system builds it). Same for the community repos, so
    > the general policy is not valid here.


    this is good information that i did not know--thanks for posting!!

    --
    DD
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: new version of amule in opensuse 11.4

    Am 06.01.2012 06:24, schrieb DenverD:
    > On 01/05/2012 09:10 PM, Martin Helm wrote:
    >> this is an application from packman where usually
    >> all supported openSUSE versions get the same application version (as
    >> soon as as the build system builds it). Same for the community repos, so
    >> the general policy is not valid here.

    >
    > this is good information that i did not know--thanks for posting!!
    >

    I have to add that this is just an observation over the years (since I
    use several community repos and of course packman) and always have more
    than one openSUSE version running on different machines (I still have a
    11.3 on one which I migrate at the moment).

    So this is not something where I ever seen an official statement for the
    community repos or packman about their policy.

    For packman it seems they only stop to provide newer application
    versions for the older openSUSE versions when the new version does not
    longer build, as I found myself this is the case for amule, there may be
    other applications where this applies also.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.4 |
    nVidia ION | 3GB Ram

  8. #8

    Default Re: new version of amule in opensuse 11.4

    Quote Originally Posted by martin_helm View Post
    Code:
    rpmbuild --rebuild aMule-2.3.1-1.1.src.rpm
    ok thanks,

    I did not know was that easy to build the package, I thought I had to manually compile amule from its own source and that is more difficult.

    I'll try to tell you have time.

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: new version of amule in opensuse 11.4

    On 2012-01-06 22:46, jony127 wrote:
    > I did not know was that easy to build the package, I thought I had to
    > manually compile amule from its own source and that is more difficult.


    which is what rebuild does. You will have the same problems as with compile
    from source re having the required -devel libraries.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  10. #10

    Default Re: new version of amule in opensuse 11.4

    Quote Originally Posted by robin_listas View Post
    which is what rebuild does. You will have the same problems as with compile
    from source re having the required -devel libraries.
    But when compiling from source I have to pass configuration data ./configure

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •