Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: Resolution 1680 x 1050 for external monitor does not work

  1. #1
    Join Date
    Mar 2010
    Location
    Germany, RLP
    Posts
    14

    Default Resolution 1680 x 1050 for external monitor does not work

    Hi folks,

    I 've installed openSUSE 12.1 on my laptop. Everything works except for the resolution 1680 x 1050 on the external monitor (the display stays black after setting this resolution or sometimes it flickers for a moment but then stays black again). Before with openSUSE 11.4 (or 11.3) the external monitor worked perfectly with this resolution.

    It is really strange: My desktop-PC with openSUSE 12.1 and the same monitor works with the 1680 x 1050 resolution. That is why I am posting this in the laptop forum.

    I tried several things e.g....
    • With strange resolutions e.g. 1280 x 1024 the monitor works on the laptop
    • Installed the fglrx-driver from ATI/AMD...the wished resolution works but this is really buggy as the display freezes again and again.


    Graphic card: ATI Mobility Radeon HD 2600
    Driver: standard (out-of-the-box-installed)

    Could this be a bug in the driver?

    Regards,
    icediver

  2. #2
    Join Date
    Mar 2010
    Location
    Germany, RLP
    Posts
    14

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    I booted an Ubuntu 11.10 live-cd and was not able to set the resolution of the external monitor to 1680 x 1050 either...or could this be a bug in the kernel? (I am not that familiar with ubuntu...)

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,374
    Blog Entries
    1

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Graphic card: ATI Mobility Radeon HD 2600
    Driver: standard (out-of-the-box-installed)
    So, are you now using the open source radeon driver? Check the output of /var/log/Xorg.0.log

    It is a verbose file, so cut and paste the contents to SUSE Paste

    and set the 'Delete After' period to something sensible. Post the link to it here.

    Usually display resolution issues like these are as a result of EDID problems - sometimes due to the type of cable/connection, and sometimes due to the display device itself.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,374
    Blog Entries
    1

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Graphic card: ATI Mobility Radeon HD 2600
    Driver: standard (out-of-the-box-installed)
    So, are you now using the open source radeon driver? Check the output of /var/log/Xorg.0.log

    It is a verbose file, so cut and paste the contents to SUSE Paste

    and set the 'Delete After' period to something sensible. Post the link to it here.

    Usually display resolution issues like these are as a result of EDID problems - sometimes due to the type of cable/connection, and sometimes due to the display device itself.

  5. #5
    Join Date
    Mar 2010
    Location
    Germany, RLP
    Posts
    14

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Thanks for the reply

    I uninstalled the fglrx driver and now I am using the default driver again. I'm not sure if it is radeon or radeonhd. "zypper se radeon" just prints the package xorg-x11-driver-video-radeonhd...the sysinfo-page of konqueror says "radeon" but in the log both drivers occur:

    SUSE Paste (the external monitor is not connected as I use the laptop screen)

    Upon a closer view I found an error with the radeonhd driver in the log:
    [ 30.941] (EE) FATAL: RadeonHD presently does not work with kernel modesetting (KMS).
    Please disable KMS in your kernel.
    But I am totally confused...I thought radeonhd was replaced by radeon (according to this information)

  6. #6
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    For the mobility card you should be using the radeonhd driver,
    M76 Mobility Radeon HD 2600; (Gemini ATI) Mobility Radeon HD 2600 XT (from cmd info radeonhd) and info from your /var/log/Xorg.0.log
    this is in the xorg-x11-driver-video-radeonhd package.

    The radion driver only covers the following chipsets,
    RV610/RV630 Radeon HD 2400/2600 (from cmd info radeon)
    RV630 : Radeon HD 2600 LE/Pro/XT, HD 2600 Pro/XT AGP (info your /var/log/Xorg.0.log)
    this driver is in the xorg-x11-driver-video package.

    Its possible your video card is not being correctly detected.

    Check in the file /etc/X11/xorg.conf.d/50-device.conf and make sure you have at least the lines,
    Code:
    Section "Device"
      Identifier "Default Device"
    
      Driver "radeonhd"
    
    EndSection
    Also check that you do not have a file /etc/X11/xorg.conf, rename it if you do.

    KMS can be disabled if you type in
    nomodeset
    in the command line when you choose whether to boot to normal or failsafe kernel modes.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,563
    Blog Entries
    38

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    I note in the Xorg.0.log this identification for the monitor:
    Code:
    [    31.007] (II) RADEON(1):  AUO
    [    31.007] (II) RADEON(1):  B154EW02 V1
    is that the internal laptop screen ? Its resolution is only 1280x800 according to the pdf file with the spec: http://www.yslcd.com.tw/docs/product/B154EW02%20V.2.pdf

    I don't see an external monitor plugged in when you provided the Xorg.0.log.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,374
    Blog Entries
    1

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Did you have your external monitor connected. (It doesn't appear so).
    Code:
    [    31.020] (II) RADEON(1): Output VGA-0 disconnected
    [    31.020] (II) RADEON(1): Output HDMI-0 disconnected
    [    31.020] (II) RADEON(1): Output LVDS connected
    [    31.020] (II) RADEON(1): Output DIN disconnected
    We really need to see the Xorg.0.log output when an external display is attached. The make and model of the monitor (and/or resolution specs) may also be helpful.

    The radeon and radeonhd drivers both support this particular hardware. The radeon will be used by default.

  9. #9
    Join Date
    Mar 2010
    Location
    Germany, RLP
    Posts
    14

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Thanks for the support so far
    I'm sorry the monitor was not connected (as I said). Here is the log with my external monitor (you can search for "PL2206W") connected: SUSE Paste. It is a iiyama ProLite B2206WS monitor.
    xorg.conf does not exist and the nomodeset boot option did not work I will try the setting in the 50-device.conf tomorrow...

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,563
    Blog Entries
    38

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Quote Originally Posted by icediver View Post
    Thanks for the support so far
    I'm sorry the monitor was not connected (as I said). Here is the log with my external monitor (you can search for "PL2206W") connected: SUSE Paste. It is a iiyama ProLite B2206WS monitor.
    xorg.conf does not exist and the nomodeset boot option did not work I will try the setting in the 50-device.conf tomorrow...
    This is better ... I note:
    Code:
    [    29.406] (II) RADEON(1): Monitor name: PL2206W
    [    29.406] (II) RADEON(1): EDID (in hex):
    [    29.406] (II) RADEON(1):    00ffffffffffff0026cd0f5603040000
    [    29.406] (II) RADEON(1):    3513010380301e782a78f1a655489b26
    [    29.406] (II) RADEON(1):    125054bfef00714f818081409500950f
    [    29.406] (II) RADEON(1):    01010101010121399030621a274068b0
    [    29.406] (II) RADEON(1):    3600de2c1100001c000000ff00313130
    [    29.406] (II) RADEON(1):    32394d39433031303237000000fd0037
    [    29.406] (II) RADEON(1):    4c1e530f000a202020202020000000fc
    [    29.406] (II) RADEON(1):    00504c32323036570a202020202000eb
    [    29.406] (II) RADEON(1): Printing probed modes for output HDMI-0
    [    29.406] (II) RADEON(1): Modeline "1680x1050"x60.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz)
    [    29.406] (II) RADEON(1): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
    [    29.406] (II) RADEON(1): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
    [    29.406] (II) RADEON(1): Modeline "1440x900"x75.0  136.75  1440 1536 1688 1936  900 903 909 942 -hsync +vsync (70.6 kHz)
    [    29.406] (II) RADEON(1): Modeline "1440x900"x59.9  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz)
    [    29.406] (II) RADEON(1): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz)
    [    29.406] (II) RADEON(1): Modeline "1152x864"x75.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz)
    [    29.406] (II) RADEON(1): Modeline "1024x768"x75.1   78.80  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.1 kHz)
    [    29.406] (II) RADEON(1): Modeline "1024x768"x70.1   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
    [    29.406] (II) RADEON(1): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
    [    29.406] (II) RADEON(1): Modeline "832x624"x74.6   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
    [    29.406] (II) RADEON(1): Modeline "800x600"x72.2   50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
    [    29.406] (II) RADEON(1): Modeline "800x600"x75.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
    [    29.406] (II) RADEON(1): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
    [    29.406] (II) RADEON(1): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
    [    29.406] (II) RADEON(1): Modeline "640x480"x72.8   31.50  640 664 704 832  480 489 491 520 -hsync -vsync (37.9 kHz)
    [    29.406] (II) RADEON(1): Modeline "640x480"x75.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
    [    29.406] (II) RADEON(1): Modeline "640x480"x66.7   30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz)
    [    29.406] (II) RADEON(1): Modeline "640x480"x60.0   25.20  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
    [    29.406] (II) RADEON(1): Modeline "720x400"x70.1   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
    With the external monitor plugged in, if you type the command in a terminal
    Code:
    xrandr
    what output do you get ?
    Last edited by oldcpu; 05-Jan-2012 at 14:29.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •