Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 39

Thread: Resolution 1680 x 1050 for external monitor does not work

  1. #11
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,396
    Blog Entries
    1

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Are you using KDE or Gnome or ???

  2. #12
    Join Date
    Mar 2010
    Location
    Germany, RLP
    Posts
    14

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    This is the xrandr output:
    PHP Code:
    ash@linux-gid1:~> xrandr
    Screen 0
    minimum 320 x 200current 1682 x 1052maximum 3840 x 1920
    VGA_1 disconnected
    DVI
    -D_1 connected 1680x1050+0+0 478mm x 300mm
       1680x1050      60.0
    *+
       
    1280x1024      75.0     59.9  
       1440x900       74.9     60.0  
       1280x960       59.9  
       1152x864       74.9  
       1024x768       75.1     70.1     60.0  
       832x624        74.6  
       800x600        72.2     75.0     60.3     56.2  
       640x480        75.0     72.8     66.7     60.0  
       720x400        70.1  
    PANEL connected                                                                                                                                  
       1280x800       60.0 
    +                                                                                                                         
       
    2560x1600Scaled   60.5                                                                                                                        
       2048x1536Scaled   60.5                                                                                                                        
       1920x1200Scaled   60.4                                                                                                                        
       1920x1080Scaled   60.5                                                                                                                        
       1600x1200Scaled   60.4  
       1680x1050Scaled   60.3  
       1400x1050Scaled   60.3  
       1440x960Scaled   60.4  
       1280x1024Scaled   60.5  
       1280x960Scaled   60.4  
       1280x854Scaled   60.4  
       1280x720Scaled   60.4  
       1152x768Scaled   60.3  
       1024x768Scaled   60.4  
       800x600Scaled   60.3  
       768x576Scaled   60.4  
       854x480Scaled   59.8  
       720x480Scaled   59.8  
       640x480Scaled   60.1  
       320x240Scaled   57.6  
       320x200Scaled   55.7  
    TV_7PIN_DIN disconnected 
    I am using KDE (but the problem also occurs under Gnome).

    I followed the instructions of keellambert's hint. Now I am using the radeonhd driver...the problem remains but it seems to work better as the external monitor (with 1680 x 1050) produces a usable display output for some seconds (before it turns black for some seconds and shows the display again and so on).

  3. #13
    Join Date
    Mar 2010
    Location
    Germany, RLP
    Posts
    14

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Ok, something I recognize: With the radeonhd driver (as you can see in the xrandr output) the external monitor is connected to the DVI port (which is correct). With the radeon driver the external monitor was listed under the hdmi port (which is false because I always use the DVI cable). So the radeonhd driver should work better (I guess).

  4. #14
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Quote Originally Posted by icediver View Post
    This is the xrandr output:
    I assume that is the output using xrandr with the radonhd driver.

    There are various xrandr tutorials on the web, such as this one: Xorg RandR 1.2 - ThinkWiki

    but I am not familiar with "PANEL" nor "DVI-D" nor "Screen 0" being lablels for graphic devices. I'm more familiar with VGA and LVDS.

  5. #15
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,396
    Blog Entries
    1

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    With the radeon driver the external monitor was listed under the hdmi port (which is false because I always use the DVI cable).
    It is the same digital interface as far as the radeon driver is concerned, so don't worry about it.

    You should be able to configure your preferred display settings with

    System Settings >> Display and Monitor

    Make the changes then 'Save as Default'.

    Alternatively, you can use the xrandr CLI command to set the resolution of the external monitor, and add to a startup script if preferred.

  6. #16
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    From the information in the man pages for radeon and radeonhd, the radeonhd
    driver is the only one that supports the mobility cards.

    The information in your Xorg.0.log seems to contradict this.

    Can you identify which chipset your card has? Possibly from the laptop manual.

    Failing that, who is the laptop manufacturer?
    What is the laptop model number?

    Apologies if you have given this info before.

  7. #17
    Join Date
    Mar 2010
    Location
    Germany, RLP
    Posts
    14

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Sorry for answering that late...

    So I tried xrandr and "System Settings >> Display and Monitor" to set my monitor resolution. With both the resolution 1680 x 1050 does not work although my external monitor supports it definitely. This is really strange.

    In the posted Xrandr tutorial there was a way to create a xorg.conf. This did not work. It failed with the message
    Number of created screens does not match number of detected devices.
    Configuration failed.
    This is the Xorg.0.log which was created in that context: SUSE Paste

    I can't say what chipset my graphic card has...so here are the data about my laptop:

    Manufacturer: Asus
    Model: X53K series
    Mainboard Version: F3Ka

  8. #18
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    1. The F3Ka/F2Ke Block Diagram shows the board has the ATI M76M/M64M chipset.
    This should be covered by the radeonhd driver.

    2. Does your laptop have two display output connectors, vga (15 pin D-sub) and hdmi?

    3. What happens to the displays when F8 key is toggled?

    4. What happens to the displays when Fn+c keys are toggled?

    Note: I've not been able to identify the X53K only the X53E.

  9. #19
    Join Date
    Mar 2010
    Location
    Germany, RLP
    Posts
    14

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Thanks for your support

    1: Thanks for your research. Then I will continue using the radeonhd driver. Strange that the radeon driver was used as default...

    2: The laptop has one VGA and one DVI connector. I just tested: The monitor works on the VGA port with the 1680 x 1050 resolution...but I don't know if the display quality is as good as before...

    3: Fn+F8 toggles between internal display and external monitor. When I switch off the internal display the screen on the external display seems more stable i.e. the periods when the screen is black get shorter. But it's still annoying.

    4: This does not seem to change anything (also in combination with Fn+F8)

    I'm not sure if I understood your note right...Do you mean that you could not find any information about the X53K model? I looked on the asus homepage e.g. when you click on download then you can select the model X53Ka. (I' m sorry. On the sticker on my laptop was only X53K given as model description)

  10. #20
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: Resolution 1680 x 1050 for external monitor does not work

    Further questions come to mind,

    1. Which colour mode are you using; 256, high colour?

    2. Can you get the LCD & CRT Cloned mode or LCD and CRT Extended mode working, toggling the Fn-F8 keys.
    -- (external monitor must be connected prior to booting)

    3. Have you tried selecting the above modes while at the terminal prompt prior to starting the gui?
    -- (booting into a terminal, selecting one of the modes from 2.) then giving the cmd startx)

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •