Results 1 to 4 of 4

Thread: Calibri font rendering messy

  1. #1

    Default Calibri font rendering messy

    Since I've been running systems with OpenSUSE the last 3 years I've noticed that when I come across websites in Firefox that use the Calibri font I have various letters (usually small "t" "f" and "i") stand out bold. Does anyone else also have this issue? What's the problem?

    For example, this page is rather ugly: https://blogs.apache.org/foundation/...er_to_the_open

    I have the fetchmsttfonts package installed, and currently within LibreOffice I can't replicate the problem with the Calibri font. If I strip out the required font style on a webpage using the Firefox Inspector the font is fine.

    I've found this article, which seems to say there is, or was or in Gentoo, a Cairo issue with Firefox: X.Org/Fonts - Gentoo Linux Wiki Is this related?

    I have freefont2 subpixel hinting turned on in my KDE desktop also.

  2. #2

    Default Re: Calibri font rendering messy

    Here is a screenshot of what I find when viewing the font through a browser.

    SUSE Paste

  3. #3

    Default Re: Calibri font rendering messy

    I had the same problem on my OpenSuse 11.4 with MUZlocker repository installed.
    The solution was posted on Fedora forum:
    FedoraForum.org - Can't Get Good Hinting on Calibri (or other MS Cleartype fonts)

    You just add this block to your $HOME/.fonts.conf file:

    <match target="font" >
    <edit name="embeddedbitmap" mode="assign">
    <bool>false</bool>
    </edit>
    </match>

    and Calibri font is rendered properly.

  4. #4

    Default Re: Calibri font rendering messy

    I have not been able to get this to work, but I'll keep trying. What font hinting settings are you on?

    Is this something that you know has been tagged for a fix in OpenSUSE or upstream?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •