Page 8 of 10 FirstFirst ... 678910 LastLast
Results 71 to 80 of 92

Thread: How do I install the proprietary Radeon Catalyst driver?

  1. #71

    Default Re: How do I install the proprietary Radeon Catalyst driver?

    Quote Originally Posted by 6tr6tr View Post
    BTW, just to double check (because I've now learned not to assume anything), but I don't need to run your install script, right?
    No. But you should update it (if you installed it from repo). So, assuming you gave the repo the alias "PTA":

    Code:
    su -l
    zypper refresh -r PTA
    zypper update atiupgrade
    If you type atiupgrade (as root), it will tell you that the latest Catalyst version is already installed. Do not continue! When a newer version of Catalyst is available, atiupgrade will offer to install it (unless ATI changed the name or the path or something on its website). You have to check from time to time by typing atiupgrade. It's not a daemon. Notice that you don't have to install the latest ATI driver if you are happy with the one you have now. I do update Catalyst because I maintain this script. Otherwise I would not.

  2. #72

    Default Re: How do I install the proprietary Radeon Catalyst driver?

    Quote Originally Posted by please_try_again View Post
    Coul you please try that:


    • delete the line you just added in /etc/ld.so.conf
    • copy/paste the following code and save as /etc/ld.so.conf.d/ati-fglrx.conf
      Code:
      # created by atiupgrade - Tue Jan  3 13:36:31 PST 2012
      # delete this file when it's not needed anymmore
      /usr/X11R6/lib64
      /usr/X11R6/lib
    • run these commands:
      Code:
      /sbin/ldconfig
      /usr/lib64/fglrx/switchlibglx amd
      /usr/lib64/fglrx/switchlibGL amd
    • reboot


    * everything as root of course.
    You guys rock!

    I ran all the commands you suggested 6tr6tr to try and they all gave the same result to me (no direct rendering, etc). I got a HD 6850 which should be fully supported by the driver, so I guess this happens to every ATI user. But hey, your method worked please_try_again, thank you both! Direct rendering and all desptop effects (including thumbnails) work flawlessly now. Awesome community here indeed

  3. #73
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,769
    Blog Entries
    1

    Default Re: How do I install the proprietary Radeon Catalyst driver?

    Well done with resolving the issue concerning the library paths in /etc/ld.so.conf guys! I guess this info should be fed back into the bug report.

  4. #74
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,575
    Blog Entries
    38

    Default Re: How do I install the proprietary Radeon Catalyst driver?

    Quote Originally Posted by deano_ferrari View Post
    Well done with resolving the issue concerning the library paths in /etc/ld.so.conf guys! I guess this info should be fed back into the bug report.
    Agree, this is pretty neat.

    My thoughts exactly re: are there any open bug reports on openSUSE-12.1 where we can feed this information into ?

  5. #75

    Default Re: How do I install the proprietary Radeon Catalyst driver?

    Quote Originally Posted by oldcpu View Post
    My thoughts exactly re: are there any open bug reports on openSUSE-12.1 where we can feed this information into ?
    I have no idea. If you add /usr/X11R6/lib64 and /usr/X11R6/lib on a 64bit system or just /usr/X11R6/lib on a 32bit system at the top of /etc/ld.so.conf, it would fix the problem. However they might have had a good reason for removing these paths, which were there in previous releases. Nvidia (from repo) includes the file /etc/ld.so.conf.d/nvidia-gfxG02.conf with following content:

    Code:
    /usr/X11R6/lib64
    /usr/X11R6/lib
    It works too. People who install nvidia "the hard way" should make sure that they have this file or any file here that includes these paths. Otherwise they will run into the same problems.

    I decided to create /etc/ld.so.conf.d/ati-fglrx.conf to do the same for ATI rather than modifying /etc/ld.so.conf. They are some info in /usr/share/doc/packages/fglrx/README.SuSE about what they did in the past. It's not long. I can paste it here:


    ATI fglrx driver configuration (including 3D support)
    -----------------------------------------------------

    Switch to runlevel 3 ("init 3") and use the following command as user
    "root" to configure the ATI fglrx driver (including 3D support).

    sax2 -r -m 0=fglrx

    There's no need to try to enable 3D support via SaX2. It's already
    enabled automatically when SaX2 is starting.

    Known Issues:
    - driver only supports 24bit color depth
    - enabling of 3D support through SaX2 does not work (see above)


    Using ATI GL library / GLX 1.3 API
    ----------------------------------

    Some OpenGL applications might already require OpenGL extensions,
    which are only available in the GLX 1.3 API, whereas the standard
    OpenGL library only provides the GLX 1.2 API. Therefore ATI provides
    an OpenGL library, which adds some of the GLX 1.3 extensions. If you
    want to make use of this library with a program called "foobar", just
    do the following:

    IA32:

    LD_LIBRARY_PATH=/usr/lib/fglrx/lib:$LD_LIBRARY_PATH foobar

    AMD64:

    LD_LIBRARY_PATH=/usr/lib64/fglrx/lib:/usr/lib/fglrx/lib:$LD_LIBRARY_PATH foobar


    Update on ATI GL library
    ------------------------

    Since release 8.08/8.8.25 the ATI driver no longer works together
    (hardware accelerated) with the standard OpenGL library. Therefore
    LD_LIBRARY_PATH is now set to

    /usr/lib/fglrx/lib:$LD_LIBRARY_PATH (IA32)
    /usr/lib64/fglrx/lib:/usr/lib/fglrx/lib:$LD_LIBRARY_PATH (AMD64)

    by default (by specifying this in /etc/profile.d/fglrx.{sh,csh}).

    Unfortunately the use of LD_LIBRARY_PATH does not work for
    setuid/setgid binaries (e.g. chromium/trackballs) because of obvious
    security reasons. If you rely on such programs you might consider to
    add "/usr/lib/fglrx/lib" (and "/usr/lib64/fglrx/lib" on AMD64) to
    your /etc/ld.so.conf and call "ldconfig" right after this. Make sure
    you insert it before /usr/lib and /usr/lib64 on AMD64.

    Update on ATI GL library (2)
    ----------------------------
    Using LD_LIBRARY_PATH is no longer required since the ATI GL library
    is now installed into /usr/X11R6/lib (and /usr/X11R6/lib64 on x86_64),
    which is preferred over Mesa's libGL in /usr/lib (and /usr/lib64 on
    x86_64).

    License Terms and Conditions
    ----------------------------

    See /usr/share/doc/fglrx/LICENSE.TXT.
    They just assumed that these directories were included in /etc/ld.so.conf, but they are not.

  6. #76

    Default Re: How do I install the proprietary Radeon Catalyst driver?

    Quote Originally Posted by oldcpu View Post
    Agree, this is pretty neat.

    My thoughts exactly re: are there any open bug reports on openSUSE-12.1 where we can feed this information into ?
    I replied to this one: https://bugzilla.novell.com/show_bug.cgi?id=728646 and it seemed to get a good response.

  7. #77

    Default Re: How do I install the proprietary Radeon Catalyst driver?

    Quote Originally Posted by 6tr6tr View Post
    I replied to this one: https://bugzilla.novell.com/show_bug.cgi?id=728646 and it seemed to get a good response.
    I haven't seen that bug report but came to the exact same conclusion ... and fix!
    But now, I would like Gnome users to try it.

  8. #78

    Default Re: How do I install the proprietary Radeon Catalyst driver?

    Quote Originally Posted by please_try_again View Post
    I haven't seen that bug report but came to the exact same conclusion ... and fix!
    But now, I would like Gnome users to try it.
    A gnome user responded to that bug report and says he did try it and it didn't work, but maybe you can check he did everything properly because he said he altered the folders and commands a bit.

  9. #79

    Default Re: How do I install the proprietary Radeon Catalyst driver?

    Quote Originally Posted by dycide View Post
    You guys rock!

    I ran all the commands you suggested 6tr6tr to try and they all gave the same result to me (no direct rendering, etc). I got a HD 6850 which should be fully supported by the driver, so I guess this happens to every ATI user. But hey, your method worked please_try_again, thank you both! Direct rendering and all desptop effects (including thumbnails) work flawlessly now. Awesome community here indeed
    Quote Originally Posted by please_try_again View Post
    I haven't seen that bug report but came to the exact same conclusion ... and fix!
    But now, I would like Gnome users to try it.
    I am trying it now. I may not have the same success but it is well worth testing.

    EDIT:

    I tried it and for me my situation might be different as I always see direct rendering as enabled, I just have a problem with artifacts, but this is worth pursuing. I actually think the artifact issue could somehow be related, as after applying this I rebooted and opened something known to cause problems, HoN (game) The results were the normal artifacts when it loads, but then what seemed to be a 'warming' up period between the cache? perhaps and the gpu, it took about 10 seconds to settle and I had never seen it glitch this way but it finally settled and worked as normal.

    The issue with artifacts remains. But just out of curiosity, it does seem to have something to do with a 'cache' of some kind, and this seemed to change things while not making them totally worse, they are just different. Relations?

  10. #80

    Default Re: How do I install the proprietary Radeon Catalyst driver?

    Come to think about it I did see the glitch like behavior, on Windows 7, when using I THINK 11.9 or so, when this machine first came out. It's a Hp Dm1z with the e350/6310 apu, perhaps that will help me pinpoint what catalyst version I used at that time, as they did eventually fix that problem in Windows 7.

Page 8 of 10 FirstFirst ... 678910 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •