Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Festival: can't open /dev/dsp

  1. #1

    Default Festival: can't open /dev/dsp

    I just installed festival-2.1-3.1.2.x86_64 package on my AMD64 PhenomII X3 running on an OpenSuSE 12.1. After issuing /etc/init.d/festival start as root, I executed festival --tts README as a regular user and festival complained with the following error messages:
    Code:
    ~ festival --tts README
    Linux: can't open /dev/dsp
    Linux: can't open /dev/dsp
    Linux: can't open /dev/dsp
    Linux: can't open /dev/dsp
    Linux: can't open /dev/dsp
    Linux: can't open /dev/dsp
    Linux: can't open /dev/dsp
    Linux: can't open /dev/dsp
    Linux: can't open /dev/dsp
    Linux: can't open /dev/dsp
    Here is the output from ls -l /dev/dsp:
    Code:
    ~ ls -l /dev/dsp*
    crw-rw--w- 1 root sys 14,  3 Dec 30 10:39 /dev/dsp
    crw-rw--w- 1 root sys 14, 19 Dec 30 10:39 /dev/dsp1
    Which clearly shows the devices are world writable.

    Has anyone seen this? How to resolve this issue? espeak works fine. However, the reason I installed festival is to use with FlightGear package.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Festival: can't open /dev/dsp

    On 12/30/2011 04:46 PM, mazilo wrote:
    > I just installed festival-2.1-3.1.2.x86_64


    did you install it with YaST or zypper? if with zypper, did you launch
    it from a "su -" root, or "su", or with sudo??

    any errors during install?

    --
    DD
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  3. #3

    Default Re: Festival: can't open /dev/dsp

    I installed festival + festival-devel packages from YaST2 GUI through SUDO sans errors AFAICT.

  4. #4

    Default Re: Festival: can't open /dev/dsp

    Here is one thing I forgot to mention. I had to install makedev-2.6-553.1.1.noarch package, cd into /dev, and executed MAKEDEV audio (through SUDO) to create /dev/dsp and /dev/dsp1 nodes before I installed festival and festival-devel packages. However, if I rebooted my system, both the /dev/dsp and /dev/dsp1 nodes are gone. Is there a way to make them permanent?

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,722

    Default Re: Festival: can't open /dev/dsp

    I do not know what festival is, nor what hardware device corresponds with dsp, but what I know is that all device special files in /dev are created by udev.. Creating them manualy is useless (as you have seen). udev uses the udev rules in /etc/udev/rules.d.

    Thus you may check if there are rules there for your device.
    Henk van Velden

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Festival: can't open /dev/dsp

    On 12/30/2011 06:16 PM, mazilo wrote:
    > Is there a way to make them permanent?


    this may or may not help your current problem, but _always_ remember
    that neither sudo nor su leads to a having root's environment and path...

    so, anytime you want/need to do something as root you should use "su -"

    more than you wanna read at http://tinyurl.com/ydbwssh

    sometimes it makes a difference, sometimes you can "get by" just using
    su or sudo..

    so, _try_ doing those things you mention from a terminal in which you
    became root via "su -"..

    --
    DD http://tinyurl.com/DD-Caveat
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  7. #7
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,130

    Default Re: Festival: can't open /dev/dsp

    I do not understand much of this. I have diminishing sight and rely quite a lot on tts; formerly festival, but now also jovie. For me both work "out of the box" in both 11.4 and 12.1. Festival is usefull because it does not need any other packages or a GUI, only a functional sound card and speakers.

    I install festival from "repo-oss", start the daemon ( sudo /usr/sbin/rcfestival start ), and test it with
    :~> festival --tts /etc/hosts

    I only have /dev/dsp except on one workstation with two sound cards, which also has /dev/dsp1
    Code:
     :~> l /dev/dsp*
    crw-rw----+ 1 root audio 14,  3 Dec 18 13:00 /dev/dsp
    crw-rw----+ 1 root audio 14, 19 Dec 18 13:00 /dev/dsp1
    Note that there will be no output from festival (or jovie) if another program (in my case normally having a radio channel open in chrome) has captured the sound system.

    I can only suggest that you remove all of your "modifications", uninstall, festival, check that you have a working sound system, and then reinstall festival from:
    http://download.opensuse.org/distrib...12.1/repo/oss/

  8. #8

    Default Re: Festival: can't open /dev/dsp

    Quote Originally Posted by DenverD View Post
    so, _try_ doing those things you mention from a terminal in which you
    became root via "su -"..
    I uninstalled festival + festival-devel packages using YasT2 through SUDO and use zypper install festival festival=devel without a problem. However, when I tried to execute festival --tts README as a regular user (of course after I executed /etc/init.d/festival start through SUDO), festival still gives me the same error messages as before.

  9. #9

    Default Re: Festival: can't open /dev/dsp

    Quote Originally Posted by eng-int View Post
    Note that there will be no output from festival (or jovie) if another program (in my case normally having a radio channel open in chrome) has captured the sound system.
    I had Google Chrome running. So, I terminated Google Chrome, restart festival server, and re-run festival --tts README to no avail.

    I can only suggest that you remove all of your "modifications", uninstall, festival, check that you have a working sound system, and then reinstall festival from:
    Index of /distribution/12.1/repo/oss
    I am not sure what exactly did you mean by modifications, but my OpenSuSE v12.1 was a new (fresh) installation. My previous attempt to upgrade from v11.3 to v12.1 gave me a lot of problems with GNOME.

  10. #10
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,130

    Default Re: Festival: can't open /dev/dsp

    Quote Originally Posted by mazilo View Post
    I had Google Chrome running. So, I terminated Google Chrome, restart festival server, and re-run festival --tts README to no avail. :(.
    You do have a text file README in the current directory?

    .
    I am not sure what exactly did you mean by modifications,
    I did not do any of this:
    I had to install makedev-2.6-553.1.1.noarch package, cd into /dev, and executed MAKEDEV audio (through SUDO) to create /dev/dsp and /dev/dsp1 nodes before I installed festival and festival-devel packages.
    /dev/dsp will be created if you have a sound device set up correctly, with /dev/dsp1 only if you have a second sound device.
    However, if I rebooted my system, both the /dev/dsp and /dev/dsp1 nodes are gone. Is there a way to make them permanent?
    How many sound devices do you have, and do(es) they/it work correctly before installing festival? I
    have not noticed any details about your sound chip(s) and drivers.

    my OpenSuSE v12.1 was a new (fresh) installation. My previous attempt to upgrade from v11.3 to v12.1 gave me a lot of problems with GNOME.
    I do not use GNOME. I installed a minimal X system,
    then KDE-4.7.4 from ../repositories/KDE:/Release:/47/openSUSE_12.1/
    and kernel-destop-3.1.8 from ../repositories/Kernel:/stable/standard/.
    I have RAID0 on the 12.1 test machine and had installion troubles until I "ditched" systemd. I have init=/sbin/sysvinit as a kernel option in grub. This is an AMD Phenom 9650 Quad-Core processor, ASRock K10N78FullHD-hSLI R3.0 motherboard with integrated NVidia GeForce 8200 graphics. There are no proprietary drivers installed.

    You could try disabling the systemd boot -- it seems to cause all sorts of obscure problems.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •