Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: LXDE certain fonts are tiny

  1. #1

    Question LXDE certain fonts are tiny

    Hi everybody!
    I have tried to find a solution everywhere and some things are so much more advanced than I am at some of this linux stuff. (A group of us have decided to format all our computers to linux and forget windows all together). I have learned a lot in the past few weeks but for some reason I cannot figure out why some of the fonts are so small they are hard to read. Icon and browsing fonts are fine but folders, taskbar, url address bar etc. are too small. I was having the problem with kde also but qtconfig fixed that with some tweaking of the fonts. LXDE fonts and the Suse login window still have tiny fonts. If anybody can point me in the direction of a fix I would greatly appreciate it. I also posted a screenshot if that helps Imageshack - fontsize.jpg

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,380
    Blog Entries
    1

    Default Re: LXDE certain fonts are tiny

    I'm not familiar with LXDE, so can only approach this from a generalized perspective....

    This might be due to the dpi value detected by the Xorg server. Examining /var/log/Xorg.0.log will confirm what is detected/used.

    This command will do the same
    Code:
    xdpyinfo |grep res
    Not sure if this is applicable to LXDE, but have a look at the ~/.Xdefaults file with respect to your desktop DPI settings.

    This thread may (or may not) offer some clues about your issue:

    Linux Mint Forums • View topic - "Global" font / dpi size for LXDE

  3. #3

    Default Re: LXDE certain fonts are tiny

    xdpyinfo |grep res said 44 42 after selecting the check box saying force dpi to 96 it seemed to fix everything except the tiny font in the taskbar (applications running only) and the suse login screen. Thanks for your help and Ill continue to tweak with this until I get that login screen to a larger font.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,380
    Blog Entries
    1

    Default Re: LXDE certain fonts are tiny

    Well done with that, but I'd still be interested in knowing the contents of your (hidden) .Xdefaults file.
    Code:
     cat ~/.Xdefaults
    Mine for reference
    Code:
     cat ~/.Xdefaults
    Xft.autohint: 0
    Xft.lcdfilter: lcddefault
    Xft.hintstyle: hintfull
    Xft.hinting: 1
    Xft.antialias: 1
    Xft.dpi: 96
    Xft.rgba: rgb
    If necessary, you can edit your 'Xft.dpi' value if not already set to 96 dpi. Then restart your desktop and note whether this corrects the font size.

  5. #5

    Default Re: LXDE certain fonts are tiny

    Ok this is definitely where my Linux noob emerges...

    Code:
    joosca77@linux-yfk0:~> cat ~/.Xdefaults
    cat: /home/joosca77/.Xdefaults: No such file or directory
    joosca77@linux-yfk0:~>

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,380
    Blog Entries
    1

    Default Re: LXDE certain fonts are tiny

    No, it is quite possible you don't have .Xresources or .Xdefaults present. All I know is, that for KDE at least, the dpi value does seem to be read, when X starts.

    This might be just an unnecessary distraction for you issue but I guess there is no harm in creating a '.Xdefaults' text file in your home directory with
    Code:
    Xft.dpi: 96
    FWIW, I've found some interesting info here:

    Stray Notes: Xresources or Xdefaults

    X Resource Default Configuration

    Anyway, if I'm on the wrong track here, we've both learned something.

    The other page I wanted to point you at is

    https://wiki.archlinux.org/index.php/LXDE#Font_Settings

    where it is mentioned

    Code:
    Font Settings
    
    Most users of LXDE usually try to use GTK+ programs because GTK+ is the backend for LXDE. To set the fonts, you can use lxappearance and set the main font.
    LXAppearance - LXDE.org

    I hope some of this is applicable.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: LXDE certain fonts are tiny

    Quote Originally Posted by joosca77 View Post
    xdpyinfo |grep res said 44 42 after selecting the check box saying force dpi to 96 it seemed to fix everything except the tiny font in the taskbar (applications running only) and the suse login screen. Thanks for your help and Ill continue to tweak with this until I get that login screen to a larger font.
    Did you try LXDE Control Center > OpenBox Configuration Manager > Appearance .... and select an appropriate FONT there ?

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,380
    Blog Entries
    1

    Default Re: LXDE certain fonts are tiny

    Did you try LXDE Control Center > OpenBox Configuration Manager > Appearance .... and select an appropriate FONT there ?
    Thanks for chiming in here Lee. I'm out of my depth with LXDE.....

    You're in safe hands now joosca77

  9. #9

    Default Re: LXDE certain fonts are tiny

    Thanks to both of you for trying to help me out. I did create a .Xdefaults in the home directory with Xft.dpi: 96 and rebooted to be sure it would take effect but nothing changed. And I actually already tried LXDE Control Center > OpenBox Configuration Manager > and changed all fonts to 20 with no change either. Somehow after all my messing around when I go back to kde everything in some windows is HUGE haha guess ill have to retrace my steps. I am on my way to work now but when I get home I will check out those links you posted Deano. Thanks again!

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,380
    Blog Entries
    1

    Default Re: LXDE certain fonts are tiny

    Somehow after all my messing around when I go back to kde everything in some windows is HUGE haha guess ill have to retrace my steps.
    You'll probably find that is a result of setting the dpi in .Xdefaults.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •