Results 1 to 8 of 8

Thread: My 12.1 OpenSUSE does not shut down properly

  1. #1
    Join Date
    Mar 2011
    Location
    Istanbul, Turkish Republic
    Posts
    46

    Post My 12.1 OpenSUSE does not shut down properly

    Hello,
    I have upgraded my 11.4 to 12.1 via web update. I left the machine for two days without shutting down. Today I tried to shut down the machine, it closed all applications, showed the green OpenSUSE wallpaper, and stopped working.

    Any ideas on how to completely shut down the machine? I tried failsafe boot, but it failed to show the login screen and stopped after 13 seconds.

    Thank you for your help...

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: My 12.1 OpenSUSE does not shut down properly

    On 12/28/2011 07:56 PM, bakkurt wrote:
    > Any ideas on how to completely shut down the machine?


    this is a known problem!!
    to shut down:
    -shut down all open programs
    -open terminal/konsole/xterm (your choice) and type/enter the following
    commands
    Code:
    su -
    shutdown -h now
    and give the root password when requested

    to reboot, change the -h to -r

    --
    DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
    http://tinyurl.com/DD-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  3. #3

    Default Re: My 12.1 OpenSUSE does not shut down properly

    This worked for me, I ran systemsettings and then went to System Administration > Login Screen > Shutdown tab and in the halt field entered in /sbin/shutdown. Probably not the most correct way but at least my machine shuts off now.

  4. #4
    Join Date
    Mar 2011
    Location
    Istanbul, Turkish Republic
    Posts
    46

    Thumbs up Re: My 12.1 OpenSUSE does not shut down properly

    Thank you for your help.

    Right now I am using the following command to shut down:
    Code:
    sudo /sbin/shutdown -h now
    By entering the password for root, I am able to shut down the machine. I hope that the developers see this problem.

    Happy new year to all forum members.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,789

    Default Re: My 12.1 OpenSUSE does not shut down properly

    Needs to be reported on bugzilla if you hope to have it work in the future

  6. #6
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,171

    Default Re: My 12.1 OpenSUSE does not shut down properly

    Quote Originally Posted by mikislate View Post
    This worked for me, I ran systemsettings and then went to System Administration > Login Screen > Shutdown tab and in the halt field entered in /sbin/shutdown. Probably not the most correct way but at least my machine shuts off now.
    I need
    /sbin/shutdown -h -P now
    to shutdown and poer off rather than leaving my machine powered on in the halt state.

  7. #7

    Default Re: My 12.1 OpenSUSE does not shut down properly

    It does power off, it is just the halt field.

  8. #8
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,253

    Default Re: My 12.1 OpenSUSE does not shut down properly

    Under Systemd use:


    halt -p
    My Linux Box
    OS:
    openSUSE 51.1 - Plasma 5.12.8
    OS:
    Tumbleweed Plasma 5.16.4
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •