Results 1 to 2 of 2

Thread: GnuCash config fail

  1. #1

    Default GnuCash config fail

    On 12.1, gnu cash fails to configure. The initial splash comes up and the tips window starts to open (blank) and then both disappear. On starting it in the terminal the same thing happens and I get the following output.

    -------------
    goseyne9@metameta:~> gnucash
    gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

    WARNING: no socket to connect to
    ;;; note: auto-compilation is enabled, set GUILE_AUTO_COMPILE=0
    ;;; or pass the --no-auto-compile argument to disable.
    ;;; compiling /usr/share/gnucash/guile-modules/gnucash/main.scm
    ;;; compiling /usr/share/gnucash/guile-modules/gnucash/core-utils.scm
    ;;; WARNING: compilation of /usr/share/gnucash/guile-modules/gnucash/core-utils.scm failed:
    ;;; ERROR: no code for module (sw_core_utils)
    ;;; compiling /usr/share/gnucash/guile-modules/gnucash/gnc-module.scm
    ;;; WARNING: compilation of /usr/share/gnucash/guile-modules/gnucash/gnc-module.scm failed:
    ;;; ERROR: no code for module (sw_gnc_module)
    ;;; WARNING: compilation of /usr/share/gnucash/guile-modules/gnucash/main.scm failed:
    ;;; ERROR: In procedure debug-options-interface: Unknown option name: maxdepth
    Backtrace:
    In ice-9/boot-9.scm:
    170: 12 [catch #t #<catch-closure 8346e80> ...]
    In unknown file:
    ?: 11 [catch-closure]
    In ice-9/boot-9.scm:
    2497: 10 [#<procedure 8308430 at ice-9/boot-9.scm:2485:4 (name #ptional autoload version #:key ensure)> # ...]
    2763: 9 [try-module-autoload (gnucash main) #f]
    2103: 8 [save-module-excursion #<procedure 840b9c0 at ice-9/boot-9.scm:2764:17 ()>]
    2774: 7 [#<procedure 840b9c0 at ice-9/boot-9.scm:2764:17 ()>]
    In unknown file:
    ?: 6 [primitive-load-path "gnucash/main" #f]
    In ice-9/eval.scm:
    458: 5 [#<procedure 82a06c0 at ice-9/eval.scm:452:4 (exp)> #]
    In ice-9/psyntax.scm:
    1024: 4 [chi-top-sequence ((debug-set! maxdepth 100000)) () ...]
    922: 3 [scan ((debug-set! maxdepth 100000)) () ...]
    1015: 2 [scan ((#(syntax-object debug-options # ...) (# # #))) () ...]
    In ice-9/boot-9.scm:
    2854: 1 [debug-options (show-file-name #t stack ...)]
    In unknown file:
    ?: 0 [debug-options-interface (show-file-name #t stack ...)]

    ERROR: In procedure debug-options-interface:
    ERROR: In procedure debug-options-interface: Unknown option name: maxdepth
    goseyne9@metameta:~>
    __________________________________

    The clue to the solution must be there somewhere, but I can't find it.

  2. #2
    Join Date
    Jun 2008
    Location
    "Dickes D"
    Posts
    94

    Default Re: GnuCash config fail

    Hello,

    see here: https://bugzilla.novell.com/show_bug.cgi?id=724917

    It's really a showstopper for me, i can't change to 12.1 as long this isn't solved.

    Regards, user2304.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •