Results 1 to 10 of 10

Thread: KDE effect blur: not working !

  1. #1
    Join Date
    Sep 2011
    Location
    127.0.0.1
    Posts
    44

    Default KDE effect blur: not working !

    Hi all, I'm back (not my fault this time I hope...)

    So after my issue with Yast Software manager refusing to connect to the Web, I completely deleted the OpenSUSE 12.1 install and installed over.
    KDE 4.7.2 works fine, temperature is around 50°C.... Alright.
    fglrx install... OK
    you (yast online update)...OK
    reboot.
    Customize everything (get qtCurve, my favourite icon theme, mouse skin...) OK
    Set the kwin effects... ouch.
    Kwin crashed, got to non compositing interface (KDE with disabled effects)... uh ? It's the first time this happens when I modify the effects...
    Got to the advanced settings, took a look:
    OpenGL 2 renderer
    keep miniatures only for displayed windows
    scaling method :
    - Precise --> makes Kwin & Plasma crash when looking at the grid desktop.
    - With smoothing ---> seems to work fine (but blur does not work on the windows: konsole transparency that is not part of QtCureve's settings is not blurred and - for example - Kwrite window is not blured)
    - Direct ---> makes kwin sometime crash when ticking or unticking effects (blur does not work on the windows)
    Effects are not disabled for full screen windows. THe next 3 boxes are checked.

    I saved the home directory of the last 12.1 install in which blur worked all right but it had dual screen, which I don't have anymore. (remember, dual screen caused KDE to behave strange when only one monitor was plugged in...)

    Blur is one of the effects I love and find it also usefull since my QtCurve settings use Opacity and my Konsole is translucent too.

    Well, I'll try to make Kwin crash again and post the crash log. By then, thanks to the ones who will help !
    OpenSUSE 11.4 & 12.1(not used a lot) x86_64, Intel Core i3, Acer 8942G, ATI Radeon HD5850 (1GB)
    KDE 4.7.4, kernel 3.1.6 & 3.1.0 desktop

    "Our life is the immortals' death"

  2. #2
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,021

    Default Re: KDE effect blur: not working !

    Your signature says you have Intel i3 graphics, so have I and the blur effect works fine.
    Not much help, I know, but rules out one of the more obvious potential issues.
    Günter

    Desk: Tumbleweed, KDE 5, AMD Ryzen 5 3400G, 16Gb, 120Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  3. #3
    Join Date
    Sep 2011
    Location
    127.0.0.1
    Posts
    44

    Default Re: KDE effect blur: not working !

    Quote Originally Posted by gminnerup View Post
    Your signature says you have Intel i3 graphics, so have I and the blur effect works fine.
    Not much help, I know, but rules out one of the more obvious potential issues.
    Sorry, but no. I don't use the Intel Chip but the ATI Radeon HD 5850 card... :-/ On the old install of Opensuse (both 12.1 & 11.4), blur worked great....
    OpenSUSE 11.4 & 12.1(not used a lot) x86_64, Intel Core i3, Acer 8942G, ATI Radeon HD5850 (1GB)
    KDE 4.7.4, kernel 3.1.6 & 3.1.0 desktop

    "Our life is the immortals' death"

  4. #4
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,021

    Default Re: KDE effect blur: not working !

    Oops, didn't read you signature properly (unless you edited it since). Well, that may be your problem (the ATI video card I mean)! One quick and dirty way of testing it is to disable the ATI card and use the Intel video. If the blur effect works, you know what the culprit is...
    Günter

    Desk: Tumbleweed, KDE 5, AMD Ryzen 5 3400G, 16Gb, 120Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  5. #5
    Join Date
    Sep 2011
    Location
    127.0.0.1
    Posts
    44

    Default Re: KDE effect blur: not working !

    Quote Originally Posted by gminnerup View Post
    Oops, didn't read you signature properly (unless you edited it since). Well, that may be your problem (the ATI video card I mean)! One quick and dirty way of testing it is to disable the ATI card and use the Intel video. If the blur effect works, you know what the culprit is...
    I edited signature since

    How do I disable ATI card ? - and enable it later ?
    OpenSUSE 11.4 & 12.1(not used a lot) x86_64, Intel Core i3, Acer 8942G, ATI Radeon HD5850 (1GB)
    KDE 4.7.4, kernel 3.1.6 & 3.1.0 desktop

    "Our life is the immortals' death"

  6. #6
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: KDE effect blur: not working !

    Quote Originally Posted by Moviuro View Post
    ...
    It seems that Kwin from KDE 4.7.x have some issues. For me in order to activate them i must relogin in to my OS after enabling desktop effects; i have an nvidia card.
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  7. #7
    Join Date
    Sep 2011
    Location
    127.0.0.1
    Posts
    44

    Default Re: KDE effect blur: not working !

    Well, logging out and back in after/before dis/enabling effects won't change anything...
    OpenSUSE 11.4 & 12.1(not used a lot) x86_64, Intel Core i3, Acer 8942G, ATI Radeon HD5850 (1GB)
    KDE 4.7.4, kernel 3.1.6 & 3.1.0 desktop

    "Our life is the immortals' death"

  8. #8
    Join Date
    Sep 2011
    Location
    127.0.0.1
    Posts
    44

    Default Re: KDE effect blur: not working !

    Here am I so far:

    New user can't have blur.
    On an other OpenSUSE 12.1 with KDE 4.7.4, blur does not work neither.

    Could someone with KDE 4.7.2 on OpenSUSE 12.1 have a look at his/her desktop with this QtCurve theme ?
    Code:
    [InactiveShadows]
    Size=35
    
    [KWin]
    BorderSize=3
    CustomShadows=true
    Grouping=false
    InnerBorder=0
    OpaqueBorder=false
    OuterBorder=2
    
    [Settings]
    activeTabAppearance=soft
    animatedProgress=true
    appearance=customgradient5
    bgndAppearance=darkinverted
    bgndGrad=horiz
    bgndImage=none
    bgndOpacity=60
    boldProgress=true
    borderInactiveTab=false
    borderMenuitems=false
    borderProgress=true
    borderSbarGroove=true
    borderSelection=false
    borderTab=true
    buttonEffect=shadow
    centerTabText=true
    colorMenubarMouseOver=true
    colorSelTab=0
    colorSliderMouseOver=false
    coloredMouseOver=glow
    coloredTbarMo=false
    comboBtn=none
    comboSplitter=false
    crButton=true
    crColor=none
    crHighlight=0
    crSize=15
    customAlphas=0
    customMenuNormTextColor=#000000
    customMenuSelTextColor=#000000
    customMenuTextColor=false
    customShades=1.16,1.07,0.9,0.78,0.84,0.75
    customgradient1=3d,0,1.2,0.5,1,1,1
    customgradient2=3d,0,0.9,0.5,1,1,1
    customgradient3=none,0,1.12,1,1.15
    customgradient4=shine,0,1.05,1,0.92
    customgradient5=light,0,1.04,1,0.92
    darkerBorders=false
    defBtnIndicator=glow
    dlgOpacity=60
    doubleGtkComboArrow=false
    drawStatusBarFrames=false
    dwtAppearance=agua
    dwtSettings=0
    embolden=false
    etchEntry=false
    expanderHighlight=3
    fadeLines=true
    fillProgress=true
    fillSlider=false
    flatSbarButtons=true
    focus=glow
    forceAlternateLvCols=false
    gbFactor=-3
    gbLabel=9
    glowProgress=end
    grooveAppearance=harsh
    groupBox=faded
    gtkButtonOrder=false
    gtkComboMenus=false
    gtkScrollViews=true
    handles=sunken
    hideShortcutUnderline=false
    highlightFactor=3
    highlightScrollViews=true
    highlightTab=true
    inactiveTitlebarAppearance=flat
    invertBotTab=true
    lighterPopupMenuBgnd=0
    lvAppearance=agua
    lvButton=false
    lvLines=true
    mapKdeIcons=true
    menuBgndAppearance=harsh
    menuBgndGrad=horiz
    menuBgndImage=none
    menuBgndOpacity=60
    menuDelay=225
    menuIcons=true
    menuStripe=none
    menuStripeAppearance=darkinverted
    menubarAppearance=flat
    menubarApps=VirtualBox,smplayer,amarok,arora,kcalc,kaffeine
    menubarHiding=0
    menubarMouseOver=true
    menuitemAppearance=fade
    noBgndGradientApps=
    noBgndImageApps=
    noBgndOpacityApps=dragon,smplayer,inkscape,totem,kaffeine,kscreenlocker,sonata
    noMenuBgndOpacityApps=inkscape,gtk,totem,sonata
    noMenuStripeApps=soffice.bin,gtk
    passwordChar=8263
    popupBorder=true
    progressAppearance=agua
    progressColor=origselected
    progressGrooveAppearance=gradient
    progressGrooveColor=dark
    reorderGtkButtons=false
    round=extra
    roundAllTabs=true
    roundMbTopOnly=false
    sbarBgndAppearance=flat
    scrollbarType=none
    selectionAppearance=agua
    shadeCheckRadio=none
    shadeMenubarOnlyWhenActive=false
    shadeMenubars=none
    shadePopupMenu=false
    shadeSliders=none
    shading=hsl
    sliderAppearance=agua
    sliderFill=true
    sliderStyle=r-plain
    sliderThumbs=none
    sliderWidth=11
    smallRadio=true
    sortedLv=none
    splitterHighlight=0
    splitters=none
    square=0
    statusbarApps=kde
    statusbarHiding=0
    stdBtnSizes=false
    stdSidebarButtons=false
    stripedProgress=diagonal
    stripedSbar=false
    sunkenAppearance=customgradient3
    tabAppearance=agua
    tabBgnd=3
    tabMouseOver=glow
    tbarBtnAppearance=none
    tbarBtnEffect=none
    tbarBtns=standard
    thin=0
    thinSbarGroove=false
    titlebarAlignment=center-full
    titlebarAppearance=flat
    titlebarButtonAppearance=gradient
    titlebarButtons=2117
    titlebarEffect=shadow
    titlebarIcon=title
    toolbarAppearance=flat
    toolbarBorders=none
    toolbarSeparators=sunken
    toolbarTabs=false
    tooltipAppearance=gradient
    unifyCombo=true
    unifySpin=true
    unifySpinBtns=false
    useHighlightForMenu=false
    useQtFileDialogApps=googleearth-bin
    vArrows=true
    version=1.8.8
    windowBorder=33
    windowDrag=3
    xCheck=false
    xbar=false
    If it works and blur is functional, plz tell me the size of your kwin effects libraries, thanks.
    OpenSUSE 11.4 & 12.1(not used a lot) x86_64, Intel Core i3, Acer 8942G, ATI Radeon HD5850 (1GB)
    KDE 4.7.4, kernel 3.1.6 & 3.1.0 desktop

    "Our life is the immortals' death"

  9. #9
    Join Date
    Sep 2011
    Location
    127.0.0.1
    Posts
    44

    Default Re: KDE effect blur: not working !

    Kwin just crashed after enabling Blur again :
    Code:
    Application: KWin (kwin), signal: Segmentation fault
    [Current thread is 1 (Thread 0x7f411ad0a760 (LWP 5105))]
    
    Thread 2 (Thread 0x7f4101704700 (LWP 5112)):
    #0  0x00007f4116544e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
    #1  0x00007f411936e852 in ?? () from /usr/lib64/libQtScript.so.4
    #2  0x00007f411936e889 in ?? () from /usr/lib64/libQtScript.so.4
    #3  0x00007f4116540f05 in start_thread () from /lib64/libpthread.so.0
    #4  0x00007f411a54a53d in clone () from /lib64/libc.so.6
    
    Thread 1 (Thread 0x7f411ad0a760 (LWP 5105)):
    [KCrash Handler]
    #6  0x00007f411a599c13 in __memcpy_ssse3_back () from /lib64/libc.so.6
    #7  0x00007f4117d8bd05 in ?? () from /usr/lib64/libGL.so.1
    #8  0x00007f4101b4edbf in ?? () from /usr/lib64/kde4/kwin4_effect_builtins.so
    #9  0x00007f4101b4bc05 in ?? () from /usr/lib64/kde4/kwin4_effect_builtins.so
    #10 0x00007f4101b4bd9c in ?? () from /usr/lib64/kde4/kwin4_effect_builtins.so
    #11 0x00007f4101b4be86 in effect_create_kwin4_effect_blur () from /usr/lib64/kde4/kwin4_effect_builtins.so
    #12 0x00007f411a8e9752 in ?? () from /usr/lib64/libkdeinit4_kwin.so
    #13 0x00007f411a8eaaaa in ?? () from /usr/lib64/libkdeinit4_kwin.so
    #14 0x00007f411a83eb3e in ?? () from /usr/lib64/libkdeinit4_kwin.so
    #15 0x00007f411a8407e2 in ?? () from /usr/lib64/libkdeinit4_kwin.so
    #16 0x00007f41168ca59a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
    #17 0x00007f41168cde79 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
    #18 0x00007f4115a69c34 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
    #19 0x00007f4115a6eac1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
    #20 0x00007f411a03ee36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
    #21 0x00007f41168b781c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
    #22 0x00007f41168e4398 in ?? () from /usr/lib64/libQtCore.so.4
    #23 0x00007f41168e5454 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #24 0x00007f4115b0dde8 in ?? () from /usr/lib64/libQtGui.so.4
    #25 0x00007f41168b6a22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #26 0x00007f41168b6c1f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #27 0x00007f41168bade7 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
    #28 0x00007f411a85e5f6 in kdemain () from /usr/lib64/libkdeinit4_kwin.so
    #29 0x00007f411a49223d in __libc_start_main () from /lib64/libc.so.6
    #30 0x0000000000400681 in _start ()
    Does this help...?
    OpenSUSE 11.4 & 12.1(not used a lot) x86_64, Intel Core i3, Acer 8942G, ATI Radeon HD5850 (1GB)
    KDE 4.7.4, kernel 3.1.6 & 3.1.0 desktop

    "Our life is the immortals' death"

  10. #10
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,021

    Default Re: KDE effect blur: not working !

    Quote Originally Posted by Moviuro View Post
    How do I disable ATI card ? - and enable it later ?
    You blacklist the card using modprobe - sorry, can't remember the exact syntax as I haven't done it for a while but google (and probably the forum search) will be your friend... You'll obviously also need the Intel driver to confirm that the Kwin blur effect works fine with the i3 graphics.
    Günter

    Desk: Tumbleweed, KDE 5, AMD Ryzen 5 3400G, 16Gb, 120Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •