Results 1 to 6 of 6

Thread: Cannot install VirtualBox 4 with openSuSE 12.1 libqtgui.so.4 is missing

  1. #1

    Default Cannot install VirtualBox 4 with openSuSE 12.1 libqtgui.so.4 is missing

    Good day,

    Running,
    openSUSE 12.1 (x86_64)
    VERSION = 12.1
    CODENAME = Asparagus

    I try install Virtualbox 4, with any result,
    Appear this message:
    libQtGui.so.4 is needed by VirtualBox-4.1-4.1.8_75467_openSUSE114-1.i586

    Thanks for your time

    Regards,
    Juan L. Mera

  2. #2

    Default Re: Cannot install VirtualBox 4 with openSuSE 12.1 libqtgui.so.4 is missing

    Sounds like you might not have qt and/or libqt installed

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,869

    Default Re: Cannot install VirtualBox 4 with openSuSE 12.1 libqtgui.so.4 is missing

    There is a special subforum for "Virtualization". You might find better gurus there.
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Cannot install VirtualBox 4 with openSuSE 12.1 libqtgui.so.4 is missing

    Quote Originally Posted by hcvv View Post
    There is a special subforum for "Virtualization". You might find better gurus there.
    +1

    But I'll say this to the OP: install from the VirtualBox repo instead from a downloaded RPM, that will handle dependencies automatically.

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Cannot install VirtualBox 4 with openSuSE 12.1 libqtgui.so.4 is missing

    Moving thread to the virtualization forum: Virtualization

    And -- I agree with the earlier advice you got. One quick way to get it sorted would be to add the Sun/Oracle repo as a repository in Yast and then use the yast software GUI to select and install VirtualBox. That should automatically attach the required dependent RPMs (like QT GUI). If you want to do that, here is the address of the repo:
    Code:
    Oracle VirtualBox openSUSE        http://download.virtualbox.org/virtualbox/rpm/opensuse/11.4/
    Despite it says 11.4, it is correct for 12.1 too.

    FFI: http://forums.opensuse.org/content/5...umbleweed.html
    Last edited by swerdna; 24-Dec-2011 at 14:31.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Cannot install VirtualBox 4 with openSuSE 12.1 libqtgui.so.4 is missing

    Hi Ken, didn't notice your post -- sorry.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •