Results 1 to 2 of 2

Thread: Installing Google Go language repeatedly fails

  1. #1

    Default Installing Google Go language repeatedly fails

    Since I got openSUSE 12.1, I've tried installing the Go language many times now, the usual way with YaST.
    The download always stalls at 98%, either with KDE or with Gnome.

    Did I do anything wrong?
    Has anyone successfully installed Go on openSUSE 12.1?

    Thank you for any hints
    and Merry Christmas to everyone!

  2. #2
    Join Date
    Jun 2008
    Earth - Denmark

    Default Re: Installing Google Go language repeatedly fails

    On 12/24/2011 04:46 AM, Franz57 wrote:
    > Since I got openSUSE 12.1, I've tried installing the Go language many
    > times now, the usual way with YaST.

    i have no idea why your download stalls...but, there are many previous
    threads on that subject, and as far as i recall, lots on stalling at
    98%...but, before you look for those:

    i looked at Google's instructions on how to get started with Go and
    found *no* mention of using YaST or any other distro's package manager..

    so, i decided to see what would happen if i exactly followed their
    instructions (which don't mention YaST) here:

    if you don't already have all the programming stuff, just open YaST >
    Software Management, switch from the "Search" tab to the "Patterns" tab,
    scroll down to the Development pattern, and single left click (to
    install) "Base Development" and "C/C++ Development" then click the
    "Accept" button....that should give you all the bits they talk about
    (GCC, C libs, parser generator Bison, GNU make and awk.

    now, since openSUSE has no "easy_install" command i used instead, in a
    root terminal
    zypper in mercurial
    then, i changed back to a normal, non-root user and just followed the
    instructions (that is do NOT run the hg command as root)...and
    everything worked as expected here.....took a while to do all the
    compiling and testing, but after a wait (a LONG wait, some it looked
    like nothing was BE patient) i saw:
    Installed Go for linux/386 in /home/denverd/temp/go.
    Installed commands in /home/denverd/temp/go/bin.
    *** You need to add /home/denverd/temp/go/bin to your $PATH. ***
    The compiler is 8g.
    so, just follow the instructions and if you get to a part that doesn't
    work, ask! like you might have first asked:

    When following <> to install Google's
    Go programming language i try this

    sudo easy_install mercurial
    and i see this:
    denverd@linux-os114:~> sudo easy_install mercurial
    root's password:
    sudo: easy_install: command not found
    what do i do now???

    now, having said all of that, i also wanna say:

    -=WELCOME=- new poster, but in the future please be more careful where
    you post your questions! Google's Go programming language is not an
    "application", so your question should have been placed in the
    Programming/Scripting forum here, that way
    the _real_ programmers have a chance to help you..

    so, take some time to familiarize yourself with the structure of our
    forums, here: and let us know how you get on
    with Go..

    openSUSE®, the "German Engineered Automobiles" of operating systems!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts