Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Privoxy will not run during system start up.

  1. #1

    Default Privoxy will not run during system start up.

    I added it to the start up program list, you can see it try to start it during boot if you hit the ESC key, but it says failed. I did Tor the same way and that one works. Permissions problem? Once the system is up and running, I have to go into terminal as root user and then enter privoxy. Then it works.

    Thanks

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: Privoxy will not run during system start up.

    On Tue, 20 Dec 2011 22:36:03 +0000, Doug08 wrote:

    > I added it to the start up program list, you can see it try to start it
    > during boot if you hit the ESC key, but it says failed. I did Tor the
    > same way and that one works. Permissions problem? Once the system is up
    > and running, I have to go into terminal as root user and then enter
    > privoxy. Then it works.
    >
    > Thanks


    It would be helpful for you to indicate what version of openSUSE you're
    using and what steps you took to add it to the startup program list. (ie,
    system-wide or when you login - for example - and if the latter, which
    desktop you're using would be very helpful as well).

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3

    Default Re: Privoxy will not run during system start up.

    Your right, not enough info. Sorry. I did it a long time ago, just tired of having to start it in terminal. I'm pretty sure I edited a start up file with kwrite.

    Dell Vostro 1500

    Linux 2.6.34.10-0.4-desktop i686
    Current user: doug@linux-rvej.site
    System: openSUSE 11.3 (i586)
    KDE: 4.4.4 (KDE 4.4.4) "release 3"

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: Privoxy will not run during system start up.

    On Wed, 21 Dec 2011 03:06:02 +0000, Doug08 wrote:

    > Your right, not enough info. Sorry. I did it a long time ago, just tired
    > of having to start it in terminal. I'm pretty sure I edited a start up
    > file with kwrite.
    >
    > Dell Vostro 1500
    >
    > Linux 2.6.34.10-0.4-desktop i686 Current user: doug@linux-rvej.site
    > System: openSUSE 11.3 (i586)
    > KDE: 4.4.4 (KDE 4.4.4) "release 3"


    So was this a system startup that you're trying to use, or a login
    startup?

    If it's a system startup, what is in your init script? (be sure to post
    it in code tags so the formatting isn't lost)

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5

    Default Re: Privoxy will not run during system start up.

    System start up.

    Here is the /etc/rc.d/privoxyd file:

    #! /bin/sh
    # ********************************************************************
    #
    # File : $Source: /cvsroot/ijbswa/current/privoxy.init.suse,v $
    #
    # Purpose : This shell script takes care of starting and stopping
    # privoxy.
    #
    # Copyright : Written by and Copyright (C) 2001 the SourceForge
    # Privoxy team. Privoxy - Home Page
    #
    # Based on the Internet Junkbuster originally written
    # by and Copyright (C) 1997 Anonymous Coders and
    # Junkbusters Corporation. Junkbusters Shutdown
    #
    # This program is free software; you can redistribute it
    # and/or modify it under the terms of the GNU General
    # Public License as published by the Free Software
    # Foundation; either version 2 of the License, or (at
    # your option) any later version.
    #
    # This program is distributed in the hope that it will
    # be useful, but WITHOUT ANY WARRANTY; without even the
    # implied warranty of MERCHANTABILITY or FITNESS FOR A
    # PARTICULAR PURPOSE. See the GNU General Public
    # License for more details.
    #
    # The GNU General Public License should be included with
    # this file. If not, you can view it at
    # The GNU General Public License v3.0 - GNU Project - Free Software Foundation (FSF)
    # or write to the Free Software Foundation, Inc., 59
    # Temple Place - Suite 330, Boston, MA 02111-1307, USA.
    #
    # ********************************************************************/
    ### BEGIN INIT INFO
    # Provides: privoxy
    # Required-Start: $network $syslog $remote_fs
    # Required-Stop: $remote_fs $local_fs
    # Default-Start: 3 5
    # Default-Stop: 0 1 2 6
    # Short-Description: Starts Privoxy
    # Description: Starts Privoxy
    ### END INIT INFO

    . /etc/rc.status
    rc_reset

    case "$1" in
    start)
    echo -n "Starting Privoxy"
    if [ ! -f /var/run/privoxy.pid ] || ! kill -0 `cat /var/run/privoxy.pid` 2> /dev/null; then
    # set up chroot dir
    for i in /etc/{resolv.conf,host.conf,hosts,localtime}; do
    cp -p $i /var/lib/privoxy/etc/ &>/dev/null \
    || { echo "...$0:$LINENO: could not copy $i to chroot jail"; rc_failed; rc_status -v1; exit 6; }
    done
    libdir=/$(basename $(echo /var/lib/privoxy/lib*))
    for i in /$libdir/{libresolv.so.2,libnss_dns{,6}.so.2}; do
    if [ -s $i ]; then
    cp -p $i /var/lib/privoxy/$libdir/ \
    || { echo "...$0:$LINENO: could not copy $i to chroot jail"; rc_failed; rc_status -v1; exit 6; }
    fi
    done
    # started process in privoxy wait 1 sec and then check forked process (e.g child died due to missing config files),
    # so we need a time (-T 1 option) while forked process checks config file
    # better options for startproc could be -w, but this options is available only since 11.2
    startproc -T 1 /usr/sbin/privoxy --user privoxy.privoxy --pidfile /var/run/privoxy.pid --chroot /etc/config 2> /dev/null
    else
    false
    fi
    rc_status -v
    ;;
    stop)
    echo -n "Shutting down Privoxy"
    killproc -TERM /usr/sbin/privoxy && rm -f /var/run/privoxy.pid

    # remove libraries from the chroot jail, just so they are not left over
    # if the server is deinstalled
    rm -f /var/lib/privoxy/lib*/*

    rc_status -v
    ;;
    reload)
    echo -n "Reloading Privoxy"
    kill -HUP `cat /var/run/privoxy.pid`
    rc_status -v
    ;;
    try-restart)
    $0 status >/dev/null && $0 restart
    rc_status
    ;;
    restart)
    $0 stop
    $0 start
    rc_status
    ;;
    status)
    echo -n "Checking for Privoxy"
    checkproc /usr/sbin/privoxy
    rc_status -v
    ;;
    *)
    echo "Usage: $0 {start|restart|reload|status|stop}"
    exit 1
    esac

    rc_exit

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: Privoxy will not run during system start up.

    On Thu, 22 Dec 2011 00:06:03 +0000, Doug08 wrote:

    > System start up.
    >
    > Here is the /etc/rc.d/privoxyd file:


    At a glance that looks OK to me.

    What runlevels do you have it enabled for (in the YaST runlevel editor -
    switch to 'expert' mode).

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  7. #7

    Default Re: Privoxy will not run during system start up.

    Runlevel show "Yes" with an asterisk next to it in simple mode, but in expert mode it says "No" with run levels 3 & 5. How can it show yes and no? Obviously the expert mode is telling me the truth, not the simple mode.

    Thanks

  8. #8
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: Privoxy will not run during system start up.

    On Thu, 22 Dec 2011 15:06:02 +0000, Doug08 wrote:

    > Runlevel show "Yes" with an asterisk next to it in simple mode, but in
    > expert mode it says "No" with run levels 3 & 5. How can it show yes and
    > no? Obviously the expert mode is telling me the truth, not the simple
    > mode.


    Hmmm, that's odd, certainly.

    I'm thinking that perhaps the network service isn't started up when it
    gets to that point, though the dependencies seem to be set up properly.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  9. #9

    Default Re: Privoxy will not run during system start up.

    This happened after I did an upgrade from Suse 11.1 to 11.3. It always worked before the upgrade. Must be some file I can edit that will allow privoxy to activate as root before the desktop screen shows up.

    Thanks

  10. #10

    Default Re: Privoxy will not run during system start up.

    I have tor.desktop in the .kde4/Autostart folder to run once the desktop logs on. It works just fine. Tor is located in /usr/bin which is root root 755. I added privoxy.desktop(which is also root root 755) to the autostart folder with tor.....I get confirmation that both commands have been executed. I checked to see if Privoxy is running, and it is not. I have to go into terminal as SU, then it runs. Both programs are root programs. One runs, one does not. Weird. I think it is a privoxy file issue.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •