Results 1 to 2 of 2

Thread: condor 7.6.4 installation

  1. #1
    Join Date
    Dec 2011
    Location
    vienna/Austria
    Posts
    15

    Default condor 7.6.4 installation

    I'm trying to install condor 7.6.4 (Condor Project Homepage) on openSUSE machines.
    There are no rpm files for suse so I used the redhat ones.

    When I do a
    > yast2 -i /path/to/condor/condor-7.6.4-1.rhel6.1.x86_64.rpm

    I get the following error messages:
    on 11.3 and 12.1 machines:
    "nothing provides perl >= 1:5.0 needed by condor-7.6.4-1.x86_64"

    on 11.4 machines:
    "nothing provides libxml2.so.2(LIBXML2_2.4.30)(64bit) needed by condor-7.6.4-1.x86_64"

    I found the following installed package infos:
    11.3: libxml2-2.7.7-4.7.1 provides libxml2.so.2()(64bit)
    11.4: libxml2-2.7.8-16.17.1 provides libxml2.so.2()(64bit)
    12.1: libxml2-2.7.8+git20110708-3.1.2.x86_64.rpm provides libxml2.so.2(LIBXML2_2.4.30)(64bit)

    The installed perl is
    11.3: perl-5.12.1-2.7.1.x86-64 and perl-32bit-5.12.1-2.7.1.x86-64
    11.4: perl-5.12.3-11.14.1.x86-64 and perl-32bit-5.12.3-11.14.1.x86-64
    12.1: perl-5.14.2-1.9-x86-64 and perl-5.14.2-1.9-x86-64

    How can I resolve the dependencies and still use the rpm for installing?
    (Building from source is something I never did up to now)

  2. #2
    Join Date
    Nov 2009
    Location
    Uruguay
    Posts
    737

    Default Re: condor 7.6.4 installation

    Redhat rpm are for Red Hat systems, not for openSUSE, you may broke
    your systems, I sugest you to compile it from source

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •